Closed

Sapphire 6570 HD 2gb drivers doesn't install correctly 1

Hello, I got sapphire 6570 HD 2gb like 3 days ago. The fan spins, but the drivers wont install correctly. I got Athlon x3, some random motherboard and 500w power and my OS is Windows 7 home premium x64. Any idea how to fix it? asd
21 answers Last reply
More about sapphire 6570 drivers doesn install correctly
  1. Go to AMD and get the latest version for your use. See below:

    http://support.amd.com/us/Pages/AMDSupportHub.aspx

    Also, make sure that Windows if fully up to date as well. Catalyst requires certain updates (.Net for example) be in place for the drivers to work properly.

    If this doesn't help, then please more fully describe the problem you are having. Please be as specific as possible.

    Good luck!
  2. There is no updates left in "Windows Update" thingy, I updated .net yesterday, I got SP1 and I have re-installed drivers million of times. The installation ends @ like 50-65%, when it's trying to install "Catalyst Control Center" :/
  3. This is true with the 12.8 version of drivers/Catalyst as well?
  4. Mhm, I tried from sapphiretech and amd site + CD. Nothing works :/
  5. Go here and get Driver Sweeper:

    http://www.guru3d.com/category/driversweeper/

    Run the app and remove all previous AMD/ATI drivers. Then restart the system and install the current 12.8 drivers (from the website I sent you earlier). It would be a good idea to have these drivers on your desktop before you run Driver Sweeper.

    Let us know if this helps.
  6. "Attention - Guru3D Driver Sweeper has been discontinued as such you will not find any download links here any longer."


    I got Driver Fusion, I have deleted all GPU drivers and installed 12.8 drivers. Didn't work.
  7. Did it stop at the same place? What video card were you using before you installed the HD6570?
  8. It stops at same place always, I had GeForce 315 + 230W PSU, but I changed to 500W
  9. I uninstalled ALL Display/GPU drivers, still doesn't work. Lemme check if they are connected enough good.
  10. Since the HD6570 doesn't require external power, changing the PSU shouldn't matter. Verify that both the 24-pin and 4/8-pin power connectors are properly (firmly) attached to the motherboard. Also, did you uninstall the previous Nvidia drivers?
  11. Check that your video card is properly installed (physically) as well.
  12. Everything is alright. Still not fixed, damn it :/
  13. This will sound odd, but give it a try. Create a new admin user on your system.

    Reboot the system and log-in to the new administrator account. Then try to install Catalyst 12.8.

    There may be an issue with you user profile preventing a successful install.
  14. Didn't work. :/
  15. I would strongly consider reloading the system from scratch at this point. I suspect some sort of registry corruption is preventing the install from successfully completing.

    Have you tried a manual install of the driver (without Catalyst)? To do that, open Device Manager, and click on Display Adapter, then right click on the HD6570. Select properties and then update driver. When asked for the driver location (go the manual route) point it to this folder:

    C:\AMD\Support\12-8_vista_win7_win8_64_dd_ccc_whql\Packages\Drivers\Display\W86A_INF

    This should allow the system to install the driver without using Catalyst.
  16. There is no "HD6570" in the device manager
  17. Srry for double post, but here is link to video of my computer https://www.youtube.com/watch?v=XOeredskcXo
  18. Then use the display adapter that shows up in Device Manager.... Nice (?) music.
  19. FINALLY! THank you so much! It works now :) tytytytytyty
  20. You are most welcome. Good luck!
  21. This topic has been closed by Mousemonkey
Ask a new question

Read More

Radeon Drivers Sapphire HD Graphics