Sapphire 5770 no display no boot

My computer has been recently crashing on me ALOT. At first, I thought it might have been the ram or the power supply. Sometimes I get the blue screen and sometimes I don't. However, last week, when my compute crashed, I've noticed that the 3 green LED'S at the top aren't on and at the bottom of the graphics card, a red LED remains on until I restart my computer. As of now, I got my computer booting but only 2 of the LED's are green, the last one is blinking. What does this mean? :o
5 answers Last reply
More about sapphire 5770 display boot
  1. U could try re-seat the card...

    Btw u should list your hardware (CPU, mobo, gpu, psu, os, etc...)
  2. Whoops sorry, they are....


    CPU: AMD Phenom II X4 955
    Motherboard: Gigabyte GA-870A-UD3
    Power Supply: SeaSonic S12II 620 Bronze 620W
    GPU: Saphire HD5770
    RAM: F3-12800CL9D-4GBNQ , 2GB Corsair
  3. very balanced build....

    so re-seating the card had any effect?
  4. Hmm re-seating helped for a bit, but it crashed after a while and got the red lights again. But as of now, it hasn't crashed yet.
  5. So the crash become much less after re-seat...
    Try to clean the connector with pencil eraser. and the slot with soft brush.... (also clean the dust bunny in the card)

    Try to reinstall 12.8 the driver or roll back to 12.7.... (12.7 beta is more stable for me)

    tips:
    to re- / clean install vga driver. u could go to VGA mode (low resolution mode in win7). uninstall and reboot (still in vga mode). install the driver (still in vga mode)...

    edit: if it still crash we will focus to card/psu/mobo failure...
Ask a new question

Read More

Graphics Cards Computer LED Monitor Graphics