Just build my new PC but it keeps beeping at me when I try to turn

Hello,
When I try to turn on my new build it just beeps and the fans including the heat-sink fan spin a Lil bit and just doesn't turn on.

Mobo : Intel DH67CL Desktop Board
CPU: Intel i5 3750K Unlocked & Unleashed LGA 1155
Heatsink: included with cpu
PSU: POWORK Model # PW-650
Graphics Card: ATI Radeon HD 4350
Memory:Super Talent 8GB DDR3 1333 MHz PC3-10600
HDD: 160GB Segate
1TB Segate

Any help would be appreciated.
2 answers Last reply
More about just build beeping turn
  1. Make sure all of your components are seated correctly, and all the power cables are plugged in. Beeps like that are sometimes an indicator that no ram is plugged in, so i would start there. Your motherboard manual should say something about beeping, maybe it even has a beep code to tell you what the problem is.

    I ahve also never heard of that PSU brand, so that could very well be a problem as well. With Off brands like that 650w doesnt always mean 650 watts.
  2. try all of this
    1) Update bios(if possible)
    http://www.tomshardware.com/forum/308518-30-update-bios
    2) Clear Cmos, do this if you cant start or have messed with the bios (don’t forget to unplug the computer from the wall and let it sit for few minutes, if you don’t have a jumper than remove the battery make sure the computer is unplugged and let it for about10 minutes before putting the battery back in)
    http://www.youtube.com/watch?v=Pdp_L5IxaNI
    3) Check your psu
    http://www.youtube.com/watch?v=5FWXgQSokF4
    4) Make sure your computer is hooked up correctly
    http://www.tomshardware.com/forum/261145-31-perform-steps-posting-post-boot-video-problems
    5) Run memtest(if possible)
    http://www.memtest.org/
    6) Run Burnintest (if possible)
    http://www.passmark.com/download/bit_download.htm
    7) If all else fails then try a gpu, Ram, or psu from another computer
    Hope this helped! :D

    and also try this it will tell you "the code"
    http://www.computerhope.com/beep.htm

    and yeah get it seated this can happen when the gpu is not seated correctly or some other component is not
Ask a new question

Read More

Homebuilt Systems