Sign in with
Sign up | Sign in
Your question

Need some input before I RMA another component.

Last response: in Graphics & Displays
Share
September 11, 2012 10:29:56 PM

Brand new build, Gigabyte 7970 Ghz Edition had coil whine when under load. The worst is during opening animations (when I play Darksiders II the initial THQ logo animation must get like 1000+ FPS because the coil whine is extremely loud) or game menus.

I RMA'd this 7970 after confirming that the coil whine was coming from the GPU (swapped out PSU's, put my card in brother's computer and coil whine persisted)

After receiving my new 7970 from Newegg, I'm still getting coil whine. At this point I'm 99% sure it's being caused by my mobo (AsRock Z77 Extreme4). Not that the sound is coming from the mobo, but that it's an interaction of my GPU and mobo together.

I figure this is the case because even after putting two different GPUs in my computer, I still get very loud coil whine at the intro of Darksiders II and other similar high FPS games.

I realize coil whine isn't detrimental to system performance or component longevity, but it's kind of disappointing spending good money on a brand new system and having this issue. Should I RMA my motherboard? (I purchased it from NCIX, and it's still within 14 days I believe or whatever the return date is). I really just want this coil whine issue solved. :( 

EDIT: Forgot to mention I've ran tests without a GPU, just using the Intel HD 4000/Ivy Bridge graphics and there is absolutely no coil whine.

Relevant specs:

Motherboard: AsRock Z77 Extreme4

GPU: Gigabyte 7970 GHz Edition (http://www.newegg.ca/Product/Product.aspx?Item=N82E1681...)

PSU: Corsair HX650

More about : input rma component

September 12, 2012 1:07:25 AM

Bump.
!