Sign in with
Sign up | Sign in
Your question
Solved

Radeon hd7770 freezes on boot....

Last response: in Graphics & Displays
Share
September 11, 2012 11:00:01 PM

Hi guys,
I just installed a brand new HIS Radeon HD7770. I installed the Latest AMD CCC, V 12.8 for the card. Once the system rebooted freezes and restarts, every time I boot..... I reset my bios to stock settings before I installed, and my bios and chipset drivers are the latest versions.... my RAM may still be OC'd slightly (IDK if that could cause the issue.... the system was running gust fine with a 3.8OC and my old HD4770 in it...
here's some specs, I'm hoping one of you has an idea for me.

MOBO: Asus Sabertooth 990FX
CPU: AMD PII x4 965BE 3.4ghz
RAM: 12gb- 8gb(2x4g) crucial DDR3 1333
4gb(2x2g) OCZ DDR3 1333
PSU: OCZ 700W
Heat is not an issue...
-Antec DF85.
- Spire Eclipse II with 2 120mm Ultra Kaze Fans.
-In a temp controlled room that doesn't go over 70F.
September 11, 2012 11:03:48 PM

make sure you dont need to have a bridge card installed in a secondary pcie slot, can cause alot of issues

these typically come with the mobo and are just a wafer like chip you pop in the first slot (depending on the mobo)
m
0
l
September 11, 2012 11:19:49 PM

I know the "Wafer" you're talking about. Haven't seen one of those in a while... I'll have to check my Box'O'Random parts... Niether the MOBO or the GPU came with one. Typicallly a sign it's not needed, no?
I'm going to make sure my ram is at stock speed when I get home (at work baby sitting servers till midnight) that's the only thing not at standard settings. I don't think that should effect the GPU though.... never effected the old 4770....
I've never had ATI/AMD CCC not work right :( 
m
0
l
Related resources

Best solution

September 12, 2012 3:02:35 PM

well ive had plenty of them that have given me problems, so I cant say for certain what causes the issues, having problems with my own amd cards atm
Share
September 12, 2012 9:47:10 PM

:bounce: 

Fixed it. I went in in safe mode and removed all AMD Graphics driver files. It wouldn't let me just uninstall..... I then reseated the card and reinstalled the latest AMD drivers (v12.8). It works just fine, and I was able to restore my OC settings without any issue. The physical layer strikes again..... :lol: 

CG_Gamer- Hopefully your fix is as easy.....



(New to the forum. Not sure how to post this as solved......)
m
0
l
September 13, 2012 2:30:25 AM

Best answer selected by Morbious81.
m
0
l
!