Computer crashing

Hi there, i have a new computer just built last week with
8GB of ram, 120GB vertex 2 2.5 SSD, 1TB HDD, silverstone sst 600w, 23" dell st23 monitor, ASUS p8z77-v-lx intel z77 mainboard and a ATI HD 7870 2GB GHZ edition.

i've installed guildwars2 and l4d2 on my system but after a while of playing it, my computer crashes. the sounds will play but when i press another button, it repeats itself.

The startup of my computer is approx 20 seconds. during idle the temp is ~35C, and during load, its ~50 - 60C. Also, i haven't been surfing the net or downloading anything on this computer so it shouldn't be a virus. i've also check the power cables and everything and they are all properly plugged in.

what could be the problem?
12 answers Last reply
More about computer crashing
  1. You might not have enough juice in your PSU and that may be the culprit. this is direcrtly from the AMD site.

    600W power supply (or greater) with four 75W 6-pin PCI Express power connectors recommended for AMD CrossFire™ technology.
  2. @tripledouce Where did you see anything about crossfire?
    @aloyxc What drivers do you have? 12.8 is the only one that works well with my 7870.
  3. @tripledouce hi i don't think that's the problem. i've calculated on several PSU calculators and they range from about ~380watts to ~420watts. not very sure about this too because i don't know if i've filled in the correct blanks!!

    @wanderer11 i'm currently running on 12.1. gonna update it to see if thats the problem
  4. @wanderer11 i've checked for updates in my CCC, but they said that my drivers are currently up to date. well thats weird. even on AMD website, they said the latest version was 12.1, 12.11 is a beta one :O.
  5. 12.1? Did you mean 12.11? Either way I suggest using 12.8. I have to use 12.8 with my 7870 or I get some flickering and stuff. AMD.com>search for driver>previous drivers>12.8
  6. Sounds like(no pun intended) onboard sound drivers, they are probably realtek too. This used to happen to me all the time back when bad company 2 was popular. Just install/reinstall realtek sound drivers if thats the case.
  7. It would only happen in Skyrim. I'll give it a try though.
  8. kiteohatto said:
    Sounds like(no pun intended) onboard sound drivers, they are probably realtek too. This used to happen to me all the time back when bad company 2 was popular. Just install/reinstall realtek sound drivers if thats the case.


    yes apparently mine is realtek too. i'm gonna try doing what you suggested tomorrow =)

    @waderer11, using 12.8. didn't seem to help =(
  9. @kiteohatto
    tried reinstalling them! didn't work either =(
  10. Just out of curiousity are you using hdmi or dvi? They should be different drivers.
  11. wanderer11 said:
    Just out of curiousity are you using hdmi or dvi? They should be different drivers.


    im currently using a dvi :o.
  12. still not fixed. any other suggestions? from game startup to approx ~30mins, the crashing will happen. games i've played TF2, GW2, L4D2. working/surfing the net on my computer seems fine, no random restarts or whatsoever.

    [update] okay, the crashes are getting faster and faster. 5 mins in gw2 and the system crashes
Ask a new question

Read More

Homebuilt Computer Systems