New build wont recognise SSD

Just completed my first build, went to install windows 64 bit and my SSD was not detected. The motherboard is a GA-Z77X-UD3H and the SSD in question is a Corsair Force GT 120GB. Ive tried checking forums and most peoples problem was that IDE was selected not AHCI, AHCI was selected on my BIOS when i checked. Any help would be much appreciated
5 answers Last reply
More about build wont recognise
  1. Have you tried this SSD on another computer to see if it is identified? Lets at least make sure the SSD works.
  2. No, unfortunately i dont have the ability to check if its working unless i get a USB/SATA converter tomorrow
  3. Have you tried putting it on a different SATA cable and to a different onboard controller slot? It looks like you have:

    Chipset:

    2 x SATA 6Gb/s connectors (SATA3 0/SATA3 1) supporting up to 2 SATA 6Gb/s devices
    4 x SATA 3Gb/s connectors (SATA2 2~5) supporting up to 4 SATA 3Gb/s devices
    1 x mSATA connector
    * The SATA2 5 connector will become unavailable when the mSATA connector is installed with a solid state drive.
    Support for RAID 0, RAID 1, RAID 5, and RAID 10
    * When a RAID set is built across the SATA 6Gb/s and SATA 3Gb/s channels, the system performance of the RAID set may vary depending on the devices being connected.

    Marvell 88SE9172 chip:

    2 x eSATA 6Gb/s connectors on the back panel supporting up to 2 SATA 6Gb/s devices
    Support for RAID 0 and RAID 1


    Make sure the controllers are enabled in bios too or you won't see anything.
  4. Just tried different cables, and different slots with no success. Controllers are enabled in bios but the ssd still isnt being recognised, thanks for the help aswell btw, much appreciated.
  5. I would then think the drive is faulty. I would want to check it on another machine before saying that 100% though.
Ask a new question

Read More

New Build SSD Motherboards New Build Systems