Sign in with
Sign up | Sign in
Your question

New ibuypower PC not booting

Last response: in Systems
Share
November 11, 2012 2:02:33 PM

So I just got a new computer from ibuypower, and I can't get it to boot at all. The power LEDs, fans, and HDD light will come on for a few seconds, then the system shuts down and restarts itself. It just continues this loop. There is no splash screen or video output at all.

I've tried booting it with and without anything plugged in, and ive tried booting it with the OS disc in, but it's the same result. Obviously I'm going to be calling ibuypower, but they are closed for the day and I just want to make sure it isn't something basic.

The PC is using an H61 Gigabyte motherboard, core i3 processor, an Ati 7770 GPU, some off brand PSU, and an NZXT Tempest 410 case with a digital power button.

Any advice anyone has would be appreciated. Thank you.


Update: Ok so I tried switching the PSU from 115 volts to 230 just for the heck of it, and the computer no longer restarts itself on a loop, but it's still not booting or anything. Not sure if that helps...

More about : ibuypower booting

!