Sign in with
Sign up | Sign in
Your question

Hd 7770 not detect in bios

Last response: in Graphics & Displays
Share
September 18, 2012 3:17:22 PM

i just buy & install sapphire hd 7770 and the problem is when i check in bios my vga its not detect, whats the problem? i try anything but still not working, anyone can help me?

More about : 7770 detect bios

a c 206 U Graphics card
September 18, 2012 3:27:34 PM

Typically, video cards don't show up in your BIOS. Are you saying that the HD7770 does not display anything, including the BIOS screen?
September 18, 2012 6:55:03 PM

if i choose hd 7770 and disable onboard vga, it does not display anything, just black screen.
Related resources
a c 206 U Graphics card
September 18, 2012 6:59:13 PM

Verify that you attached the PCIe power cable firmly into your HD7770. It should click into place.

What make/model is your motherboard and your power supply?

Also, make sure that you connect your display to the video card and not to the motherboard (if present) connectors. Not trying to insult your intelligence, but it happens from time to time.
September 18, 2012 7:02:56 PM

mb : ecs a880gm-m7

psu : tagan stonerock 600w tg600 uh7

i try anything but not working and beep sound from mb like 1 long beep and 8 short beep
September 18, 2012 7:10:39 PM

I think the problem is on motherboard that only supports pci express 2.0 and not support pci 3.0
a c 206 U Graphics card
September 18, 2012 7:47:47 PM

farri said:
I think the problem is on motherboard that only supports pci express 2.0 and not support pci 3.0

That is not a problem as the GPU is backward compatible with the earlier standard.

Will the system start with the HD7770 removed and using the integrated video adapter?
a b U Graphics card
September 18, 2012 7:56:21 PM

sounds like your monitor is connected to the onboard video, plug it into the shiny new card you installed.
!