Sign in with
Sign up | Sign in
Your question

Troubleshooting question: won't boot HDD

Last response: in Systems
Share
November 14, 2012 9:02:03 PM

This is probably a little off topic (this PC is ten years old) but I'm figuring the wizards on here will know exactly what to do. I've been working on this thing for several days and I'm starting to get tunnel vision.

This is an Intel D845EBG2 MOBO, 1 GB RAM PC that I did not build but it has very good components and very low hours despite it's chronological age. Worked fine when it was shut down a year or two ago. Decided to clean it up, install some new HW and use it as a boat anchor backup. Part of my motivation for wanting to figure out what's wrong is the benefit of learning something I obviously don't know.

My initial plan was to install Ubuntu. The LiveUSB install went just fine but when it came time to reboot from the HDD, it wouldn't. Figured it was a *NIX issue... but it won't boot XP Pro after the install either. I've eliminated pretty much everything which is why I'm asking for help. I've tried 4 different hard drives, two ribbon cables and I've disconnected everything that isn't needed to boot. There is no on-board video in the mobo.

What I've done:

Flashed BIOS to the latest
Installed two new 500GB WD drives. (The BIOS sees them just fine).
Tried each HDD in various combinations, different ribbon cable, etc.
Tried various boot order settings, no difference
Can install software on any HDD.. just won't boot off it

No events are logged in BIOS log file
Current boot order: CD, HDD, Floppy
Gets disk read error occurred if no CD installed
- However, the HDD does have a correct looking boot.ini file

[boot loader]
timeout=1
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional Edition" /noexecute=optin /fastdetect

There is probably some dumb little thing that I'm overlooking. I'd be grateful for a nudge in the right direction. Many thanks in advance!
November 14, 2012 9:17:43 PM

IDE ribbon cables come in two varieties. 40 and 80 wire. If the hard drives are old 40 wire might work. You might need 80 wire if the drives are newer. Read this. http://en.wikipedia.org/wiki/Parallel_ATA. Good luck
m
0
l
November 15, 2012 1:31:10 AM

Thanks for the tip. The drives are quite a few years old but were never taken out of the anti-static packaging. So they are not "new" but are unused. The PC is circa 2002. The "new" HDDs are ~2004-2005 (I'm guessing).

The drives do read and write. The complete Ubuntu install wrote to the HDD with no errors that I can see. The problem is with the bootloader (or lack of one). I haven't tried this but I'm guessing that if I was able to put grub or something on a floppy perhaps the OS on the HDD would boot.

For XP Pro, where should I be looking for the boot loader?
m
0
l
November 16, 2012 9:12:07 PM

I hate it when I do a search for information about a problem I'm having and find a thread for EXACTLY the problem I am trying to fix and see that no solution has been posted. So......

Turns out that this mobo will not support "larger drives" without installing an accelerator. The vendor (Intel) documentation is VERY vague about this and says that the patch is for "performance"....

So to get this to work, I had to build XP on the 120 GB drive, install the accelerator and then use Clonezilla to copy everything to my 500 GB drive. That got everything 100% working except that for some reason, probably not related, a second 500 GB drive installed as a primary slave does not work.

Hope this helps anyone who also runs into this problem.
m
0
l
!