Sign in with
Sign up | Sign in
Your question

SERIOUS concern regarding GTX 670 drivers

Last response: in Graphics & Displays
Share
September 19, 2012 1:41:31 PM

A few days ago all my components and parts for my new computer arrived and i started building it asap ( my first build btw ) i had a good friend of mine who knows what he is doing help me, when it was all finished it would boot perfectly. So i installed a fresh install of windows 7 then went on to install the motherboard chipset that all worked perfectly also, but then i went on to install the GTX 670 drivers. I knew not to use the ones on the disc so i got the latest drivers from the internet and installed them, i restarted my computer after the install and when windows tried to boot after the windows forming logo, the login screen wouldn't appear but the audio would still play. The really odd thing is i can type my login password and it would carry on to my desktop, the desktop background would be perfect crisp quality but there would be no windows 7 bars or desktop icons.

I've tried many things to get this fixed and none of it seems to work, iv just payed a lot of money to build my computer and im kind of worried about it now.

I have done these steps:

Installed windows 7

Installed motherboard drivers

Restarted computer 4 times during this process (was told to)

Installed Nvidia GTX 670 graphics drivers

Restarted computer (was told to)

### And the problem occurs after this point.

I have literally tried everything i can think of, but I'm not a specialist. If someone can help me it would be highly appreciated as i don't know what's wrong / what to do. I spent around £1300 on everything for my computer and only to find out I'm having problems i am extremely frustrated and worried right now.

My specs:
- Asus p8z77v-Pro motherboard
- Palit GTX 670 Jetstream Graphics Card
- Intel i7-3770k Processor
- 2x4 of Corsair Vengeance RAM
- Western Digital 1TB HDD
- Corsair TX750 V2 Power Supply

Again, if anyone can help it will be highly appreciated. Cheers.
September 19, 2012 1:47:23 PM

"The really odd thing is i can type my login password and it would carry on to my desktop, the desktop background would be perfect crisp quality but there would be no windows 7 bars or desktop icons."

Sounds to me like explorer.exe is not running. Next time you start up ctl+alt+del and look at processes in task manager. If there is no explorer.exe go to new task and type in explorer.exe and click ok. Let me know if this works.
September 19, 2012 2:08:59 PM

Nope explorer.exe is in task manager. I think it might have something to do with the motherboards intergrated graphics, but i don't have a clue how to disable them.
Related resources
September 19, 2012 2:23:03 PM

colourised said:
Nope explorer.exe is in task manager. I think it might have something to do with the motherboards intergrated graphics, but i don't have a clue how to disable them.


Could you humor me and kill explorer.exe then restart it? My laptop had the same thing happen before and explorer.exe was the issue. You can just go into the bios and disable the IGP. I never disabled mine and haven't had an issue though.
September 19, 2012 2:28:45 PM

wanderer11 said:
Could you humor me and kill explorer.exe then restart it? My laptop had the same thing happen before and explorer.exe was the issue. You can just go into the bios and disable the IGP. I never disabled mine and haven't had an issue though.


Iv done lots of research over the internet, and this seems to be a common problem, its the graphics card / drivers not the explorer.exe i found a post saying its the intergrated graphics interfering with the gtx 670, but i cant find the intergrated grphics in the BIOS / device manager
September 19, 2012 2:36:04 PM

colourised said:
Iv done lots of research over the internet, and this seems to be a common problem, its the graphics card / drivers not the explorer.exe i found a post saying its the intergrated graphics interfering with the gtx 670, but i cant find the intergrated grphics in the BIOS / device manager


Take a read through http://rog.asus.com/forum/showthread.php?16455-Asus-Max.... I know it isn't your mobo, but it seems to explain where to go to do it.
September 19, 2012 2:45:41 PM

Everything noted there i have already done, there is literally nothing else i can think of to do, I'm past the verge of giving up.
September 19, 2012 2:48:35 PM

colourised said:
Everything noted there i have already done, there is literally nothing else i can think of to do, I'm past the verge of giving up.


If you pull the gpu and plug the monitor into the mobo does it work right? If so you may want to RMA the 670.
September 19, 2012 2:55:21 PM

How will RMA the 670 do to help?
September 19, 2012 3:43:14 PM

Sounds like it is defaulting to the onboard graphics and is displaying an extended desktop through the 670 output. Right click the desktop and go to properties. Does is show two monitors?

Easy solution, set the GTX 670 as the primary display.

More intensive solution:
Disable the onboard graphics in Bios and Win 7 Control Panel.

Remove any windows updates regarding the HD 4000(iGPU) or Nvidia GTX 670.
*it may force you to reboot. After reboot, it will search for VGA drivers. Stop windows from searching for drivers.

Re-install the Nvidia Driver you downloaded. Choose custom install and choose "Remove existing component and perform a fresh install"

Should be fine after that.

September 19, 2012 3:59:01 PM

After re- reading the OP, it seems you do not know where to disable the iGPU in Bios.
From the manual for your mobo:



Click the Advanced tab and Select "System Agent Configuration" then "Graphics Configuration" and you will have the options in the screenshot above.

For Primary Display select "PCI Graphic Device"
For iGPU Multi Monitor Select "Disabled"

Save your settings and reboot.
!