Sign in with
Sign up | Sign in
Your question
Solved

Major Internet Problem

Tags:
  • Routers
  • Wireless Router
  • Computers
  • Internet
  • Networking
Last response: in Networking
Share
November 4, 2011 11:32:00 PM

After reinstalling Windows 7 because of a boot up problem, I started to have some major problems with getting my computer connected to the interent, and I shall do my best to explain:

The computer cannot detect any internet connections, and I own a wireless router and a modem. I have the computer connected to the wireless router which is connected to the modem, but it still does nothing, even if I unplug the cable and replug it into the computer. I even tried plugging the computer into just the modem insted of the wireless router, but that still didn't do any good. Even resetting the computer doesn't do good either. So with my Dell Drivers & Utilitles disc, I tried to reinstall the network driver. After it finished installing, I get this message:

The Realtek Network Controller was not found. If Deep Sleep mode is enabled Please Plug the Cable.

After that, the computer STILL says I don't have a network driver installed, and this means it still cannot detect the internet connection. Even after reinstalling Windows 7, I still have wireless internet on my laptop.

So could it be some sort of hardware problem, meaning I have to replace something?

More about : major internet problem

November 5, 2011 2:33:19 AM

Goto Control panel >> Network and Sharing >> on the left panel select Manage Network Connections.

See if your network Adapter is listed there.

If it is then right click on it and then properties, then uncheck "Internet Protocol Version 6" and then select "Internet Protocol Version 4" and then click properties
Then select "Obtain IP address automatically" and also "Obtain DNS address automatically" then click OK.

If the above doesnt work, then check this,
when you plug the ethernet cable into the computer, do you see the lights on your Ethernet card (right where the cable is plugged) flickering?

If not then its possible that your NIC is the issue.

Do you have any other computers in the house which you can connect to your router/modem to rule them out?

m
0
l
November 5, 2011 3:46:54 AM

zer0net said:
Goto Control panel >> Network and Sharing >> on the left panel select Manage Network Connections.

See if your network Adapter is listed there.

If it is then right click on it and then properties, then uncheck "Internet Protocol Version 6" and then select "Internet Protocol Version 4" and then click properties
Then select "Obtain IP address automatically" and also "Obtain DNS address automatically" then click OK.

If the above doesnt work, then check this,
when you plug the ethernet cable into the computer, do you see the lights on your Ethernet card (right where the cable is plugged) flickering?

If not then its possible that your NIC is the issue.

Do you have any other computers in the house which you can connect to your router/modem to rule them out?

Well I go to the Network and Sharing center, I go to the left and click Change adapter settings, and it shows nothing by a white block, and my computer is connected to the wireless router. Here's a picture I took with my camera & edited with MS Paint to show what it's like:


Like I said, I've connected them with cables, and I even tried different cables for the computer too. I do see a green light at the back of my computer form the cable connection, but there's no light from the back of the modem. I tested connecting the laptop to the modem, but I got no connection from it, even though I get a connection with wireless internet with my laptop. So could it be the modem, or is something wrong with my computer network hardware?

Edit: According to the Windows Network Diagnostics, I get this as my problem:

Windows could not find a driver for your network adapter.

But I installed the driver, and I still get that message! So what could be wrong?
m
0
l
Related resources
November 5, 2011 3:20:25 PM

ok, so windows is saying that it can not find the drivers.
Please check the following
Right click on Computer >> Properties >> On the left panel click Device Manager

Find "Network Adapters" from the list and expand that tree, and check if anything listed there has a yellow triangle or circle or something there indicating that it is not installed properly.

m
0
l
November 5, 2011 3:45:29 PM

zer0net said:
ok, so windows is saying that it can not find the drivers.
Please check the following
Right click on Computer >> Properties >> On the left panel click Device Manager

Find "Network Adapters" from the list and expand that tree, and check if anything listed there has a yellow triangle or circle or something there indicating that it is not installed properly.

I go to the Device Manager menu, but I don't see Network Adapters at all, thus this means something could be up with the network hardware.
m
0
l
November 5, 2011 3:54:30 PM

That is strange,
Is your NIC standalone or built into the motherboard?

If its in the motherboard, try re-installing the chipset drivers from your dell CD.
m
0
l
November 5, 2011 4:12:10 PM

zer0net said:
That is strange,
Is your NIC standalone or built into the motherboard?

If its in the motherboard, try re-installing the chipset drivers from your dell CD.

Well my computer is a Dell Inspiron One 19, which looks like this:

So how can I tell if the NIC is built in or not?

I followed the instructions of this video to reinstall Windows 7:
http://www.youtube.com/watch?v=JyMWz5UEgoI

I also used a Dell Edition of the Windows 7 Installation, which looks like this:

So what if I installed Windows 7 wrong?
m
0
l
November 5, 2011 4:17:00 PM

ok since its all in one computer, its most likely on board network adapter. Can you please tell me the exact model of the computer?
m
0
l
November 5, 2011 4:23:40 PM

zer0net said:
ok since its all in one computer, its most likely on board network adapter. Can you please tell me the exact model of the computer?

I told you, the computer is a Dell Inspiron One 19. Or do you want my model's number? Should I look on the box for it, or look on the system?
m
0
l
November 5, 2011 4:24:57 PM

should be written on the back of the system,
or even service tag ID, i just want to look on the dell website what are the specs of your system.
m
0
l
November 5, 2011 4:31:59 PM

zer0net said:
should be written on the back of the system,
or even service tag ID, i just want to look on the dell website what are the specs of your system.

Ok I looked at the back of the computer, and here's my service tag ID:
CKGSSL1
m
0
l
November 5, 2011 4:45:02 PM

does your computer also have a wifi built in? is that working fine?
m
0
l
November 5, 2011 4:47:51 PM

zer0net said:
does your computer also have a wifi built in? is that working fine?

I don't think so. But my laptop has WiFi, and the laptop's WiFi works great.
m
0
l
November 5, 2011 4:55:24 PM

ok I just had an epiphany,
Turn off the computer, and unplug the power cable. Once the cable unplugged, hold down the power button for good 10 seconds, and i mean hold it pressed. This will drain all the capacitors in the system, and then let go of the power button, leave the system like that for about 10 min. Then plug the cable in and power on the system. It might just detect your network card.

IF the network card does come back when you restart after power drain, do this to make sure it doesnt go back to sleep.

Goto device manager again,
expand the network adapter tree
select your network card (double click to open its properties)
Select power management tab
UNCHECK “Allow the computer to turn off this device to save power”

press ok...

and all should be good... (fingers crossed)
m
0
l
November 5, 2011 5:08:09 PM

zer0net said:
ok I just had an epiphany,
Turn off the computer, and unplug the power cable. Once the cable unplugged, hold down the power button for good 10 seconds, and i mean hold it pressed. This will drain all the capacitors in the system, and then let go of the power button, leave the system like that for about 10 min. Then plug the cable in and power on the system. It might just detect your network card.

IF the network card does come back when you restart after power drain, do this to make sure it doesnt go back to sleep.

Goto device manager again,
expand the network adapter tree
select your network card (double click to open its properties)
Select power management tab
UNCHECK “Allow the computer to turn off this device to save power”

press ok...

and all should be good... (fingers crossed)

Ok, so I go back to the Device Manager, then I make the Network adapters appear by going to the View tab and clicking Show hidden devices. Afterwards, I click on the Network adapters tab, and find all these devices, but after right clicking on them and selecting Properties, it doesn't show the Power Management tab for either if them. So what now?
m
0
l
November 5, 2011 5:30:57 PM

did you power off the computer unplugged the power cable and held the power button for 10 seconds?
if so did windows detect your network card?
m
0
l
November 5, 2011 5:34:26 PM

zer0net said:
did you power off the computer unplugged the power cable and held the power button for 10 seconds?
if so did windows detect your network card?

No, I haven't tried that before. Do you suppose it could work? Can you put in a list form so that I can follow it like an instruction manuel?
m
0
l

Best solution

November 5, 2011 5:48:08 PM

Ok, you need to do that before you can goto device manager and do the other stuff..

1. click start then shutdown to completely turn off the computer

2. unplug the power cable from wall or computer or both

3. press and hold the power button for 10 to 20 seconds (while hoding it pressed you may hear the fan run or some LEDs light up, dont worry dont let go of the button keep it pressed for 10 to 20 seconds)

4. After you have let go of the button, leave the system as is for about 10 min (dont plug any power cables in or do anything, go have a cup of coffee)

5. After 10 min have passed, plug in the power cable in the computer/wall or both and then power on the computer.

When the windows boot this time hopefully your card will be detected. And will begin to work.

Only once the card begins to work follow these instructions to make sure that it doesnt happen again.

Goto device manager again,
expand the network adapter tree
select your network card (double click to open its properties)
Select power management tab
UNCHECK “Allow the computer to turn off this device to save power”
Share
November 5, 2011 8:20:11 PM

I'm curious to know if it worked?

m
0
l
November 5, 2011 10:00:17 PM

zer0net said:
I'm curious to know if it worked?

I did wat you said, and it works! :D  Thank you so much for the help!
m
0
l
November 5, 2011 10:31:25 PM

oh good.
Glad I could help.

Dont forget to mark the thread solved, you can do that by selecting the post that helped you by selecting it as the best answer.

This could also help others who are having the same issue.

Thanx
m
0
l
November 5, 2011 10:59:24 PM

Best answer selected by NiTROACTiVE.
m
0
l
!