Sign in with
Sign up | Sign in
Your question

VPN able to ping not able to view shares or RDP

Last response: in Networking
Share
November 6, 2011 12:33:51 AM

Hello All,

I am working on a WRVS4400N with V2.0.1.3. I have an issue with its vpn. The issue is the user connects with the client (QuickVPN), all is well, but when you try to RDP or, for example go to Run and put \\ ipaddress to view the shares of that workstation, it says it cannot be found. But if you ping the workstation, you get replies. I have checked the logs and nothing seems suspicious. I have disabled the firewall on both ends and tried to connect and it still gives the issue. I have tried the client on a Windows 7 and Windows XP machine and still have issues. The workstation I am trying to access is XP. I need some help.



If it is the client, is there any other client I can use to test.





Thanks in Advance
November 6, 2011 12:53:30 AM

Do you have file and printer sharing enable for the VPN connection? (it may be disabled by default!)
November 6, 2011 12:55:14 AM

Inside the router config or on the XP machine? On the XP machine yes.
Related resources
November 6, 2011 1:04:46 AM

So it sounds like the router is the actual VPN server. If you can ping the machine but nothing else, it has to be something on the router's VPN config. It has to be a firewall or something similar. Did this work before and suddenly break, or never work? Is it just you having a problem, or perhaps others?
November 6, 2011 1:23:39 AM

On the VPN connection itself. When I configure the Microsoft PPTP VPN, for example, I don't have to bind file and printer sharing to the VPN if I don't want to. And if I choose not to, those protocols will NOT traverse the VPN tunnel. And therefore it doesn't matter if the client and remote machine have file and printer sharing enabled, you can't get the protocol (SMB) across the VPN tunnel! Since I'm not familiar w/ QuickVPN, I don't know if it *might* be blocking file and printer sharing by default. Just a guess.
November 6, 2011 1:27:21 AM

Well the client is very minimal. Username, password, server, and port (you have the option of Auto, 443, 60443, I use 60443), and the last option is Use Remote DNS Server. Nothing more to it. So I am assuming it is in the router config?

Should it be a check box or a port I am suppose to forward?
November 6, 2011 1:34:22 AM

What about the VPN server side? Are you sure file and printer sharing is enabled/supported? And you're using explicit IP addressing, right? (\\135.16.7.8\myshare, not \\serverx\myshare).
November 6, 2011 1:36:34 AM

VPN Server is the router. I am trying to access a workstation which Has no software relation on there what so ever, all VPN management is done by the router. I have checked the LAN connection properties and File and Printer Sharing is enabled. As well as RDP. I am doing \\10.10.10.5. Which is the ip address of that local machine not the router.
November 6, 2011 1:48:26 AM

And your local network and the remote network are using different subnets (e.g., 192.168.1.x and 10.10.10.x)?
November 6, 2011 1:49:01 AM

yes
November 8, 2011 2:33:49 AM

Alright so have made some progression. I am now able to narrow it down to a port that needs to be forwarded in the Windows XP Firewall. One of out the 2 main problems was not having 60443 forwarded with UDP in the Router Firewall. Now I am able to RDP and such with XP Firewall up. I have tried port 135,136,137,138,139,445,1723,47,443,60443 TCP and UDP. Still not able to view shares. Right when I disable the firewall, I can see shares. So there has to be one port out there that it is using that I am missing. Anyone have any idea?

One of the main issues is because I didn't have 60443 forwarded with UDP. Now I can RDP because 3389 is forwarded in the XP firewall. I just need that port or ports for the File Sharing. and yes the default preset File and Printer Sharing port range is forwarded. That includes 135-139 and 445.
!