Sign in with
Sign up | Sign in
Your question
Closed

Problems with Sapphire Radeon 7950

Last response: in Graphics & Displays
Share
September 21, 2012 10:35:03 PM

I recently upgrade my video card from an XFX 6850 to a Sapphire 7950 (810mhz core clock). I really didn't need the new card yet; however, I was able to get it for $250 after rebates...I wanted the higher VRAM for games, and at that price, why not get it. I had some troubles installing the latest drivers, but I believe that the drivers are correctly installed. I have four concerns with this card that I can't seem to figure out.

First, I have had random instances with receiving the following error message: AMD driver has stopped working and has recovered. I have seen that this is a common problem; however, I'm not sure of the cause. I uninstalled AMD software using the AMD Catalyst Install Manager. I had several instance of loading CCC and removing. On my final attempt, I uninstalled AMD software using the AMD Uninstall Manager. I also was not connected to the internet at the time in order to prevent my system from downloading an older driver online. I had the card installed, and when I checked display apapters in device manager, it showed AMD 7900 series driver (which I thought shouldn't have been intalled yet). Then installed the newest CCC (ver12.8). Still have had instances of the drivers stopping working. I do have a new Cougar GX1050 psu (another good deal). Have not had any problems with PSU in past. Am not using the modular outputs for the power connection to the GPU...just the connections straight from the PSU. I would assume that this PSU is more than sufficient for my card.

Second, I have an Asrock z77 Extreme4 mobo. Since installing the new card, I cannot get VirtuMVP to work. States that I have the wrong GPU configuration. I'm not sure if I really need the VirtuMVP; however, I would like to use it if it is helpful.

Third issue is the AMD overdrive in the CCC. It lists my GPU clock at only 300mhz, memory clocck at 150mhz, power at 0% (I don't even know what this feature is for), and temp is currently running fine at 33c. I do have my GPU clock set to 950 and mem to 1250; however, the system still shows 300 and 150. Is this the normal output for the card until it is used or is something wrong?

Finally, when I ran the WEI after installing the card, my Graphics index dropped from 7.7 (with the 6850) to 2 (with the 7950). I had numerous instances where I received the error message that the driver stopped working.

So, in conclusion, I don't know if all of these problems are par for the course for this card+drivers, or if I need to make some corrections. I would appreciate any input if I need to make corrections.

I use the system mainly for games. Skyrim at the present (approx 10 mods). Will be playing BF3, Metro 2033, Portal, Borderlands, Arkane Asylum.

Specs (I have not changed voltages on anything):

Windows 7 Home Premium 64bit
OCZ Agility 3 240gb SSD with latest firmware (OS, games, some programs)
WD Blue 1tb (Backup, some programs, files)
i-5 3570k OC'd to 4.2
Corsair Vengeance 8gm ram
Cougar GX1050 PSU (1050 Watt Gold Plus)
Corsair H60 CPU cooler
Sapphire HD 7950 (810mhz core)
Asrock z77 Extreme4 mobo (haven't flashed to newest BIOS if it's available)
Liteon 12x BluRay, DVD rw,blah blah blah
Corsair 500r case (airflow and temps are great)
Dell Wireless keyboard/mouse and XBOX wireless controller

**I did have MSI afterburner and Kombuster (?) installed with the 6850, but uninstalled both while trying to trouble shoot for problems. They are still not installed.
**Also, I was able to play Skyrim. I did not notice any noticeable improvement with the 7950 over the 6850...still had the same stuttering at times and no real noticeable graphic improvement (which my be normal IDK).

**Experienced the drivers crashing during the WEI, which--I believe--caused the low WEI score.
September 21, 2012 11:49:54 PM

Ok, thanks for the info on the card and driver solution. I'll try the fix and post the results. I do think that there is some AMD stuff floating around that was not uninstalled properly...so this may work.

I won't be able to try this out for a few days due to some work that I need to take care of. I spent a lot of time trying to fix the problem initially and need to take care of other stuff...but will post the results in a few.
September 21, 2012 11:52:52 PM

I went from an Asus 6870 to a Sapphire 7950 and have been very pleased...if you can get it working correctly, I think you'll enjoy the difference.

Just a thought that may or may not apply in your case: I've seen random crashes and odd system behaviors when a power supply wasn't quite up to snuff. You might consider trying a different power supply. For that GPU, I'd recommend 600W+.
Related resources
September 21, 2012 11:55:16 PM

sounds like a driver problem to me as well.
but just to make sure, do you both 2 x 6pin connectors plugged in? Because the low wei makes me think it's running the integrated graphics with virtu.
September 22, 2012 12:11:09 AM

The power supply is 1050 watt 80plus Gold. Had some mixed reviews over Cougar's parent company; however, most reviews were positive that this is a solid PSU. I do have both 6pin's connected....and it is seated correctly.
I believe that I was getting the integrated graphics reading as well--which, I believe was due to the driver crash occurring while WEI was testing my system. I forgot to mention this in the original post.
September 22, 2012 5:20:34 AM

i was having same problem what u have to do to COMPLETELY uninstall all ur AMD driver
follow the steps.

Start>control panel>uninstall a program>click on Amd catalyst install manager>click uninstall ALL amd sofware>follow the steps.reboot it ..

then start ur pc in safe mode...
run driver sweeper software in administrative mode....u can download it from following link
http://www.guru3d.com/content-page/guru3d-driver-sweepe...

run this software...(in safe mode with run as administrator)
it allows u to remove all left over driver files..which might be interfere with new driver installation so remove the files which u wanted...
so now u r clear of all old driver files .now start it and do fresh installation of latest amd driver...at present it is catalyst 12.8...
then tell me if it works or not....
September 22, 2012 2:16:36 PM

I don't want to use Drivesweep as I've read that it can cause problems over extended use. I want to try BigMack's solution; however, I'm a little leary of fooling with the registry. I tried a solution for a different problem one time...that solution involved making changes in the registry--and I had to reinstall Windows.

Also, I assume that I can leave my 'video out' attached to the GPU during this process. Onboard graphics won't work with the GPU seated in the mobo.
September 23, 2012 4:53:48 AM

Best answer selected by willyj73.
September 23, 2012 4:56:52 AM

Ok, I removed AMD via Catalyst install and then removed all AMD/ATI files as the guide had stated. It was rather simple...just had to check that I was navigating according to the instructions as this was my first time deleting the files/folders this was. WEI is up to 7.9 across the board except for my i5 and I haven't had any of the driver crases during the testing.
September 23, 2012 10:04:30 AM

This topic has been closed by Mousemonkey
!