Sign in with
Sign up | Sign in
Your question

Gtx 670 HDMI problems with 7.1

Last response: in Graphics & Displays
Share
September 22, 2012 2:14:53 AM

first ill start off with my components

asrock z68 extreme 3 MB (realtek al892)
i5 - 2500k
16 gig ram
gtx 670 gigabyte wf3


just installed the nvidia gpu previously had dual 5870 from ati. i uninstalled and swept the ati drivers before the install

with my ati cards i could run the hdmi into my onkyo receiver and go into the audio properties and select 7.1 surround and al speakers would play perfectly. when i try the same with the gtx the options are there and i can select 7.1 but when you run the audio test it only plays the front two speakers. If you click next with the 7.1 selected the speakers make a god awful noise untill you select stereo again.

i did ty blurays and the ones i did try output perfectly dolby hd 5.1 but games like battlefield 3 dont like it used to..

please help me figure this out

More about : gtx 670 hdmi problems

a c 219 U Graphics card
September 22, 2012 2:23:27 AM

Check Control Panel/Sound/Playback. Right click on HDMI audio output device, select configure speakers, select 7.1. Click OK. Try sound again.
m
0
l
September 22, 2012 4:46:35 AM

Sorry I should have clarified that's where I was doing all this was through the output device menue
m
0
l
Related resources
September 22, 2012 4:55:48 PM

I'm not sure what the combination was but I somehow got it working like a champ. Wish I knew how so I could help anyone else that might have this dilemma. I changed the bit rate, drivers, cables and tons of reboots with no luck. Came home and decided to try it again fired up the pc and it switched to 7.1 with no problems. Don't know how or why but glad it did. Thanks
m
0
l
a c 219 U Graphics card
September 22, 2012 7:36:56 PM

Good job! Have fun!
m
0
l
!