Sign in with
Sign up | Sign in
Your question

Laptop runing slow when on build in screen

Last response: in Graphics & Displays
Share
September 23, 2012 12:11:46 AM

hi all

i have some problems with my ASUS N55SF
the problems i have is that when i are gaming on the build in screen it lags and run very slow but when i on a external monitor it runs fine (when on build in 25 FPS in minecraft when on external 75 FPS)

the computer spec's

Intel® Core™ i7 2670QM/2630QM Processor
Genuine Windows® 7 Home Premium
8 GB DDR3 Ram
15.6" 16:9 HD (1366x768)/HD+ (1600x900)/Full HD (1920x1080) LED Backlight
NVIDIA® GeForce® GT 555M 2GB DDR3 VRAM

Full specs:
http://www.asus.com/Notebooks/Multimedia_Entertainment/...


can anyone tell me what can be wrong

Thx in advance

Rasmus
a c 218 U Graphics card
September 23, 2012 12:28:38 AM

What resolution are you gaming at when connected to an external display?

Also, are your drivers up to date?
September 26, 2012 1:06:31 PM

1920 x 1080 on both screens (internal and external)

i have also tried to update the drivers for my grafics card but without luck...
Related resources
September 26, 2012 2:48:10 PM

i downloaded them from nvidia and used they auto dectect service
and what u are linking to are the wrong driver i have NVIDIA® GeForce® GT 555M 2GB DDR3 VRAM
a c 218 U Graphics card
September 26, 2012 3:31:00 PM

No they are the correct drivers. Look at the Supported Products tab on both links.

Are you using 32-bit or 64-bit Windows 7? You have to use the version of the drivers for your version of Windows.

Also, don't use the auto-detect. Just download and install the drivers.
September 27, 2012 1:48:45 PM

i use 64 bit
i have tried to download and install to driver u gave me the link to but ut have not help at all :( 
a c 218 U Graphics card
September 27, 2012 2:07:52 PM

This Asus model appears to support hybrid graphics (I can't confirm from looking at the Asus website):

http://www.asus.com/Notebooks/Multimedia_Entertainment/...

This is a power saving feature that lets you use the laptop's on-board Intel video adapter when less demanding tasks are running. When more demanding video tasks are running, the system will automatically switch to the Nvidia video adapter.

If your system is not switching back and forth, it could be part of the issue. I am only theorizing at this point. Try this, look at your BIOS settings and see if you can disable the on-board video adapter (Intel) and then test your graphics speeds.

Also, just as an aside, how does the system perform when you display to both the internal LCD and the external display at the same time?
September 27, 2012 2:28:38 PM

i have looked i BIOS and i can't find any video settings at all i have tryed google and i can see the adaptor from intel grafichs controller in device manager
should i try that?
a c 218 U Graphics card
September 27, 2012 2:51:13 PM

Sure, you could disable it in Windows. That should force the use of the Nvidia adapter at all times. This will increase performance, but will decrease battery life.
a c 218 U Graphics card
September 27, 2012 2:52:39 PM

Also, if for some reason you lose all graphics upon restarting the system after disabling the Intel adapter in Widnows. Just boot into Safe Mode and re-enable the Intel adapter in Device Manager.
September 27, 2012 5:40:35 PM

i have tried to disable the intergrated Intel HD Graphics 3000 but without luck...
i think i will contact ASUS to hear if i am the only that have this problem....
thx u for all the help :) 
a c 218 U Graphics card
September 27, 2012 5:45:50 PM

You are welcome. Good luck. Please post the results.
September 27, 2012 6:24:27 PM

will do :) 
October 22, 2013 12:57:39 AM

Hi, this is an old topic but i have the same laptop and just realized that my problem is the same. I am a BF player and i have 60-70 fps minimum on 720p but, screen does not perform decently, screen tears and mouse stutters. it feels like i have low fps but it doesnt. i plugged laptop to my 47" tv it performs amazingly well. As a result, please help me if you find any solution for this.
!