Sign in with
Sign up | Sign in
Your question

GPU/PSU Issue

Last response: in Systems
Share
November 18, 2012 10:09:39 PM

Hey guys,

Recently built a machine (thanks to suggestions from people on this forum!) - got it all set up and working nicely on Friday night, had it running all through Saturday, and most of today, then this evening it just wouldn't display anything on the screen. I narrowed it down to the fact that the GPU didn't display anything (despite having fans on). My CPU has in built graphics (i5 3570K) so I was able to confirm that it was this.

These are the steps I then followed:
1) Swapped out PCI-E power cables. I thought one of them was dodgy, but then did it in a logical manner (I labelled all 4 PCI-E cables A-D, then tried all the combinations e.g. AB, AC, AD, BC, BD, CD). It worked for the first 3, then failed for the next 3, leading me to realise it wasn't a cable. To confirm, i repeated this test and it failed the first 3 so I stopped.

2) After realising it wasn't these, I switched the GPU into the second PCI-E slot and re-ran the tests, and it worked 5 times in a row, leading me to think now it was the motherboard.

3) Switched it back to PCI-E 1, it failed, then passed, on the same test

4) Still unsure whether it is the GPU, maybe faulty PSU, or now potentially the Mobo, I decided to leave the GPU in PCI-E2, close it up and see how it worked. I did this, only to find that my PC wouldn't turn on at all. WTF.

5) Checked all connections - still nothing.

So my question is - do you think it could have been the PSU that was dodgy? I read that GPU starts its fans but doesn't turn on if it realises there isn't enough power, hence leading me to the initial conclusion that it was a PCI-E cable. Now the fact nothing seems to work suggests it's the PSU - although I guess it could still be the mobo (Unplugging the GPU doesn't work either, so pretty sure it's not that).

Is there any way for me to truely test that the PSU is screwed? (I don't have a multimeter with me).


My specs are:
CPU: Intel i5 3570K
GPU: Sapphire HD7870 OC GHz Edition 2GB
RAM: Corsair Vengeance 8GB (2x4GB) DDR3
PSU: Corsair TX750 V2
Mobo: ASRock Extreme4 z77

Kind Regards,
Phil

More about : gpu psu issue

November 19, 2012 10:03:51 AM

Update:
Forgot to mention that I also updated the BIOS to the latest version.

Anyway, I've also managed to get the PSU working now - I redid all the connections and that seemed to solve it - I will wait and see if it continues to work in PCI-E slot 2 as that will tell me if it's the motherboard, or the PSU.
November 19, 2012 10:25:11 AM

I'm pretty sure that's the GPU. The Sapphire 7870 series has been hit with an unfortunate, well-known "black screen" bug. I reckon your PSU is perfectly fine. I would recommend RMAing the GPU and see if you can get a different brand 7870 or something like that.
November 19, 2012 10:26:25 AM

BTW, you can confirm this by trying it in a completely different rig, like a friend's or something and see if you can replicate the issue.
!