Sign in with
Sign up | Sign in
Your question

No output on a Radeon X1950 XTX

Tags:
  • Radeon
  • Graphics Cards
  • Graphics
Last response: in Graphics & Displays
Share
September 23, 2012 11:07:18 AM

Hi guys. I have a problem with my custom built PC. I recently moved house and decided to dual screen. After about a week, I bought a DVI cable and when i put the 2nd cable into my Radeon X1950 XTX, the PC wouldn't POST. The lights & fans come on but no beeps and no output at all on either monitor. There's a red light on my graphics card which is the "fail" light so I decided to reseat it as I figured I dislodged it by pushing too hard with the DVI cable. But reseating it did nothing.
Everything in my PC I bought new except for the RAM (Corsair) and the graphics card, which I bought from a respectable friend. They've given me several years with no trouble.
I was going to buy a new graphics card as I figured that was the problem, but if the problem lies with the motherboard or PSU, I don't want to fry my brand new graphics card. Any help would be appreciated as I don't quite know what to do next.
Many Thanks

More about : output radeon x1950 xtx

September 23, 2012 12:19:37 PM

The card has 3 monitor ports. The card has switched it's main output to a port that you are not using.
If you plugged a monitor into each port, you would find the one that IS working.
This a a bug that causes the card to reset the output configuration. The bug is in the software.
After you find the port that IS working, you can go in and reset the monitor configuration, back to the original way that it was to start with.
September 23, 2012 1:27:05 PM

Thanks for replying.
That could very well be happening but I don't think my PC is POSTing. Just from the noises. There are no beeps and no other noises. Would that stop it from POSTing?
Thanks again
!