Sign in with
Sign up | Sign in
Your question

FX 8150 and Asrock 970extreme3 HELP

Last response: in Systems
Share
November 19, 2012 2:32:52 PM

Hello all,

Firstly i regret that my first post is a help question, but also I'm glad because if i'd never searched for help then i would never of found tom's hardware with such great guides and advice...

Lets get down to my problem... Basically about 2 months ago I did (what i thought) was a lot of research into the world of homebuilt and took the plunge to build a ok'ish pc at a budget.

Heres the components i brought:-


Processor: AMD FX-8150 AM3+ 3.6GHz 16MB 125W
Motherboard: ASRock 970 Extreme3
Graphics: Radeon 1GB HD7770 (sapphire)

OK now for the cheap(er) parts
Power: Alpine 750W Quiet Silent PC Power Supply PSU Black Red (EBAY)
RAM: 4x4GB KomputerBay (it reads- 4GB PC3-10600 DDR3 1333Mhz 4096MB NON ECC 9-9-9-25)

HardDrive: the 2nd one from my laptop
- Little speaker from very old pc
And an ACER monitor which i have plugged into my laptop atm...


PROBLEM: NO DISPLAY OR BEEPS - Ok so basically the problem is that when i power it on everything seems to look like its working (fans spinning) but no post beeps or no display. I've followed quite a lot of tutorials explaining how to test by breadboarding which i've done... some say i should be able to get to the bios without ram others say not, but to be sure ive tried most combinations to try and get any beeps/activity.

I dont mind buying new parts as long as i can get to a texting stage to know the parts are faulty or not compatable... for example ive tried the ram on my friends pc (although it was intel) and it worked fine.

oh ive also taking it to 2 computer shops to get it looked at (which bear in mind are the only 2 computer shops in my town) and both have said they cant test it because they deal with intel...

Anyway any help would be greatly appreciated.



a b B Homebuilt system
November 19, 2012 2:50:25 PM

Did you try without graphics and ram? At least that should give you a beep. And outside the case to sort out any short circuits caused by the stand-offs or the I/O Shield?
November 19, 2012 3:34:31 PM

noidea_77 said:
Did you try without graphics and ram? At least that should give you a beep. And outside the case to sort out any short circuits caused by the stand-offs or the I/O Shield?


hello, thanks for teh reply,

yes i've just took both out and i get 3 beeps... the manual for the mobo says the bios is '32mb AMI UEFI legal BIOS with GUI support' ive just checked this site - http://www.computerhope.com/beep.htm#04 and the AMI section says 3 short beeps (although they sound quite long but there isnt a 3 long beep option) is a memory issue i think. I also get the same 3 beeps with my graphics card and also with a spare graphics card i have.

The Ram isnt actually on the memory support list on the asrock website (http://www.asrock.com/mb/AMD/970%20Extreme3/?cat=Memory) is this the issue? or in reality should this ram still work but maybe not as well?
Related resources
a b B Homebuilt system
November 19, 2012 4:21:30 PM

^also make sure the 6 pin pcie power connector is plugged in snugly into the gpu. If you have a spare gpu laying around I would try that. The psu isn't the greatest quality, but the 7770 sips power.
November 19, 2012 4:54:56 PM

thanks for your reply's. zooted ive made sure the power to GPU is plugged in firmly and i've also tried another GPU (an older 512mb nvidia one) which doesn't require external power but no luck. I haven't got another PSU to test, but research the past few days has made me decide to invest in a more well known reliable one, so thats one thing i will do.

But, reading over fun500's link it shows the 4pin/8pin 12 volt power cable... my mobo has a 8 pin and im only using 4 pins (as my PSU only has the 4 pin). could this be the issue?

November 19, 2012 5:04:03 PM

Just looked in the motherboard manual. and although it is a 8 pin socket it says ATX12V1 next to it and also says in the manual that 'it can still work if you adopt a tradictional 4-pin ATX 12V Power supply'
a b B Homebuilt system
November 20, 2012 11:18:49 AM

Yes it should work as long as you have it plugged in along the 1 and 5 pins as shown in the motherboard.(It shouldn't allow you to plug it in any other slots as it is fitted this way.)

Have you tried booting with one ram stick at a time?
November 20, 2012 12:45:49 PM

Yes, i have also tried booting one ram stick at a time in each slot... many combinations. The beep code says it is the ram, (3beeps) could it be incompatible?
a b B Homebuilt system
November 20, 2012 12:57:30 PM

Have you checked your bios version? cross-reference with this to ensure your chip is supported on your current bios,
http://www.asrock.com/mb/cpu.asp?Model=970%20Extreme3
If not then you will need a compatible chip to get things up and running, flash the bios to the latest and then install the Dozer
Ram has no affinity with Intel or Amd so don/t worry about compatability that way,
I run two machine with four pins even though they have 8pin Cpu sockets, no problem there,

I think your local Pc shops attitude sucks, but such is life :S
I know you said you've done some breadboarding but run through these (3&4) to check you haven't missed anything out,
http://www.tomshardware.co.uk/forum/288241-13-read-post...
and try the build out of the case (in case theres a grounding issue on the case)
Moto
November 26, 2012 8:02:58 AM

jkeyte, I have the same MB, CPU and GPU. At the first time my rig didn't fire up, just spinning fans and that was all - I didn't connect a speaker to listen to the beeps.
I switched the PSU with a Corsair CX600 and everything started to work.

My two cents: better pay more for a medium and better PSU with less W, than less for one that has lots W.
!