Sign in with
Sign up | Sign in
Your question

How can I not max out GW2??

Last response: in Graphics & Displays
Share
September 23, 2012 6:56:40 PM

How can I not max out Guild Wars 2 with my setup?
All settings maxed out, including supersampling, FXAA and all reflections, I hardly get 60FPS in normal gameplay. In combat I almost drop below 30. When I turn around I get FPS drops most of the time. In busy fights I run about 25 FPS

And that with this build:

Intel Core i7 - 3770k @ 4,2Ghz
Corsair H100 liquid cooling
16GB G.Skill ripjaws 2133Mhz Quad-kit
Asus Sabertooth Z77
Corsair Force 3 240GB SSD
(Extra 500GB random HDD for storage)
XFX 1050W Black Edition PSU
2x Palit Jetstream GTX 680 4GB in SLI
Raven RV02-e

Temps reach up to almost 80 C on GPU1, GPU2 around 70 C.
CPU hardly hits 55 C with GW2

Current driver: 306.23
I have tried any other driver (beta AND WHQL drivers). But they all perform bad.

Is this a game problem, or do my GPU's have a problem? Other games run fine.. So I can't see why I can't max it :S

More about : max gw2

September 23, 2012 6:59:46 PM

Because your rig is too old and slow? :lol: 

More seriously, I'm not sure - sounds like a driver problem or a problem with the game not really using SLI well - I've heard GW2 isn't handling SLI/CF yet but I don't know if that's true or not.

(I'm assuming you're gaming on a single screen?)
September 23, 2012 9:05:29 PM

Yes, sorry for not mentioning that. I currently still game on 1 screen (1920x1080).. I've consired a surround setup, but my desk is too small because I use a 27" screen.. Buying 2 extra won't fit, going back to smaller sized screens is hard :p 

I'm not how I can notice if Guild Wars 2 is using my SLI right. The only thing I can see, is that both GPU's Core load hit 99% during the game. So that's why I expected the SLI actually worked.

I think I have to wait for some patches then. Guild Wars updates, or maybe newer drivers.
Related resources
a b Î Nvidia
September 23, 2012 9:06:13 PM

GW2 has problems.
a c 172 Î Nvidia
September 23, 2012 9:06:50 PM

kemperkipie said:
Yes, sorry for not mentioning that. I currently still game on 1 screen (1920x1080).. I've consired a surround setup, but my desk is too small because I use a 27" screen.. Buying 2 extra won't fit, going back to smaller sized screens is hard :p 

I'm not how I can notice if Guild Wars 2 is using my SLI right. The only thing I can see, is that both GPU's Core load hit 99% during the game. So that's why I expected the SLI actually worked.

I think I have to wait for some patches then. Guild Wars updates, or maybe newer drivers.

Have you tried turning the SLi indicators on?
September 23, 2012 9:07:58 PM

Stop using SLI and GW2 will run better.
September 23, 2012 9:50:44 PM

I had 2 6850s in CF and guild wars 2 ran like crap, It ran alot better with just one card. Now im running a 7970 and I can max it out and get 60fps the lowest I got was in the 40s in a decent group fight. Ima go play some more and try to find a big big group fight and see how many frames I get. But try it with just one card like others said.
a c 81 Î Nvidia
September 23, 2012 10:22:32 PM

Turn off Supersampling for starters. SSAA for many years has been one of the most insanely demanding settings, and generally not usable on any game that isn't really super easy to max without it.

It is also completely unnecessary to use FXAA with SSAA or visa versa. They do the same thing for the most part, only SSAA is much better at it and far more demanding.
September 23, 2012 10:25:08 PM

^^ Good catch - didn't realize you said you're using SSAA. Think of SSAA like a negation of SLI, as it typically cuts your framerate in half.
September 24, 2012 12:24:38 AM

As mentioned earlier, guild wars is really messed up. They're still working on getting it to run more efficently, but I think that their biggest priority for now is to fix all the glitches in the game first. Before that they were dealing with all the hackers and stuff, it's lower on the list of things for them to do yet is basically what I'm saying.

For reference the rig in my signature will max it out, minus shadows I run on low, reflections on the mid setting, and view distance on high, not ultra. And of course I don't use SSAA.
a c 81 Î Nvidia
September 24, 2012 12:48:15 AM

JamesSneed said:
You see toms write up http://www.tomshardware.com/reviews/guild-wars-2-perfor...

A gtx 670 is getting around the same performance as your 680s in SLI. I have a single gtx 670 overclocked a bit and I get a tad better than toms write up at 1080p.


Until he disables SSAA, he can't compare to those benchmarks. They just use FXAA and no Supersampling (SSAA).
September 24, 2012 11:57:31 AM

I don't always use supersampling, but if I set everything to max, and disable SSAA, I still get crappy FPS, and not as good as the review promisses.. My brother runs a single GTX 680 (Phantom 4GB) and runs it even worse than me.. (He is using a Phenom II x4 955 BE, what probably is his bottleneck)
September 24, 2012 4:01:17 PM

I would just run everything on high, FXAA, native rendering sampling until you see a driver update from Nvidia stating a specific fix or GW2 puts out a fix. I suspect GW2 will put out a performance fix but I think it wont be for a month or more since they do have other bugs etc to work out now..
Anonymous
September 27, 2012 8:29:11 AM

I have exactly the same problem, when i turn camera to see what is behind me, then sometimes my fps fall from around 50fps to 1-5fps. Then after few seconds fps is going back to 50. I have no any problems with other games at maxed settings like battlefield3, witcher2 etc.
My config i5 3570k 4.5Ghz, GB Gtx660ti, crucial m4, 16gb ram, 1920x1080 max settings.
September 27, 2012 10:05:59 AM

I think that lagg while turning is because the GPU has to render a whole new view in a few seconds.. And when some of the objects aren't loaded to the RAM he has to load them first..
I gues.. I'm not sure.. I just think it goes this way.. correct me if I'm wrong
a c 81 Î Nvidia
September 27, 2012 2:44:43 PM

kemperkipie said:
I think that lagg while turning is because the GPU has to render a whole new view in a few seconds.. And when some of the objects aren't loaded to the RAM he has to load them first..
I gues.. I'm not sure.. I just think it goes this way.. correct me if I'm wrong


The last couple posts make me think this game engine is just like Gothic 3's game engine. When ever you enter a new area, when you turn around, it has horrible lag while game files are loaded. After that, it runs smooth. That was one of the worst game engines I've played.
September 27, 2012 6:02:10 PM

nvidia cards aren't doing too well in guildwars 2 from what I see, mostly SLI won't work well. Some other minor problems but the consensus on the gw2 forums is nvidia cards seem to have more problems than the AMD ones. Its the complete other way around with CPU tho.
a c 172 Î Nvidia
September 27, 2012 6:12:57 PM

esrever said:
nvidia cards aren't doing too well in guildwars 2 from what I see, mostly SLI won't work well. Some other minor problems but the consensus on the gw2 forums is nvidia cards seem to have more problems than the AMD ones. Its the complete other way around with CPU tho.

How so? Nvidia don't make CPU's! :lol: 
September 27, 2012 7:36:34 PM

bystander said:
Turn off Supersampling for starters. SSAA for many years has been one of the most insanely demanding settings, and generally not usable on any game that isn't really super easy to max without it.

It is also completely unnecessary to use FXAA with SSAA or visa versa. They do the same thing for the most part, only SSAA is much better at it and far more demanding.

SSAA is not a menace for nvidia 600 series cards I've a gtx 660 ti and I get 38.2 fps in heaven 3.0 with everthing else maxed and 8x MSAA while if I turn MSAA off and use 8x SSAA from nv control panel I get 63.8 fps.
Even anandtech showed how other GPUs get humbled by nvidia 600 series when SSAA is used

http://www.anandtech.com/show/6159/the-geforce-gtx-660-...

I've also started a discussion thread on this here,so feel free to post your opinion there too

http://www.tomshardware.com/forum/371780-33-anti-aliasi...
September 27, 2012 7:39:23 PM

Those results look completely bogus... there's no way you're using true 8xSSAA without your performance getting absolutely crushed. Nvidia probably found a way to cheat it in the drivers.
September 27, 2012 7:46:06 PM

^ how can you prove that?
the image quality is also getting a boost in unigine heaven when I'm using SSAA.
how can you prove SSAA is bandwidth dependent not shader dependent?
September 27, 2012 7:48:04 PM

Image quality getting a boost doesn't mean that SSAA is being used.

Go run The Witcher 2 on any GPU and try to enable ubersampling. That's just 2xSSAA. Watch what happens to your framerate. If you don't have it, try to find some benchmarks of it - you'll see that it cuts framerates roughly in half across all hardware configurations.
September 27, 2012 7:51:26 PM

I don't have the game rite now so I can't tell but I'll surely try doing it asap.
Thanx for the suggestion
a c 81 Î Nvidia
September 27, 2012 9:06:37 PM

Anik8 said:
SSAA is not a menace for nvidia 600 series cards I've a gtx 660 ti and I get 38.2 fps in heaven 3.0 with everthing else maxed and 8x MSAA while if I turn MSAA off and use 8x SSAA from nv control panel I get 63.8 fps.
Even anandtech showed how other GPUs get humbled by nvidia 600 series when SSAA is used

http://www.anandtech.com/show/6159/the-geforce-gtx-660-...

I've also started a discussion thread on this here,so feel free to post your opinion there too

http://www.tomshardware.com/forum/371780-33-anti-aliasi...


SSAA is not available through the Nvidia Control panel. You are probably thinking about SSAA on transparencies. To use SSAA on Nvidia, you either have to use it on a game that has support built in, or use Nvidia Inspector to force it on. On AMD they have it listed in their CCC.
September 28, 2012 8:22:20 AM

ok yes I used the transparency option then
But now I've tried running heaven benchmark again with these settings in nv inspector -



The AA effect was incredible but still I got 63 fps which is 0.8 fps lower.(Also note that I tweaked texture filtering to high quality and LOD bias to -1.5 this time so a drop was expected) still 0.8 fps is negligible.

Also I don't want to hijack this thread as OP's own problems need to be sorted out so its better we discuss these in the Anti-aliasing thread(link of which I've posted already),I only suggested it might not be SSAA hampering his performance.
I'm looking forward to more suggestions from you in the appropriate thread.
September 28, 2012 10:35:50 AM

^^ That's not real SSAA, like I said.

Real SSAA crushes performance, and is at least one of the factors in OP's performance.
September 28, 2012 10:58:53 AM

^ I'll be getting witcher 2 by tomorrow or the day after and will soon give you my feedback with ubersampling.
a c 81 Î Nvidia
September 28, 2012 2:35:07 PM

Anik8 said:
ok yes I used the transparency option then
But now I've tried running heaven benchmark again with these settings in nv inspector -

http://img.techpowerup.org/120928/nvidia_20120928_134011.png

The AA effect was incredible but still I got 63 fps which is 0.8 fps lower.(Also note that I tweaked texture filtering to high quality and LOD bias to -1.5 this time so a drop was expected) still 0.8 fps is negligible.

Also I don't want to hijack this thread as OP's own problems need to be sorted out so its better we discuss these in the Anti-aliasing thread(link of which I've posted already),I only suggested it might not be SSAA hampering his performance.
I'm looking forward to more suggestions from you in the appropriate thread.


Do you see where it said "Antialiasing - Setting", and you have it set to "8xQ [8x Multisampling]", that is the setting we are talking about. That is the AA setting. You have done exactly what they have in the Nvidia control panel under AA Transparencies, which only applies SSAA to a specific type of texture, and not the whole frame.
September 28, 2012 3:16:54 PM

Actually no.When I enable this option in nv inspector I checked nv control panel and nothing changed in the AA transparency setting it was set to custom and still is in custom while the AA setting which I had turned off previously automatically changed to 8x (the options in the list box however are 2x 4x 8xcsaa 8x 16xcsaa 16xqcsaa and 32xcsaa).
What more do you need to know?
September 28, 2012 3:19:53 PM

Bystander is correct. The settings in your screen cap show exactly what I've been telling you (and what your performance has been telling you) - you are not applying SSAA to the whole frame. You're applying MSAA to the frame and SSAA to a few textures.
a c 81 Î Nvidia
September 28, 2012 3:36:08 PM

Anik8 said:
Actually no.When I enable this option in nv inspector I checked nv control panel and nothing changed in the AA transparency setting it was set to custom and still is in custom while the AA setting which I had turned off previously automatically changed to 8x (the options in the list box however are 2x 4x 8xcsaa 8x 16xcsaa 16xqcsaa and 32xcsaa).
What more do you need to know?


I just did a test, and applied the SSAA to the transparency setting you just showed, from Nvidia inspector, and it changed the setting on my Nvidia Control panel. Did you fail to hit Apply or did you apply it to a specific profile, or maybe you had the Nvidia Control panel open as you tried to use Nvidia Inspector?

It's not hard to read, you showed the change of "Antialiasing - Transparencies", why would you think that would change the "Antialiasing mode"? Are you just trying to confuse things so you don't look wrong?

edit: I also applied SSAA to the Antialiasing - mode from Nvidia inspector, and that change the Antialiasing mode inside the Nvidia control panel to "Custom", which is what it should, as the Nvidia Control panel does offer that setting (well, they haven't offered it for a few years, it did exist a few years back).
September 28, 2012 3:36:38 PM

@BigMack70
Then how is it that I get almost half the performance when I turn only 8x MSAA from unigine heaven's own AA setting? :o 
a c 81 Î Nvidia
September 28, 2012 3:39:11 PM

Anik8 said:
@BigMack70
Then how is it that I get almost half the performance when I turn only 8x MSAA from unigine heaven's own AA setting? :o 


8x MSAA is demanding in its own right.
September 28, 2012 3:40:14 PM

Driver-based MSAA might be applied differently than in-game/in-engine MSAA. I don't know enough about the details to know exactly how it works.
September 28, 2012 3:44:13 PM

@bystander why shall I do that when it will affect my own learning experience.I'm talking about the setting where I've used 8xQ [8x Multisampling] not where I've used 8x sparse grid ssaa try to understand... and the former option caused changes in AA setting in nv control panel.
If you think these settings are wrong,please prescribe what settings would you like me to use for doing FSAA,after all you're the one who suggested me to move to nv inspector not me nor BigMack70.So you should know pretty well about enabling full screen SSAA through nv inspector so prescribe the settings you want me to use please....
a c 81 Î Nvidia
September 28, 2012 3:44:37 PM

Btw, the use of MSAA mode + SSAA on transparencies is a good way to go. I am not saying you shouldn't use that setting, as it's a good compromise. It cleans up jaggies on things like leaves and foliage better than just MSAA, and doesn't give the huge penalty that you get with SSAA mode. However, that setting is most similar to AMD's adapative MSAA (which unfortunately doesn't work very often, except on dx9 games).
September 28, 2012 3:49:17 PM

bystander said:
Btw, the use of MSAA mode + SSAA on transparencies is a good way to go. I am not saying you shouldn't use that setting, as it's a good compromise. It cleans up jaggies on things like leaves and foliage better than just MSAA, and doesn't give the huge penalty that you get with SSAA mode. However, that setting is most similar to AMD's adapative MSAA (which unfortunately doesn't work very often, except on dx9 games).

Again I don't have any complains regarding the image quality I was getting along with the high performance,I just want to check how things turn up when I apply/force full screen SSAA thats it.
a c 81 Î Nvidia
September 28, 2012 3:49:57 PM

Try this:
"Antialiasing - Mode" -> "Override any application setting"
"Antialiasing - Setting" -> "2x2[2x2 Supersampling (D3D only)]"

Apply those settings. That will give you the same AA that you get when you set AMD's CCC setting to 4xSSAA (maybe 2xSSAA, it can get confusing, but I believe it's 4xSSAA). This is the setting that Nvidia removed a few years back when they realized that SSAA was too demanding for practical use. However, this version of SSAA is really good on games that aren't too demanding. It works great with Dragon Age: Origins, and used to work good with Risen before updates cause it to not work.
September 28, 2012 4:07:32 PM

okay the settings are this now



still got 63.6 fps

The AA effect was however strange,in some areas it was much better than previous settings while on other areas the 8x transparent SSAA was slightly better.Maybe this was because its comparison of 4x SSAA vs 8x transparent SSAA.
But the framerates are roughly the same.
September 28, 2012 4:09:50 PM

You seem to have a gtx 680 so why don't you try using full screen SSAA from nv inspector and try running heaven 3.0 basic edition at max settings with other forms of AA turned off.And then give me a feedback?
a c 81 Î Nvidia
September 28, 2012 4:50:14 PM

Anik8 said:
okay the settings are this now

http://img.techpowerup.org/120928/nvidia_20120928_213242.png

still got 63.6 fps

The AA effect was however strange,in some areas it was much better than previous settings while on other areas the 8x transparent SSAA was slightly better.Maybe this was because its comparison of 4x SSAA vs 8x transparent SSAA.
But the framerates are roughly the same.


That's not entirely surprising. 8x MSAA is pretty demanding too, which is why most only use 4x. 8x MSAA will result in smoother outer edges around objects, SSAA will result in smoother textures.

I'll have to get back to you on the test. I haven't used those settings in a while, as 4x msaa and 4x SSAA transparencies are a good compromise.
September 28, 2012 4:59:25 PM

I wish I could be there when you get to see what real SSAA in The Witcher 2 does to your framerate :lol: 
a c 81 Î Nvidia
September 28, 2012 5:04:09 PM

I just did testing on Unigine: Heaven, and it just won't work. I'm getting no AA when trying to force it on. Unfortunately, forcing AA on is a hit and miss proposition. That might be why you aren't seeing a difference. The only other possibility is the newer Nvidia drivers aren't supporting Nvidia inspector, but I have used it to force 120hz on games that weren't allowing me to get 120hz, so I think it just might be a case of not being able to force it on. I also do not have GW2 to test if it's working there or not.

Edit: I did some testing on Skyrim, hoping a Dx9 game might work better, and I am unable to force on any form of AA through Nvidia inspector, even the normal MSAA modes. I could not even force AA modes through the Nvidia control panel.

I have noticed that this is the case more and more, that game engines don't allow you to force settings on. Here is an example from a test THG did on AA: http://www.tomshardware.com/reviews/anti-aliasing-nvidi...
September 28, 2012 5:38:58 PM

Try the anti-aliasing compatibility codes.In one of them my framerates reduced to 40 fps or so.
And does guild wars 2 have built in SSAA like portal 2 or sleeping dogs or is it that the OP is also using this through control panel/inspector?
a c 81 Î Nvidia
September 28, 2012 5:45:22 PM

Anik8 said:
Try the anti-aliasing compatibility codes.In one of them my framerates reduced to 40 fps or so.
And does guild wars have built in SSAA like portal 2 or sleeping dogs or is it that the OP is also using this through control panel/inspector?


I don't know about GW2, most games don't support it, but I do recall Rift did, it's possible that GW2 does too, I don't know.

I read something about how many games that were written to work on consoles, were written in such a way that traditional methods of AA won't work, and it's possible that this style of coding is just more common. I've also read that Dx11 also has difficulties with forcing AA.

Obviously something kicked in with the compatibility codes, unfortunately, I'm not sure what. I'm just going to leave as it is. It won't work on Unigine or Skyrim and it sounds like you couldn't force it on in GW2 either, unless that compatibility option did the trick.
September 30, 2012 10:07:30 AM

BigMack70 said:
I wish I could be there when you get to see what real SSAA in The Witcher 2 does to your framerate :lol: 

Yep ubersampling is hitting it hard alright... at 1080p max settings,ubersampling is reducing performance almost 3 folds especially when in the dense jungle area.
!