Sign in with
Sign up | Sign in
Your question

AMD Radeon 6950 3rd monitor not working

Last response: in Graphics & Displays
Share
September 24, 2012 8:32:36 AM

Hello,

3 monitors (2 DVI and 1 display port)
with only the 2 DVI connected everything works fine, when i plug in the DP cable i get the message

"The system has detected a link failure and cannot set the requested resolution and refresh rate on your DisplayPort display"

it is an active cable and was working until i accidently unplugged it. the system recognizes its plugged in and even gives me the model of the monitor I have plugged in.

hoping its something i can fix without having to order in a new cable and praying i did not fry my card.

EDIT: also forgot to mention, when the DP is plugged in the system limits its resolution to 800x600 (no pic but settings show the low resolution) and the monitor plugged into the top DVI port also gets dropped to 800x600
a b C Monitor
September 24, 2012 8:43:22 AM

Have you tried any of the other ports? (Or the other port...)
m
0
l
September 24, 2012 8:47:39 AM

both ports have the same issue, also tried different monitors on the cable and tried different DVI cables to the DP adaptor all signs i can see are either issues with the cable, the GPU or something set wrong on the software side (getting eyefinity to work properly always seemed to be a strugle)
m
0
l
Related resources
a b C Monitor
September 24, 2012 8:53:17 AM

Maybe fiddle around with CCC a bit and see if you can't get anything to budge.
m
0
l
September 24, 2012 9:35:52 AM

edited top post with new info
m
0
l
!