Sign in with
Sign up | Sign in
Your question

No boot device available.

Last response: in Systems
Share
November 20, 2012 4:54:21 PM

Im home on break trying to help my brother with his computer issues. Here is his known hardware:

Mainboard: ASRock Z68 PRO3 GEN3
GPU: XFX HD-687A-ZHFC
PSU: Corsair TX-750
CPU: i5 2500k
RAM: Team Xtreem Dark Series 8GB
HDD: Seagate Barracuda 7200.11 ST31500341AS 1.5TB

The issue stated seemingly at random. He tried to start his computer one morning and got an error saying something along the lines of "No boot device available press any key to continue". He tried returning his HDD for a replacement and the new one does the same thing. Heres what I have done thats made it semi-bootable now:

First reset CMOS. No change.
Changed to AHCI in BIOS which allowed me to recognize the drive and reinstalll Windows 7.
After rebooting, same error message popped up.
Switched the SATA port the HDD was plugged into.
Windows booted.
After rebooting it booted again.
After being off over night it gave the same "No boot device available" message.
Swapped ports and it was able to boot again.
Did a startup repair off of win 7 disc, did not find anything.
After a google search found out I could switch two registry entries under HKEY_LOCALMACHINE (msahci and iaStorV) to fix the issue.
After changing both start values to 0 on the two registry entries, the system now boots sometimes and other times give me the same error.

After all of this Im not sure what to try. The HDD isnt making any strange noises, and has passed the long tests on Seatools with no errors. I dont know what else to try at this point. Any help is appreciated.

More about : boot device

a b B Homebuilt system
November 20, 2012 5:19:41 PM

Have you tried using a different SATA data cable?
m
0
l
November 20, 2012 5:20:52 PM

Ah yes, sorry. That has been tried as well, I should have mentioned that.
m
0
l
Related resources
a b B Homebuilt system
November 20, 2012 5:45:07 PM

That motherboard model was plagued by quality issues so it doesn't surprise me one bit that you're having problems.
m
0
l
November 20, 2012 9:05:35 PM

Is there anything I can do to test and rule out the HDD to be sure it's the motherboard? At this point I feel it could be either one.
m
0
l
a b B Homebuilt system
November 20, 2012 9:37:39 PM

make sure your using the intel chipset for the sata drive. m,ost newer mb will have intel and a 3 party chipset. you can try using the other chipset and see if the drive works. with drives that work and dont work it could be that the drives or the replacment is spining up slow. most drives and chipset have to have a nice handshake and tell them that there ready. i would try the vendor test tool and hd tune and read the smart info to see if there an issue. if it not the drive it could be the sata controller or a power issue. where the power supply not supply full 12v to the drive. one last thing to check is to see if there are any bios updates for the mb.
m
0
l
November 20, 2012 11:10:29 PM

BIOS is up to date, and I tested the PSU with a multimeter to see if it was outputting the correct voltages with no load. Since the PSU was outputting correct voltages I tried it in an older PC he had in the closet. It booted just fine so I dont think the PSU is the cause. Ill try changing the chipset now and see what happens. The drive is currently booting but I have no way of knowing if/when it will give the error message again.

Looking online I've seen that a lot of people have had similar issues with this series of seagate drives. Im thinking of just having him send it back for refund and picking up a nice WD or Hitachi drive on black friday. I'll also have him RMA the motherboard for replacement just in case that is the issue.
m
0
l
!