Sign in with
Sign up | Sign in
Your question
Closed

Radeon 6950 BSOD, please help

Last response: in Graphics & Displays
Share
September 25, 2012 10:07:26 AM

Hello everyone, I've finally finished building my PC which took a lot longer than expected so I have some last generation parts, but don't mind that.

PC:
CPU: Intel i7 2600k 3.4(3.8)GHz
RAM: G-Skill Ripjaws 4x4gb 2133MHz (they also run at 1600 for some reason, but that's another issue)
MOTHERBOARD: ASRock extreme4 gen 3 Z68
GPU: XFX Radeon 6950 2GB (not unlocked or overclocked)
PSU: Corsair CX 600 watt
SSD: Mushkin Chronos 60gb (no HDD installed other than that yet)
CASE: Collermaster CM 690 II (if this matters at all)

Anyway, after finishing it, I noticed my CPU ran at 97 degrees celsius on startup (no overclocking or turbo boost), which seemed somewhat dangerous to me. The performance of the CPU was also a lot below what it should have been. So, after searching around the web I found out that i should update my BIOS and it would fix my CPU issues. it's also worth noting that other than this everything else on the PC worked flawlessly.

I downloaded the latest, 2.20, BIOS, flashed my MB using the instant flash method on startup. After this the computer refused to boot to anything.

I took out all my RAM, except the A1 socket, my GPU, connected my DVI to my MB, and took out the MB battery for a few minutes. After starting the computer it finally worked and I was relieved. I turned it off and put my GPU and RAM inside. Once again it refused to boot. So I took my GPU out and it once more refused to boot with the RAM.

I kept trying different combinations and finally somehow managed to make it work with all 4 sticks (the original RAM issue may have been my error due to maybe playing them incorrectly).

I finally started the PC once more to see if everything worked in Windows (7, genuine, 64bit, by the way). Running on intel integrated graphics the display was crisp, however I instantly got errors from CCC complaining something along the lines that there's no GPU connected (there wasn't) and if I remember correctly that there was an error with it.

I plugged my GPU in, ran the PC, got BSOD. I tried a different PCI-e socket, ran it, it worked, but no drivers were running for some reason and I was at 640*480. I deleted the drivers properly using a sweeper (there was absolutely no trace of them left), rebooted and installed them again (everything worked since there were no drivers). I rebooted the PC again and got another BSOD. I kept repeating this procedure with the same results. The BSODs occur just after the windows logo finished loading.

I tried drivers a few versions older and I tried the new beta drivers with the same results.

I also can't enter BIOS, I try pressing F2 and del when prompted, however I just get into a black screen, and DR. debug (only in this case) displays error code A9.

Please help, I've exhausted all my knowledge and now seek help from someone more experienced.

More about : radeon 6950 bsod

September 25, 2012 7:34:14 PM

bump :/ 
!