Sign in with
Sign up | Sign in
Your question
Solved

Cisco VPN not connecting to websites on XP, but works in Windows 7

Last response: in Networking
Share
November 10, 2011 3:54:55 PM

I am doing some remote work for a company and their website. I can only connect to the development server when I am logged into the VPN (Cisco VPN)
I do most of my work on my desktop, which is running XP sp3. While logged into the vpn there, I can reach the SVN and FTP servers fine, but I cannot connect to the development website to view anything.
I also have a laptop that is running windows 7. When I connect to VPN on that, I can connect to the website just fine. It is all from within my house so using the same router / cable modem / internet service. Both have installed the latest Cisco VPN softare, and use the same profile to connect.
The differences are, windows 7 vs Windows XP. Windows 7 is running Microsoft Security Essentials and XP is running Comodo. However, even when I turn off Comodo on XP I still can't connect to the website. (Just FYI, I also have XP as dual boot on the laptop and tried connecting from it but no go)

I am getting absolutely no help from the company I am working on, so really can't ask them anything, I guess it is something I have to figure out myself.
But it is frustrating me. I prefer to work on my desktop and it is set up in with all my development tools etc in a nice environment, where the laptop is noisy and slow and not a preferred work place.

So I am wondering what else I can check or if anyone has any ideas on why this might be happening?
Please let me know if I can provide more information.

Thanks much.
November 10, 2011 4:24:13 PM

Not sure what the problem is, but what you might do, at least as a temporary workaround, is use a remote desktop solution to access your laptop from the desktop. Depending on the software (RDP, VNC, LogMeIn, etc.) and differences in screen resolution, it may or may not be practical.

You might also try sharing the VPN client connection using ICS (and perhaps Connectify to establish an AP/repeater on the laptop). I’m not sure if they offer that option, depends on how the VPN client is integrated into the OS. For example, I can do this w/ the Microsoft PPTP VPN client. Others can leverage my VPN connection without having a direct connection of their own.

Again, these are just workarounds for now.
m
0
l
November 10, 2011 9:49:28 PM

OK thanks for the suggestions, but I can workaround by just using my laptop sitting next to the desktop on my desk.

m
0
l
Related resources
November 10, 2011 10:50:48 PM

I was assuming there were other benefits to using the desktop beyond mere location (keyboard, screen size, tools, etc.). I know for myself I can only work off a laptop for so long before feeling cramped and straining my eyes. But whatever.

You say the only difference is XP vs. Win7. But that leaves open a lot of possibilities. Could there be an issue w/ differences in browsers? Maybe you’re running different versions of IE? Can you ping the machine w/ the HTTP server? IOW, can you tell if it's a case of being denied access based on IP address vs. the service (regardless of IP)? You're just gonna need to poke around a little more to see if you can't narrow down the real difference.
m
0
l
November 11, 2011 2:35:27 PM

Hi, I do appreciate any suggestions! At this point I am only using the laptop to view the pages, not actually doing any work on it. It would just make things a lot easier if I could view the pages on the desktop as well.

I can poke around on my pc but I am not getting any answers at all from the other end, that is why I am posting here. It could be browsers, but I have tried Chrome, Firefox and IE and still cannot connect within xp and all work in 7.
It is only the website I cannot connect to, I can connect to all the other services behind the VPN. I have also worked with other companies that also use cisco VPN, and have no trouble connecting to pages that require the VPN to use. So it could still be the way they have things set up, I just need to present a request saying - hey can you check X ?

Last night I put virtual PC on win7 so I can test the site in older versions of IE. So while running Windows XP Mode, I can connect to the site (but the VPN is running in win7, so really the connection is still going through win7). I am just not sure what else to look at.

I don't get a page not found message - the message I get when trying to browse to the page is:

Problem loading page
The connection was reset
The connection to the server was reset while the page was loading.

> Can you ping the machine w/ the HTTP server?
Yes
> Can you tell if it's a case of being denied access based on IP address vs. the service (regardless of IP)?
How do I test this? But I doubt it, from my laptop, all works fine within Win7 but not XP (also on laptop, dual booted), that should be using the same IP

> You're just gonna need to poke around a little more to see if you can't narrow down the real difference.
Yes I need some suggestions on what else to check!

Thank you!

m
0
l

Best solution

November 11, 2011 7:15:52 PM

Based on that info, it's pretty clear this isn't a problem of basic connectivity. It's not as if the IP address isn't being located, or even inaccessible. It seems to be talking to the server, attempting to grab files, and then chokes.

Could you possibly have a proxy configuration enabled under IE (something you forgot to disable)? Or maybe some add-on/plug-in is getting in the way? Or maybe some security tool on your client is blocking access? I know this is all rather vague, but it’s hard to provide specifics. But that’s where I’d be looking at the moment.

I assume this is strictly HTTP, not HTTPS, right?

The only other thing that might help is to use telnet to access the webserver and see if you might detect anything unusual in the response messages (the Windows browser may be obscuring those details). Not everyone realizes it, but it is possible (if awkward) to communicate w/ a webserver over telnet, if you know the protocol.

http://support.microsoft.com/kb/279466
http://kalanir.blogspot.com/2008/10/how-to-telnet-to-we...


Share
November 11, 2011 8:53:05 PM

OK, I feel stupid now.

Turns out it is Comodo Firewall. I would swear I had tested this by turning off the firewall and was still not able to connect, but apparently I didn't do it properly!
I just checked that out again after not being able to even telnet to the webserver. Completely turned off the firewall and then suddenly I am able to get there! So apparently last time when I was checking that I didn't do it right. Who knows.

Thanks for your suggestions and taking the time to help me as they made me think in new directions.

Thanks again!

m
0
l
November 11, 2011 8:53:31 PM

Well actually now have to figure out what specific thing in the Comodo firewall is blocking this specific address, but at least it is a step in the right direction!
m
0
l
November 11, 2011 8:53:41 PM

Best answer selected by xnera.
m
0
l
November 11, 2011 9:25:48 PM

Sometimes you just need someone's else input to find the answer for yourself. At least you did find the problem. Good luck.
m
0
l
November 16, 2011 4:39:48 AM

Or maybe it's your own VPN that has a problem. Cisco's very good but nothing's perfect yet. Just sharing because that was the problem with my recent VPN service provider ha ha! If you want you can try this, one of the best VPN out there in the market so far.
m
0
l
November 17, 2011 6:20:30 AM

It's the firewall that's the problem and not the VPN service provider it self. Though it can be the problem of the server but as long as it's about the repair service for such problems haha. I've just checked what mlacieta's talking about and it does seem to be one of the good stuffs in the internet. For more information on what we're talking about just check this best VPN.
m
0
l
!