Sign in with
Sign up | Sign in
Your question

Windows doesn't enter sleep state but crashes instead

Tags:
  • Windows 7
Last response: in Windows 7
Share
January 25, 2010 12:19:27 PM

Hi everyone. I've been having some trouble with configuring my desktop to enter sleep mode. I've already tried normal sleep, hybrid sleep, hibernate but they all seem to have the same problem. Whenever they enter sleep the first time, all is good.. I can wake it without a problem. But when it enters sleep a second time, it unexpectedly shuts down instead. I have to power it on from square one and select "Start Windows Normally" on the recovery screen. In my Event Viewer, I noticed this particular error:

The platform firmware has corrupted memory across the previous system power transition. Please check for updated firmware for your system.

This is my setup:
GA-EX58-UD4P (BIOS version F8)
Core i7 920
Sapphire ATI Radeon HD4870 Toxic 1 GB
OCZ 6 GB DDR3
RealPower 620W

Anyone know how to fix this?

More about : windows enter sleep state crashes

a b $ Windows 7
January 25, 2010 5:53:52 PM

Run memory test to see if any problems showup. You could also try removing some ram, assuming you have 3 x 2gb sticks, try it with one first and see if the problem goes away, then add another untill the problem reappears.
m
0
l
January 25, 2010 7:27:14 PM

I'll try to run the memory test soon. I've updated my BIOS to F10K (a beta version) and it seems to have resolved the random unexpectedly shutdowns of before. I flashed it because it was suggested as the answer to the error I had.

However, though it appears to have fixed the sleep issues, I still get the errors I mentioned in my previous post. I think the two issues are unrelated. Is the error something I should be worried about or could I just ignore it?

ps. I noticed I forgot to mention I have Windows 7 Ultimate (64 bit)
m
0
l
!