Sign in with
Sign up | Sign in
Your question

AMD Radeon HD 7970 - No Sound - HDMI - HDTV

Last response: in Graphics & Displays
Share
September 27, 2012 6:20:43 AM

I connect my AMD Radeon HD 7970 graphics card to my hdtv with hdmi to hdmi cable, and I get no sound from my computer. I've checked under Control Panel/Sound and it says "realtek hdmi output, not plugged in." It is plugged in there is video but no audio, i tried a different hdmi cable, and tried different hdtv, but still no sound. I can't change realtek hdmi output to default device since it thinks the cable is unplugged. I don't know how to make it work, I just got this computer today, and I think it came with all the latest drivers. My laptop gets Sound and Video from hdmi cable but not my desktop computer. How do I get my tv speakers to play sound?
September 27, 2012 9:24:41 AM

It should not be Realtek HDMI drivers. It should be AMD/ATI HDMI drivers because you connect HDMI cable to the AMD gfx card and AMD HDMI audio can be output from there. Please check first Device Manager / Sound, video and Game controlers and expand it. There shoud be AMD/ATI HDMI sound driver installed.If it is installed, then you should enable AMD/ATI HDMI output in Control Panel / Sound. Again not Realtek.

If your motherboard has HDMI output, too, and you use it, then Realtek drivers may take control of sound.
September 27, 2012 1:01:57 PM

i see ati hdmi audio in device manager, it says it's enabled. In the same sound option where it says "Realtek HDMI Output" It says right under it "ATI HDMI Audio" and still says not plugged in, tried to disable and enable in device manager but that didn't work.
my motherbord is gigabyte x79 and intel core 3930k, no video outputs on it.
Related resources
September 27, 2012 1:26:25 PM

which hdmi port you using? the one on the video card or the one on the motherboard?

The audio from the graphics card will be recognised as amd high definition audio device and most likely have a tv as it's icon in playback devices since thats where the sound is going.

realtek hdmi output is from the motherboard
September 27, 2012 1:41:21 PM

Is your HD TV the only display device connected to your computer or is there another monitor as well ? If HD TV is the second monitor, then please make it the primary monitor and see if sound is heard from it.
October 4, 2012 4:33:03 PM

The only hdmi port is on my video card, my mother board doesn't support intergrated video, Intel Core i7 3930k, AMD Radeon HD 7970, Gigabyte X79 UD3 Motherboard, my audio is intergrated. My HDTV is the only one connected and is set to be the primary display, I still don't know how to fix the problem, but I do connect my stereo to get sound. So i guess this can be closed.
December 5, 2012 2:38:46 AM

I don't know if anyone has found an alternative to this, but I found that it helped if you went to the realtek website and downloaded the ati sound driver then installing it only after uninstalling all other current devices. Also, if this works for you then i would advise not installing the hdmi audio part of the ccc (catalyst) updates as it seems to me that the realtek and amd sound drivers conflict.
December 14, 2012 3:03:40 AM

Kherus said:
I don't know if anyone has found an alternative to this, but I found that it helped if you went to the realtek website and downloaded the ati sound driver then installing it only after uninstalling all other current devices. Also, if this works for you then i would advise not installing the hdmi audio part of the ccc (catalyst) updates as it seems to me that the realtek and amd sound drivers conflict.


Yes I also certainly believe there is a conflict with AMD and Realtek..After trying many different scenarios I discovered if you keep the Realtek driver uninstalled - HDMI audio from the graphics card will work.

What was really weird was that before my last reinstall of MS OS7 I was able to have both my onboard Realtek and graphics card HDMI sound working..all i did was uninstall everything, ran CCleaner once and both worked.

Now it seems I can only get the graphics card HDMI sound working when I take out the Realtek driver
April 14, 2013 8:01:13 AM

Had same problem with my HD5000 series card. This what I did:
1: Disabled on-board sound device (Realtech) in BIOS
2: In Control Panel, System, Device Manager, Sound Video and Game Controllers - DISABLED AMD High Definition Audio Device
3: In Control Panel, System, Device Manager, Sound Video and Game Controllers - ENABLED AMD High Definition Audio Device
4: All now working
October 8, 2013 7:20:52 AM

I have a HD 6850 with this problem as well. My motherboard HDMI does not input sound for my TV and it used to, I've just set up speakers to plug into my computer to workaround this issue because I couldn't fix it.

Recently AMD was found to be disabling 3rd party DVI to HDMI adapters through their catalyst drivers. http://www.phoronix.com/scan.php?page=news_item&px=MTQ4...

I wonder if it might also be interfering with our realtek drivers as well.
November 29, 2013 12:34:13 AM

For windows 7/8 -> Right click on the speaker icon on the task bar -> goto playback devices -> You should see list of installed drivers(either it could be default audio drivers or the Graphics card audio drivers) -> right click on the desired one and select SET DEFAULT. Hope this should solve the problem
March 5, 2014 7:15:34 PM

Dinesh posted the answer. Pick whatever device/source as sound output you want and set as "default". For example, if I want to watch youtube documentaries on my tv via hdmi ( hmi also plugged in my graphics card hdmi port), then I set the TV as default. Then if I want to play some late night games quietly and plug the headset in, there's no sound in the headset until I set the headset as default. If you need sound from your computer and connected peripherals, then set the audio software ( realtek for me) or connected speakers as default. Just manually set devices to default as needed. There's probably a better way to do this but a few clicks is not much of a hassle.

Hope this helps. It stumped me too until I accidentally right clicked on the speaker icon and found all those options. No need to do all the other crazy stuff people posted.
!