Sign in with
Sign up | Sign in
Your question

Viewing dvr over internet

Last response: in Networking
Share
November 11, 2011 3:53:45 PM

Hello, I am trying to setup a D-link 614+ router to be able to access my dvr via the internet.

The dvr is setup with ports 5000/5005 (5005 is the public port).

When I power up the D-link router the ports show up in the firewall settings automatically. So now I add a virtual server with the same ports, but when I enter the dns address to get to the dvr it says "unable to connect". I can get to the dvr via the local LAN 192.168.0.100:5005.

I restarted the dvr and I can see in the Dlink log an entry saying "DHCP lease IP 192.168.0.100 to unknown". From IE I tried to enter my IP 108.28.xxx.x:5005 but I get an "unable to connect".
This thing is killing me because I had it working at one time but had to reset my router and I didn't write down what I did to make it work. Could someone please help me get over my frustration?

More about : viewing dvr internet

November 11, 2011 4:22:00 PM

Give your dvr a static IP address, then port forward 5005 to the IP address assigned to the dvr.
November 11, 2011 4:47:54 PM

Thanks. I tried this but still get only the same results. THe only thing that changed looking at the log is it now says "DHCP lease IP 192.168.0.100 to BCL DVR" instead ...to unknown.

I don't even know if the request from IE via the internet goes to the router and then to the DVR. Is there a way to check whether I can sort of like ping to the DVR?

I checked with my ISP and the settings all look good. I also checked the modem and have that set to wide open to allow ALL traffic.
Related resources
November 11, 2011 5:01:35 PM

Ok, I'm sure this is obvious, but I don't know your technical level. If you set a staic IP address for the DVR and port forward as I stated in my last post... when you connect from the outside world, you need to use the WAN address of your router. If the WAN address is 65.189.217.98, then when you try to access the dvr remotely you need to use this in your browser:

http: //65.189.217.98:5005 (space added so it doesn't show as a link)

The router will then forward to the IP address you assigned to the dvr via port forwarding.

Unfortunately, your ISP can change your IP address and sometimes even rebooting your modem will change the IP address. You will either need to check your new WAN IP address or use something like DynDns.

http://free.domain.name/en.html
November 11, 2011 5:15:37 PM

I tried this again entering the URL with a space as you said, but no difference.

I am using dyndns. So from the internet the request should go to my address at dyndns, then to the modem, the router and from there forwarded to the DVR. The same on the return I suppose.
November 11, 2011 5:32:50 PM

Great, I didn't know you are using DynDNS. The link in my previous post, the one with the space, was an example.

Make sure dyndns is actually pointing to your router's WAN address. Check your router logs to see if it's actually forwarding to your dvr or if it's dropping the packets.

One way to make sure your dyndns is pointing to the correct address is to try to remote into your router. You will need to temporarily turn on remote management if it isn't already and be sure your router has a password set up - not the default password!!!

If you can't remote into your router, then dyndns hasn't been updated with your new address.

The port forwarding is too simple to fail, as long as you are sure you have the correct IP address of the dvr and the correct port number.
November 11, 2011 5:36:36 PM

ok Hawkeye22, here is what I did trying to set everything back to what I believe worked for me at one time before messing it all up.

I set the DVR config to: DCHP,Media port 9000 and Web port 80.

The router firewall setting picked it up after I restarted the dvr.

I set the virtual server to 80/80 and put it back to DCHP instead of static in the router and dvr .

I can get to the DVR using 192.168.0.100 just fine.

But when I enter the dyndns URL without a port number I get the same "unable to connect"

You can see I am shutgon'ning around because I am so frustrated.

November 11, 2011 5:40:26 PM

You need the port number when you use your dyndns domain. That is how the router knows which internal IP address to forward to, in this case, 192.168.0.100.
November 11, 2011 5:40:47 PM

I ched with dyndns and the IP is still good
November 11, 2011 5:42:00 PM

on the router where the remote setup is configured, do I enter my WAN IP or the IP of the computer that is connecting remotely?
November 11, 2011 5:47:45 PM

You shouldn't need an IP address for remote management unless it's requesting the address(s) that you are allowed to remote in from. If any is an option, set it to that, otherwise you will need to know the ip address of the computer you will be using to remote in from.
November 11, 2011 7:03:14 PM

seems that I can't even get into the router. set the port to 1080 and when I enter the WAN IP and port it just sits there and then saying unable to connect. I need a drink.....
November 12, 2011 1:11:01 PM

I'm refreshed and trying it again. Looking at the router's log it says "DHCP lease IP 192.168.0.100 to" with no destination entry. The note says "00-11-22-77-84-32", which is the MAC of the DVR. Can you tell me if the destination comment should say what the destination should be and if yes what am I supposed to see there?
November 14, 2011 11:10:23 AM

Weird that remote management won't even work. I don't know if that's typical for your router. I have a dlink router too (DGL-4100) and I get stuff like Assigned new lease 192.168.2.102 to client 001FA74AXXXX.

You might want to check you remote management settings. It may have filters for date/time as well as allowed addresses. I have my remote management set up so that only my pc at work can use it and it has to be a mon - fri (weekday), 7:00am - 5:00pm.
November 20, 2011 7:56:58 PM

So, I finally go this thing going again. I can now watch my DVR over the Internet again.

Don't ask me what exactly was wrong, but in the end I was sure that I could setup port forwarding in my dreams, with my hands tight behind my back. I ended up resetting the modem and that did the magic.

Thought I post a resolution in the event someone else is dying to know what it was. he he he
!