Sign in with
Sign up | Sign in
Your question

New graphic card problem - display comes and goes

Last response: in Graphics & Displays
Share
September 28, 2012 1:16:38 AM

Hello,

I recently (probably about two weeks ago) upgraded my video card to a Gigabyte Radeon HD7870. The install went off without a hitch and the drivers updated nicely. Up until now, it's been working fine.

Tonight, I come home and wake my computer and there is no picture. Ok, so I restart. No picture again. I know it boots up because the Windows Login tone plays. This time, I tried leaving it on and checked the monitor connections, both connected securely.

So after about five minutes with it on, I tried restarting it again. This time, the picture shows up as it goes through BIOS and the Windows load, but before it gets to the sign in, the picture goes out again. The only thing I can think of that's different tonight, is I left the windows open before I went to work and it got a bit chilly. My computer, while not directly under the window, is in line of the draft and the room's temperature is much cooler than normal.

I'm not sure what might be wrong or what else I can try.

EDIT: I just tried restarting again and it is possibly a problem with Windows as it never gets to the login screen. I will try reinstalling Windows.

EDIT2: Nevermind; tried entering BIOS and after about ten seconds, the display still goes out.
a b U Graphics card
September 28, 2012 1:21:52 AM

does your POST screen come up??? do you have on die gfx you can try???
m
0
l
September 28, 2012 1:37:18 AM

I think I have it working now. I opened it up and it looked like one of the wires connecting the power supply might have been loose. It seems to be working now so fingers crossed.
m
0
l
Related resources
September 28, 2012 2:09:35 AM

Thanks. I'll try turning my monitor sleep off as well as rolling back my update. I'll keep this in mind should it happen again.
m
0
l
September 28, 2012 2:10:39 AM

Best answer selected by sirius101.
m
0
l
!