Sign in with
Sign up | Sign in
Your question

[AMD Radeon HD] audio stutters everywhere, except in games

Last response: in Graphics & Displays
Share
September 29, 2012 10:48:12 PM

I am completely stumped by this... Forgive me for the long description, but a lot of troubleshooting has occurred - but I'm no closer to determining the source of the problem.
This is a brand new build that was put together 9/27/12. The problem has happened since day one.
Specs:
i5 3570k CPU - stock cooler, no OC
ASUS P8Z77-V board
Corsair 750 watt modular PSU
Sapphire Radeon HD 7950 Vapor X
Kingston Hyper X 120 GB SSD (boot and basic programs)
WD Caviar Black 1TB HDD (data/media, including games)
8 GB Gskill Ripjaws X RAM @ 1600
8 GB Team Black series RAM @ 1600 (came free with board)
Windows 7 Ultimate 64 bit
this is connected from the GPU to a 40 inch Sony TV via HDMI cable

As soon as Windows was installed, before the Sapphire/AMD driver disc was run, I noticed the various Windows dings and chimes had a stutter. By stutter, I mean it is like the sound is continuously cycling in and out about every 1.5 seconds. This happens to ANYTHING... youtube video, netflix, videos played via VLC or windows media player, MP3s, and it does not matter which drive the source material is on.
I have tried changing HDMI cables with a known good one, I have checked and double checked that all the AMD sound and video drivers are up to date, as well as the Realtek drivers that are for the on board audio and such. For awhile I thought the cause was the SSD, however, if I plug headphones in and run the audio through the realtek system, there is no problem. It plays perfectly fine. I have tried disabling the realtek drivers, and using the AMD audio as the source, but it makes no change. I have not uninstalled them, mostly because I want to be able to use headphones occasionally. This has lead me to think the SSD is not the culprit... but it gets even weirder... If you leave AMD HD Audio as the source - where all the video and windows sounds skip/stutter, and run a Steam game (Borderlands 2, Skyrim) the audio in the game is perfectly fine, which tells me the Video Card and TV are fine, and makes me not suspect anything else hardware related.
I am at a loss. This PC is for my fiancee and I feel terrible that it is doing this and no one knows why, or how to fix it. ANY help would be greatly appreciated!




October 2, 2012 3:41:17 AM

Defective motherboard.
m
0
l
October 2, 2012 9:36:14 PM

No.
I have found a temporary solution. Enabling LCD Overdrive in the Catalyst Control Center, then disabling it, seems to clear up the audio. No clue why this works, but it does. The only downside is I have to do it after every reboot. I have submitted the issue to AMD.
m
0
l
Related resources
October 10, 2012 1:56:13 PM

i have the same problem, have you gotten any reply from amd, or found a permanent solution?

Thanks
m
0
l
December 31, 2012 7:32:26 PM

Same bug here. Same fix. Shame on you amd.

Also ivy + z77
m
0
l
December 31, 2012 7:54:03 PM

snavemada5 said:
I am completely stumped by this... Forgive me for the long description, but a lot of troubleshooting has occurred - but I'm no closer to determining the source of the problem.
This is a brand new build that was put together 9/27/12. The problem has happened since day one.
Specs:
i5 3570k CPU - stock cooler, no OC
ASUS P8Z77-V board
Corsair 750 watt modular PSU
Sapphire Radeon HD 7950 Vapor X
Kingston Hyper X 120 GB SSD (boot and basic programs)
WD Caviar Black 1TB HDD (data/media, including games)
8 GB Gskill Ripjaws X RAM @ 1600
8 GB Team Black series RAM @ 1600 (came free with board)
Windows 7 Ultimate 64 bit
this is connected from the GPU to a 40 inch Sony TV via HDMI cable

As soon as Windows was installed, before the Sapphire/AMD driver disc was run, I noticed the various Windows dings and chimes had a stutter. By stutter, I mean it is like the sound is continuously cycling in and out about every 1.5 seconds. This happens to ANYTHING... youtube video, netflix, videos played via VLC or windows media player, MP3s, and it does not matter which drive the source material is on.
I have tried changing HDMI cables with a known good one, I have checked and double checked that all the AMD sound and video drivers are up to date, as well as the Realtek drivers that are for the on board audio and such. For awhile I thought the cause was the SSD, however, if I plug headphones in and run the audio through the realtek system, there is no problem. It plays perfectly fine. I have tried disabling the realtek drivers, and using the AMD audio as the source, but it makes no change. I have not uninstalled them, mostly because I want to be able to use headphones occasionally. This has lead me to think the SSD is not the culprit... but it gets even weirder... If you leave AMD HD Audio as the source - where all the video and windows sounds skip/stutter, and run a Steam game (Borderlands 2, Skyrim) the audio in the game is perfectly fine, which tells me the Video Card and TV are fine, and makes me not suspect anything else hardware related.
I am at a loss. This PC is for my fiancee and I feel terrible that it is doing this and no one knows why, or how to fix it. ANY help would be greatly appreciated!





Go to your sound card’s control panel.
Locate the option that allows you change the default audio format for the card.
Set the default format to 24-bits, 48000Hz or less (if it doesn't work with 48000Hz, try 24 bits, 44100Hz)
m
0
l
January 13, 2013 11:22:17 PM

Same problem, same temporary-only fix. The solution that snavemada5 suggested makes no difference at all for me.
m
0
l
May 23, 2013 10:56:18 AM

Update your bios, I was having the exact same issue but now it is fixed.
m
0
l
December 1, 2013 1:09:03 PM

The 2d clocks are set to low . That's why it does not stutter in games or while in 3d clocks. You must use a program like Radeon pro to set programs to run in higher clock mode. You will get no help from AMD and I had to figure this out on my own. I had a 7970 that did this while watching movies. If the core dropped below 500mhz it cracked every few seconds. I went in and upped it to 700mhz and problem solved.
m
0
l
!