Sign in with
Sign up | Sign in
Your question

Video Hardware Error!

Last response: in Graphics & Displays
Share
September 30, 2012 2:36:38 PM

Hello!

I have a serious problem with my computer. Everytime I play a game for a while my graphic card suddenly stops working and the computer crashes!

This is not becouse of bad computer, I have a brand new computer and no lag what so ever, only problem is the video hardware error

SPECS:
Intel i5 3570k (factory turbo, no oc)
12gb ram Kingston hyperx 1600
AMD Radeon HD 7850, sapphire 975hz OC version
Gigabyte Z77-DS3H (bios vers F3)
OCZ Fatality 750W power supply
Kingston SSD HyperX 120gb harddrive

WHO CRASHED REPORT
On Tue 3.7.2012 14:20:33 GMT your computer crashed
crash dump file: C:\Windows\Minidump\WD-20120703-1720.dmp
This was probably caused by the following module: atikmpag.sys (atikmpag+0x8768)
Bugcheck code: 0x117 (0xFFFFFA8009F124E0, 0xFFFFF88006A86768, 0x0, 0x0)
Error: VIDEO_TDR_TIMEOUT_DETECTED
file path: C:\Windows\system32\drivers\atikmpag.sysproduct: AMD drivercompany: Advanced Micro Devices, Inc.
description: AMD multi-vendor Miniport DriverBug check description: This indicates that the
display driver failed to respond in a timely fashion. A third party driver
was identified as the probable root cause of this system error. It is suggested
you look for an update for the following driver: atikmpag.sys (AMD multi-vendor
Miniport Driver, Advanced Micro Devices, Inc.). Google query: atikmpag.sys Advanced Micro Devices, Inc.
VIDEO_TDR_TIMEOUT_DETECTED


4 crash dumps have been found
and analyzed. A third party driver has been identified to be causing system
crashes on your computer. It is strongly suggested that you check for updates
for these drivers on their company websites. Click on the links below to search
with Google for updates for these drivers: atikmpag.sys (AMD multi-vendor Miniport Driver, Advanced Micro
Devices, Inc.)


The problem is NOT overheating! (temperatures are under 40!)
latest DRIVERS are installed!

PLEASE HELP!

Here are some additional PCHF reports!
  1. http://speedy.sh/sPRJC/PCHF-120927-160727.zip

More about : video hardware error

October 1, 2012 2:54:12 PM

No ideas?
Related resources
October 2, 2012 3:33:19 AM

You have one bad driver installed. It may not be the video driver.
Memory diagnostics will not solve this.
October 2, 2012 3:45:33 PM

Ok, you have an idea of what will solve it? :) 
October 3, 2012 12:53:28 PM

suat said:
First run a memory diagnostics program. http://www.memtest.org/ . Create a bootable CD and boot to it to run mem diagnostics. Run the test at least four hours.

Second read and apply this: http://support.microsoft.com/kb/2665946/en-us

If the above do not help, please let us know.


Okey ran the memtest no errors!
Also read and applied the microsoft fix but it did not solve my issues
October 3, 2012 1:02:55 PM

How many passes or how long did you run memtest by booting to memtest CD ?

After applying the fix, did you restart Windows because the fix does not take effect if you do not restart ?

If you can positively answer the above, then what else you can do is, increase idle core and memory clock speeds to 400 and 900, respectively, by creating a profile through CCC. Then run your games and see if your issue is resolved now.
October 3, 2012 1:43:21 PM

suat said:
How many passes or how long did you run memtest by booting to memtest CD ?

After applying the fix, did you restart Windows because the fix does not take effect if you do not restart ?

If you can positively answer the above, then what else you can do is, increase idle core and memory clock speeds to 400 and 900, respectively, by creating a profile through CCC. Then run your games and see if your issue is resolved now.


I ran it for 4hrs no errors!
Yes it asks if I want to restart after applying the fix and I did!

Can you tell me how I increase the idle and memory clock speeds?
You mean creating a profile through Catalyst Control Center and how do I do that?
October 3, 2012 3:47:55 PM

Here is the procedure to increase the core/memory clocks:

How to increase idle-state core and memory clock speeds for Radeon HD 5xxx, 6xxx, and 7xxx series cards:

Open Catalyst Control Center (new version since October 2011).

Make sure Enable Graphics Overdrive is unchecked in Overdrive section.

Click Presets.

Click Add preset.

Give a name to the preset (such as Boost) and save.

Now go to %USERPROFILE%\AppData\Local\ATI\ACE\Profiles\ (AppData folder is hidden. Make it visible.).

In Profiles folder, you will see a file called Boost.xml.

Open Boost.xml with notepad.

In this file there is a line

name="CoreClockTarget....."
<Property name="Want_0" value="xxx00" /> (xxx00 is your idle-state core clock (R7850). Make it 40000)

and another lines

name="MemoryClockTarget....."
<Property name="Want_0" value="yyy00" /> (yyy00 is your idle-state memory clock (R7850). Make it 110000)
<Property name="Want_1" value="yyy00" /> (yyy00 is your mid-power-state memory clock (R7850). Make it 110000)
<Property name="Want_2" value="yyy00" /> (yyy00 is your full power-state memory clock (R7850). Make it 110000. If yours is different from 1100 MHz, change all the above values to that. Do not forget to add trailing 00.)

Save the file with the changes you have made.

Now go back to Catalyst Control Center.

Select the Preset called Boost and then put a checkmark in the box next to Enable Graphics OverDrive.

Click Apply at the bottom of the Catalyst Control Center window.

Now you can see the new idle-state core/memory clock speeds.

If the above solution does not work for you, uncheck Enable Graphics Overdrive and delete the profile Boost. Your default values return.
October 3, 2012 8:12:24 PM

suat said:
Here is the procedure to increase the core/memory clocks:

How to increase idle-state core and memory clock speeds for Radeon HD 5xxx, 6xxx, and 7xxx series cards:

Open Catalyst Control Center (new version since October 2011).

Make sure Enable Graphics Overdrive is unchecked in Overdrive section.

Click Presets.

Click Add preset.

Give a name to the preset (such as Boost) and save.

Now go to %USERPROFILE%\AppData\Local\ATI\ACE\Profiles\ (AppData folder is hidden. Make it visible.).

In Profiles folder, you will see a file called Boost.xml.

Open Boost.xml with notepad.

In this file there is a line

name="CoreClockTarget....."
<Property name="Want_0" value="xxx00" /> (xxx00 is your idle-state core clock (R7850). Make it 40000)

and another lines

name="MemoryClockTarget....."
<Property name="Want_0" value="yyy00" /> (yyy00 is your idle-state memory clock (R7850). Make it 110000)
<Property name="Want_1" value="yyy00" /> (yyy00 is your mid-power-state memory clock (R7850). Make it 110000)
<Property name="Want_2" value="yyy00" /> (yyy00 is your full power-state memory clock (R7850). Make it 110000. If yours is different from 1100 MHz, change all the above values to that. Do not forget to add trailing 00.)

Save the file with the changes you have made.

Now go back to Catalyst Control Center.

Select the Preset called Boost and then put a checkmark in the box next to Enable Graphics OverDrive.

Click Apply at the bottom of the Catalyst Control Center window.

Now you can see the new idle-state core/memory clock speeds.

If the above solution does not work for you, uncheck Enable Graphics Overdrive and delete the profile Boost. Your default values return.


Okey this is what I have done now:
name="CoreClockTarget_PCI_VEN_1002&DEV_6819&SUBSYS_25531458&REV_00_4&B77C4C1&0&0008A">
<Property name="Want_0" value="40000" />
<Property name="Want_1" value="97500" />

name="MemoryClockTarget_PCI_VEN_1002&DEV_6819&SUBSYS_25531458&REV_00_4&B77C4C1&0&0008A">
<Property name="Want_0" value="120000" />
<Property name="Want_1" value="120000" />
<Property name="Want_2" value="120000" />

Gonna try play now and see, will respond as soon as I have results!
October 3, 2012 8:38:33 PM

Okey bad news! After changing that and running for a while my computer froze even thought I didnt play a game :( 
October 4, 2012 4:28:30 AM

Did you only change the Want_0 value under CoreClockTarget_PCI...

Ther should be another Want_1 and Want_2 values. You did not touch them, did you ?

I have R6850 and my card runs the same way as I told you. If the modified setting is in conflict with your VBIOS code, then crash may occur.

Therefore, we must know the clock values of your VBIOS.

Please use GPU-Z " http://www.techpowerup.com/gpuz/ " to make a copy of your VBIOS. Please also use Radeon BIOS editor " http://www.techpowerup.com/rbe/ " to look into your VBIOS clock settings.

After noting the clock settings, please let us know them. Please read the documentation of how to use the programs.

We are not going to modify your Video BIOS. We will make a copy and look into the copy. So there is nothing to worry about, if you are anxious.
October 4, 2012 12:23:44 PM

suat said:
Did you only change the Want_0 value under CoreClockTarget_PCI...

Ther should be another Want_1 and Want_2 values. You did not touch them, did you ?

I have R6850 and my card runs the same way as I told you. If the modified setting is in conflict with your VBIOS code, then crash may occur.

Therefore, we must know the clock values of your VBIOS.

Please use GPU-Z " http://www.techpowerup.com/gpuz/ " to make a copy of your VBIOS. Please also use Radeon BIOS editor " http://www.techpowerup.com/rbe/ " to look into your VBIOS clock settings.

After noting the clock settings, please let us know them. Please read the documentation of how to use the programs.

We are not going to modify your Video BIOS. We will make a copy and look into the copy. So there is nothing to worry about, if you are anxious.


No I only changed want_0 values and there was no want_2 input on CoreClockTarget




Radeon BIOS editor does NOT support my graphics card!
October 4, 2012 12:42:03 PM

Can't seem to load my bios in RBE, getting invalid file specified when I try to load. Is assume this is because my graphic card is not supported?
October 4, 2012 1:00:13 PM

I am sorry but I am not able to help you any further except for saying that you should create differently named profiles and use a combination of core and memory clocks until you find a combination that works for you. Ex: Core=300 MHz, memory= 400 MHz or core=300 MHz, memory=500 MHz. This should not take too much of your time. This time change only Want_0 values of core and memory.

I have one Sapphire Radeon HD5770 and another MSI R6850 Cyclone. They both gave me problems. After a couple of tries, they became solid performers. Sapphire could only work with idle core=209 memory=400 (When bought, core=157 memory=300) and MSI could only work core=300 memory=1100 (when bought, core=100 memory=150). Idle means Want_0 values. The others should be at their default values.

Good luck.

EDIT: Before you create new profiles- if you wish to create any, please remember to uncheck Overdrive check box in CCC. Otherwise, all your clocks will change from default values to your modified values.
October 4, 2012 1:05:40 PM

Okey no worries will try on my own, or try other forums!

Thanks for your time!
!