Sign in with
Sign up | Sign in
Your question
Closed

7870 Not Sticking to Stock Clock Rate

Last response: in Graphics & Displays
Share
September 30, 2012 6:04:25 PM

I recently received a MSI HAWK 7870, now the card's stock clock rate and memory is 1100 and 1200. When running 3D applications or having MSI Kombustor open, it jitters, jumping from 450 core to 1100 back down to 450. GPU Usage jumps around from 60% to 99% back down to 60% and then 100% etc. Kombustor reports FPS 45-50.

Picture:


Now, when I add a little OC to it, 1101 Core and 1202 Memory, it stays the core and memory rates BUT the GPU usage is still jumping up and down.

Picture:


Clocking it down to 1000 Core and 1100 Memory, it stays that clock rate and the GPU usage stays a 63% while Kombustor is running. Wouldn't the GPU be at 99%-100% the WHOLE time Kombustor is running?



I even tried it on 900 core and 1000 memory rate, GPU usage stayed 63% and the core/memory rate stayed the same.

Picture:


After a bit of testing, when I OC past the 1100 and 1200 "stock" clock, the GPU usage will always be jumping up and down in Kombuster. Ranging from 60% and 100%.


Did I receive a faulty 7870? Should I return it? I just uninstalled and reinstalled Catalyst 12.8. I haven't messed with any voltages and have it set to keep a constant voltage(which it jumps from). I also looked in the Catalyst Control center and made sure that there wasn't anything in there, but there is stuff like the AMD Overdrive(which is disabled) and there are Application Profiles.

Do I have to set my own profiles? Or is there somewhere that I have to install them? This is my first AMD card...
September 30, 2012 6:44:15 PM

Does it affect playability in actual games, does fraps show dips and increases alot say when your playing GW2? Also i was just wondering, whats your fps in GW2 on the best appearance @ 1920x1080? Just wanting to know because i was going back and forth between a 7870 and a 7950, i chose the 7950, it might have been overkill but ehh.
Score
0
September 30, 2012 7:21:39 PM

MotherFerJones said:
Does it affect playability in actual games, does fraps show dips and increases alot say when your playing GW2? Also i was just wondering, whats your fps in GW2 on the best appearance @ 1920x1080? Just wanting to know because i was going back and forth between a 7870 and a 7950, i chose the 7950, it might have been overkill but ehh.


I do not have a 1920x1080 display, but I do have a 1680x1050 display.

On best appearance I am getting around 30FPS avg. Not ideal. But if I turn reflections to just terrain and sky, and a few settings down to just high instead of ultra, I get a minimum of 40 FPS and an avg. of 50FPS.

But it is constantly jumping around, and on my stock clocks they jump between 450 and 1100 core clock. If I have it set to 1099 clock rate, it stays that but my GPU usage never goes above 50%.

Really starting to piss me off. I'm going to go reseat my card, that always fix any issues like this with my GTX 550 ti.

*Edit,

I reseated and tested it, nothing changed.
Score
0
Related resources
September 30, 2012 9:21:57 PM

It is kind of a band aid fix, but you can try disabling powerplay in afterburner since your clock rate seems to be jumping back and forth between 2d performance and 3d performance. Basically, go into the afterburner config file and change the unofficial overclocking eula to 1 and change the UnofficialOverclockingMode to 2
Score
0
September 30, 2012 9:40:19 PM

Dude496 said:
It is kind of a band aid fix, but you can try disabling powerplay in afterburner since your clock rate seems to be jumping back and forth between 2d performance and 3d performance. Basically, go into the afterburner config file and change the unofficial overclocking eula to 1 and change the UnofficialOverclockingMode to 2


I just tried that right now, but I am still receiving jumping around in clock rates and my GPU usage is still jumping from 63% to 100%.

Thanks for the suggestion, but it did not change a thing. :( 
Score
0
a b U Graphics card
September 30, 2012 9:40:28 PM

So are the clocks jumping while you are gaming or when you alt tab out to desktop. Because its normal for them to tune down if not in a 3D game. My 460 goes from 800+ to 400 when i tab out of a game. If its happening in game, first check the temps and fans to make sure they are working correctly. If all else fails I would RMA.
Score
0
September 30, 2012 9:44:17 PM

yarmock said:
So are the clocks jumping while you are gaming or when you alt tab out to desktop. Because its normal for them to tune down if not in a 3D game. My 460 goes from 800+ to 400 when i tab out of a game. If its happening in game, first check the temps and fans to make sure they are working correctly. If all else fails I would RMA.


I have the game's windowed currently, I am not alt tabbing out. The fan speed is normal, GPU temperatures in game never go above 55C.

In more demanding games I am receiving stuttering even though I am at a constant FPS of 60, mostly in Skyrim and Borderlands 2. I have MSI Afterburner on the side so I can see what is happening, it is still jumping up and down from the clock rates and GPU usage when the stuttering occurs.

Even though it says 60 FPS via FRAPS, when it stutters it feels as if it's dropping below 45 FPS even though it says it stays 60 and Afterburner is also reporting it staying at 60 FPS, but the only thing that is changing is the clock rate and the GPU usage, it just jumps back and forth.
Score
0
September 30, 2012 10:04:30 PM

viridiancrystal said:
What is your CPU?


Sorry, it's in my sig. A i5-2500k.

I've gotten rid of the OC for now since the problem has occurred, thinking it could be in correlation with the GPU and game.

I guess it's not.
Score
0
September 30, 2012 10:08:22 PM

Well, I thought you may have been bottlenecked by it but that definitely isn't the case.

Your card underclocking itself means it's at a low enough usage to downclock to save power. Were you running the games in fullscreen and having this problem?
Score
0
September 30, 2012 10:12:08 PM

viridiancrystal said:
Well, I thought you may have been bottlenecked by it but that definitely isn't the case.

Your card underclocking itself means it's at a low enough usage to downclock to save power. Were you running the games in fullscreen and having this problem?


Just tested that possibility and I am still having this problem.

Again, thanks to all who are helping.

Score
0
September 30, 2012 10:18:36 PM

You seem smart enough not to have many background apps running while trying this, and it doesn't seem to be a problem with the rest of your system. I would suggest trying the 12.9 beta drivers, and if they doesn't help we may have to rest this on a defective card.
Score
0
a c 84 U Graphics card
September 30, 2012 10:20:28 PM

Skyrim has this weird 64Hz game engine clock thingie that can cause stuttering even at steady 60fps, if you take a look at their forums there are plenty of stuttering related threads with various means to fix it. The same problem has been present in all of their recent games that used the same engine or earlier versions of it...

might be something completely different but I thought I should mention it anyways...

edit linky
http://forums.bethsoft.com/forum/117-v-skyrim/
Score
0
a b U Graphics card
September 30, 2012 10:22:42 PM

not sure about borderlands, but I know that skyrim loads textures "on the fly" from your storage and that if you have it set up for high with slow storage it can affect performance pretty badly.

That may be your "stuttering" problem. If you have 60FPS steady then it is not really a GPU issue. In fact you are getting such low utility because you are running at low resolutions. It is not a problem, your expectations are just wrong.

If you were running at 1920x1080 with lots of candy you would invariably see 100% GPU utilisation.

As mentioned previously you simply are not stressing the card anywhere near its potential.
Score
0
a c 84 U Graphics card
September 30, 2012 10:27:58 PM

You could remove the vsync in skyrim with .ini tweaks to push the card harder...
iPresentInterval= something forgot which one it should be, 1 or 0 lol... search the forums
Score
0
September 30, 2012 10:28:41 PM

I dont know if afterburner has this but with the OC assistant HIS gives you iTurbo, you can go into the settings and disable the 2d clock so it stays at the max clock 24/7. Just make sure your card has some good cooling as it will get pretty toasty running just 3d graphics.
Score
0
September 30, 2012 10:30:01 PM

viridiancrystal said:
You seem smart enough not to have many background apps running while trying this, and it doesn't seem to be a problem with the rest of your system. I would suggest trying the 12.9 beta drivers, and if they doesn't help we may have to rest this on a defective card.


What is weird is the only problem I am having is the stuttering issue and the stock clocks not being at a constant rate, if I overclock/downclock it stays constant, but the stuttering is still there.

I don't have anything except for Steam, Skype, and Google Chrome in the background, well and also my Core temp and MSI afterburner monitoring programs.

Kari said:
Skyrim has this weird 64Hz game engine clock thingie that can cause stuttering even at steady 60fps, if you take a look at their forums there are plenty of stuttering related threads with various means to fix it. The same problem has been present in all of their recent games that used the same engine or earlier versions of it...

might be something completely different but I thought I should mention it anyways...

edit linky
http://forums.bethsoft.com/forum/117-v-skyrim/


Thank you for the heads up. I've never had a problem with the past games I've bought from them; Fallout 3, NV, Morrowind, Oblivion, Skyrim etc. on my old GTX 550 ti. But since I installed my new 7870, there is the stuttering issue, is this not an optimized game for AMD cards? I'm using the same exact rig for the past 7-8 months, the only new thing I have put in is the 7870.

americanbrian said:
not sure about borderlands, but I know that skyrim loads textures "on the fly" from your storage and that if you have it set up for high with slow storage it can affect performance pretty badly.

That may be your "stuttering" problem. If you have 60FPS steady then it is not really a GPU issue. In fact you are getting such low utility because you are running at low resolutions. It is not a problem, your expectations are just wrong.

If you were running at 1920x1080 with lots of candy you would invariably see 100% GPU utilisation.

As mentioned previously you simply are not stressing the card anywhere near its potential.


Same as above. Same system for 8 months now, had a 550 ti in it before and never had a stuttering issue.

I'm running Skyrim at Ultra settings and max AA @1680x1050. I'm getting above 60 FPS but have V-sync enabled, it just stutters over and over, even if the card isn't on stock settings.


As for suggestions, I'll try the new 12.9 drivers, maybe something just got screwy.


*Edit

Kari said:
You could remove the vsync in skyrim with .ini tweaks to push the card harder...
iPresentInterval= something forgot which one it should be, 1 or 0 lol... search the forums


Just tried it, I am going over 60 FPS, more into 70 and having a minimum of 55 FPS. But I am still seeing stuttering when turning back in forth in front of walls at 65 FPS.

MotherFerJones said:
I dont know if afterburner has this but with the OC assistant HIS gives you iTurbo, you can go into the settings and disable the 2d clock so it stays at the max clock 24/7. Just make sure your card has some good cooling as it will get pretty toasty running just 3d graphics.


Haven't seen that in Afterburner.
Score
0
a c 84 U Graphics card
September 30, 2012 10:43:20 PM

echondo said:
, is this not an optimized game for AMD cards?
dont know about that, but there have been also people with nvidia cards complaining about the stuttering. But it's weird, some people see it, others don't...


Quote:
Just tried it, I am going over 60 FPS, more into 70 and having a minimum of 55 FPS. But I am still seeing stuttering when turning back in forth in front of walls at 65 FPS
hows the clocks? stable?
Score
0
September 30, 2012 10:49:44 PM

Kari said:
dont know about that, but there have been also people with nvidia cards complaining about the stuttering. But it's weird, some people see it, others don't...


Quote:
Just tried it, I am going over 60 FPS, more into 70 and having a minimum of 55 FPS. But I am still seeing stuttering when turning back in forth in front of walls at 65 FPS
hows the clocks? stable?


Nope, still jumping around. I cropped an image from Afterburner.

Score
0

Best solution

September 30, 2012 10:59:37 PM

download iturbo from HIS's website http://www.hisdigital.com/un/news_show-237.shtml, disable the 2d clocks and see if that fixes either issue. At this point it couldn't hurt lol.
Share
a c 84 U Graphics card
September 30, 2012 11:01:54 PM

hmm, dont know what else to try then, it's not like you have cpu bottlenecking with that 2500k so it shouldn't be doing that anymore without the fps limit.... perhaps this is one of those amd driver problems...

^^that iturbo software looks quite versatile, I take it works on any card and not just HIS's cards? Just like Afterburner?
Score
0
September 30, 2012 11:13:55 PM

MotherFerJones said:
download iturbo from HIS's website http://www.hisdigital.com/un/news_show-237.shtml, disable the 2d clocks and see if that fixes either issue. At this point it couldn't hurt lol.


Well out of all the things that I have tried and everything that has been suggested to me, disabling the 2D clocks have fixed the problem!

Gotta give it to HIS for this one, I don't like the layout of the program itself but that one little box that I ticked fix my stuttering and FPS drops!

I've never heard of a program from HIS....

Kari said:
hmm, dont know what else to try then, it's not like you have cpu bottlenecking with that 2500k so it shouldn't be doing that anymore without the fps limit.... perhaps this is one of those amd driver problems...

^^that iturbo software looks quite versatile, I take it works on any card and not just HIS's cards? Just like Afterburner?


It is quite universal, as a lot of other monitoring/overclocking programs are! EVGA Precision, MSI Afterburner are the big two I use, I think XFX has one? And now I'm hearing about a HIS one?


Thank you MotherFerJor, saved me from the headaches! Now the only thing I have to worry about now is the constant 3D clocks :p 
Score
0
September 30, 2012 11:14:03 PM

Best answer selected by echondo.
Score
0
a c 84 U Graphics card
September 30, 2012 11:16:16 PM

echondo said:
Now the only thing I have to worry about now is the constant 3D clocks :p 

:lol:  just untick the box when you're not playing?
Score
0
September 30, 2012 11:19:26 PM

Kari said:
:lol:  just untick the box when you're not playing?


Probably my best bet :D 
Score
0
October 1, 2012 2:57:29 AM

good deal that worked, and thanks for BA. Yeah the layout is crap but the fan control and settings are where its at.
Score
0
a b U Graphics card
October 14, 2012 2:21:53 PM

You could just use 12.6 drivers and not have to turn off 2D clocks. 12.8 and 12.9 have this problem, 12.6 works just fine.
Score
0
October 14, 2012 5:36:57 PM

stickg1 said:
You could just use 12.6 drivers and not have to turn off 2D clocks. 12.8 and 12.9 have this problem, 12.6 works just fine.


I have read that but people have reported that certain games like BF3 and Skyrim(games I play, a lot) experience performance drops of around 10%.

That really isn't ideal for me, I will just slug it out for now, but it appears to be a driver issue and not the card itself, so no real concern.

Thanks for the recommendation however ;) 
Score
0
a b U Graphics card
October 14, 2012 5:44:27 PM

Yeah that's what i hear about performance on the newer vs older drivers however my fps are the same on both with much less stutter on 12.6. I play BF3 and Skyrim. I rather have less performance and no stutter. Smooth frame rates are my priority.
Score
0
October 14, 2012 7:14:21 PM

stickg1 said:
Yeah that's what i hear about performance on the newer vs older drivers however my fps are the same on both with much less stutter on 12.6. I play BF3 and Skyrim. I rather have less performance and no stutter. Smooth frame rates are my priority.


Well in my case as long as I have v-sync on I don't see most if not any stutter but my FPS does drop randomly which sucks but my gameplay experience doesn't really suffer.

It's a great card but they really messed up these drivers.
Score
0
a b U Graphics card
October 14, 2012 8:03:36 PM

Me and about 20 other guys on OCN have sent complaints to AMD and have yet to get a response. They know a problem exists but haven't done anything about it.
Score
0
October 14, 2012 10:28:13 PM

stickg1 said:
Me and about 20 other guys on OCN have sent complaints to AMD and have yet to get a response. They know a problem exists but haven't done anything about it.


Yeah I've sent a complaint as well.

Hopefully there will be an announcement or at least something mentioned somewhere from AMD as an official response.
Score
0
February 23, 2013 4:46:41 AM

I know this thread is alittle old but i just bought a powercolor 7870 LE graphics card and im having the same issues and ive tried creating the profiles and changing the core clock values but it hasn't fixed my problem. In fullscreen on BF3 it will start out with my OC settings then once the game is loaded it will drop back to 925mhz and sometimes even 300mhz however my memory clock stays the same. Has anyone found a fix for this issue?
Score
0
February 23, 2013 10:28:36 PM

MotherFerJones said:
download iturbo from HIS's website http://www.hisdigital.com/un/news_show-237.shtml, disable the 2d clocks and see if that fixes either issue. At this point it couldn't hurt lol.


jb14813 said:
I know this thread is alittle old but i just bought a powercolor 7870 LE graphics card and im having the same issues and ive tried creating the profiles and changing the core clock values but it hasn't fixed my problem. In fullscreen on BF3 it will start out with my OC settings then once the game is loaded it will drop back to 925mhz and sometimes even 300mhz however my memory clock stays the same. Has anyone found a fix for this issue?

Score
0
!