Sign in with
Sign up | Sign in
Your question

60GB SSD OS Driver shows full after fresh installation of Windows 7 Pr

Last response: in Windows 7
Share
February 23, 2012 2:01:17 PM

Hi everyone,

My computer specs are as follows;

ASUS P9X79 Deluxe, X79
Core i7-3930K, 6x 3.20GHz
Intel RTS2011LC
64GB G.Skill RipjawsZ
60GB SSD (for OS installation)
240 GB RAID 0 (2 x 120GB) SSD
Windows 7 Professional

After installing OS the C drive (60GB SSD) shows full. I've check the size of each windows folders, in total it shouldn't be more the 10-12GB. I've tried to clean the disk, no luck. Some of the people says it's because of the huge RAM installed. Could any one help me. Thanks
a c 209 $ Windows 7
February 23, 2012 2:52:49 PM

Check the root folder of the C: drive to see how large your pagefile and hibernation file are. The pagefile tends to get created quite large if you have a lot of RAM (ironic, since generally speaking the more RAM you have the less pagefile you need).
a b $ Windows 7
February 23, 2012 2:58:36 PM

If you allow hibernate, which I think is the default, you will need a drive space equal to the size of ram. But, it is not so easy to get rid of it if you have ever used it. Google the issue if you think that might be the cause.
Related resources
February 23, 2012 3:08:06 PM

Thank you guys. I'll be looking these issues in the morning and let you know.
February 23, 2012 3:08:40 PM

agree with the above - disable hibernate and shrink page file size (I use 2 GB min, 4 GB max but that's your call). That's my 2 bits...
a b $ Windows 7
February 23, 2012 3:30:00 PM

as already said its the huge amount of ram causing most of the problems

delete the hyberfil.sys file

open command prompt and type

powercfg.exe -h off and press enter--may need to reboot

this still lets you use sleep

lower pagefile to 2gb

turn off system restore--this is recommended for ssd

you can also run this if you dont plan to uninstall sp1

open command prompt and type

dism /online /cleanup-image /spsuperseded and press enter

all these gained me about 32gb on my ssd with 16gb of ram installed

February 23, 2012 3:47:36 PM

Go here for turning off hibernation....

http://support.microsoft.com/kb/920730

Basically...

To make hibernation unavailable, follow these steps:
1) Click Start, and then type cmd in the Start Search box.
2) In the search results list, right-click Command Prompt, and then click Run as Administrator.
3) When you are prompted by User Account Control, click Continue.
4) At the command prompt, type powercfg.exe /hibernate off, and then press ENTER.
5) Type exit and then press ENTER to close the Command Prompt window.

Check on the root of your C: to see if Hiberfil.sys (hidden, system file) is gone. If not delete it.

I guess you know that when you hibernate a machine in Windows it takes a snapshot of what is currently in ram and saves it to the Hiberfil.sys file. With your colossal amount of ram and speedy SSDs I see no point in ever hibernating your machine. You would save a couple of seconds at most. That's a beast you have their.

You can also move your pagefile to your raided SSDs and reduce their size to ohh say 1gb. Can't say Windows would ever need to use it when you have 64gb ram. There is much debate to be found about whether to disable it entirely something you could check out if you feel the need to save some more.

Don't forget Windows restore also likes to steal a few gigs. Once fully up and running you can delete all the restore points prior and create a new one.

Also check out your C:\Users\you\AppData\Local\Temp (hidden) directory. You can delete all (you're able) from here. Usually loads of dross left over from installs / setups etc.

Then finally run a system cleaner like CCleaner or Auslogic Registry Cleaner.

That lot should get you cleaned up.
February 23, 2012 9:56:57 PM

Solved: manage to disable hiberfil.sys and everything is normal know. Thank you guys for your time.
!