Sign in with
Sign up | Sign in
Your question

Amd 7870 screen tearing or artifacting ?

Tags:
  • Radeon
  • Graphics
Last response: in Graphics & Displays
Share
October 2, 2012 8:43:50 PM

im haveing screen tearing or artifacting in train simulator 2013 but mine is not horizontal mine happens were it pleases it flashes once and gose back to normal very fast i changed my power supply and my problem still persists here is my current setup

Intel i7 2600K 3.3 O.C 4.4
asus P8Z86-V LX
16GB Corsair RAM
XFX R7870 GHZ Edition
Corsair cpu cooler
XFX PRO 750W XXX Edition (Formally: win power + 850W)

Any help please guys

thanks in advance

More about : amd 7870 screen tearing artifacting

October 2, 2012 9:11:24 PM

Force Vertical Sybcronization. To make sure it works you may check framerate (you may use Fraps). It should then be matching your monitor refresh rate or it may jump to half of it or quarter. For example, your monitor refresh rate is 60hz. Your frame rate may be jumping but matching 60, 30 or 15fps.

Anyway, if the effect is gone, with V Sync. enabled, it is screen tearing.
October 2, 2012 9:20:56 PM

hi there vsync is enabled and the same happens how do i resolve this issue ?
Related resources
October 2, 2012 9:28:27 PM

yyk71200 said:
Force Vertical Sybcronization. To make sure it works you may check framerate (you may use Fraps). It should then be matching your monitor refresh rate or it may jump to half of it or quarter. For example, your monitor refresh rate is 60hz. Your frame rate may be jumping but matching 60, 30 or 15fps.

Anyway, if the effect is gone, with V Sync. enabled, it is screen tearing.

hi there vsync is enabled and the same happens how do i resolve this issue ?
October 2, 2012 9:34:46 PM

Is it just in that one particular game?

My guess is its a driver issue. Updated your drivers? Tried downgrading your drivers?

Is the game updated to the latest patch version?
October 2, 2012 9:52:02 PM

aaab said:
Is it just in that one particular game?

My guess is its a driver issue. Updated your drivers? Tried downgrading your drivers?

Is the game updated to the latest patch version?

no i had little squares at the top of the screen in arma 2 when i went on multiplayer
my current drivers are 12.8
train sim 2013 just got released
October 2, 2012 10:35:10 PM

If it's happening in multiple games I would RMA the video card.


EDIT. Just a quick thought. Are you able to try a different monitor?
October 2, 2012 11:13:08 PM

not with my old monitor as it is a vga connection ps the item has already been sent for a RMA Back to ebuyer and they found no fault

doyou think this could be my refresh rate on my monitor conflicting with the refresh rate of my card ?
October 2, 2012 11:55:54 PM

mark2009 said:
not with my old monitor as it is a vga connection ps the item has already been sent for a RMA Back to ebuyer and they found no fault

doyou think this could be my refresh rate on my monitor conflicting with the refresh rate of my card ?



If you can try another monitor it would be helpful. What is your refresh rate set to? Also what monitor do you have?
October 3, 2012 12:13:22 PM

i have set my refresh rate to 60 and my monitor is a iiyama prolight E2710HDS
October 3, 2012 8:05:22 PM

Do you have another gaming computer that you can connect to that monitor? Also have you tried a different VGA cable? Or try a HDMI or DVI cable?
October 3, 2012 9:07:25 PM

i only gt dvi conections but the spare screen is a vga anf my old pc is vga the computer in question is my gaming pc
October 3, 2012 11:00:10 PM

Try a different DVI cable.
October 13, 2012 7:36:49 PM

Hey bud,
You are not alone. I have a 7950, and have the exact same issues.

You should check out this thread:
http://forums.guru3d.com/showthread.php?t=368290

It's a driver issue. I have had a lot better luck using 12.6 with train sim 2013, so I suggest you use 12.6.
I still have the black flashing triangles, but much less often.

Also, I RMAd my card, and had the exact same issue with the new card.

I took a video of the issue, and I suspect that you are seeing the same thing.

I suggest that you email railworks support(so they know that there are multiple people with the issue) and send a bug report to AMD.


If you look closely(sorry that I couldn't keep the camera still), you will see flashing black boxes, and triangles that appear every few seconds on the screen.
http://www.youtube.com/watch?v=RScSvhVRSfk&feature=vmds...


The following is the same location and locomotive, but on the 12.6 driver, only minutes later.
http://www.youtube.com/watch?v=QTHW-oTdhXY
October 14, 2012 12:25:58 AM

I have a 7950 and I have the same problem just not in games it happens when I browse the web just not very often. games and videos play fine. I am going to try 12.6 as well.
October 14, 2012 4:53:13 PM

Boardjames said:
I have a 7950 and I have the same problem just not in games it happens when I browse the web just not very often. games and videos play fine. I am going to try 12.6 as well.


Well for the others it sounds like a simple conflict between the driver/card/game. But for you we have a different story. One of two things could be happening here:

One is a driver issue. Try completely uninstalling all AMD software from your PC, then removing all residual AMD files from your PC (there are tools for this). Then do a clean install using the latest CCC/driver. I've had this issue before on both AMD and Nvidia cards. Sometimes things just go wrong during the install, I guess.

The other possibility is the one thing ever gamer dreads: A burnout. Sometimes, when a piece of hardware has a shoddy heatsink or fan, or no fan at all, and it's a powerful part (like a nice CPU or GFX card), it can heat up way past the recommended temps and burn out one or two leads inside the chip, causing system instability but not rendering it useless.

It happened to the CPU on my last desktop rig. I didn't seat the sink properly on the CPU and it fried a bit. It still turns on, but it burned out enough to F**k the the POST screen so I couldn't even boot.
October 15, 2012 2:27:39 PM

@asciikode you are a star if its driver related will it affect all my games ? and cause my mouse to shake while it loads ???? as i have only just descovered it shakes while loading
meaning the big blue circle that replaces your cursor when loading it shakes
October 15, 2012 2:46:27 PM

P.S Bug rport sent to amd and im just on RSC,C Case now
!