Sign in with
Sign up | Sign in
Your question

Help Trying to disable Intels HD4000 GPU and enable Radeon 7670m GPU

Last response: in Graphics & Displays
Share
October 3, 2012 4:17:47 PM


Hello, I'm have a Samsung laptop and i was trying to figure out how to use my Radeon HD 7670m instead of Intel's HD 4000 graphics !

I have tried Disabling Intel's HD 4000 Graphics in device manager and enabling My Radeon HD 7670m. But all it did was change my Windows 7 color scheme to Basic and when i go to play a game like Battlefield 3 it cannot find my Graphics card AT ALL.

I also have already got all of the newest drivers + Catalyst but still no Avail :fou: 
By the way in my bios there is no setting to change the display adapters or Anything similar >:( 
+ Iv'e tried switchable graphics but didn't make a differance.

So i was hoping this forum could assist me with this problem :)  Thank You


Laptop specs:

i7 3610QM

4gb RAM

Radeon HD 7670m

15.5" screen

Windows 7 Home Premium
October 3, 2012 5:19:23 PM

go to bios you might be able to disabled it in integrated peripherals section
m
0
l
October 3, 2012 5:57:58 PM

Just tried that couldn't find anything :/ 

Any other suggestions?
m
0
l
Related resources
October 3, 2012 6:32:43 PM

Not totally sure about this one, (it has worked for me before) but uninstall the HD 4000 driver, rather than just disabling it.
m
0
l
October 4, 2012 1:08:24 AM

I did a full Windows 7 Re-install last night i Uninstalled the Intel HD 4000 but my computer just went to Windows Basic and when i went to play a game (example) Counter Strike Source it came up with a warning saying that no graphics card was detected.

Any other suggestions ????
m
0
l
October 4, 2012 1:15:42 AM

contact samsung about it, maybe they can help you. Im not sure how you'd go about disabling things in a laptop.
m
0
l
October 4, 2012 4:43:17 AM

I have already contacted Samsung but there useless. They can only help me about THEIR programs nothing else like cpu's gpu's things like that.
m
0
l
October 4, 2012 8:37:33 PM

With laptops, you should Never install a driver that comes from the company that made the parts.
OEM's like Samsung modifies the part a little bit to meet the requirements of its users.
You should install the drivers that came from your OEM company, in your case, Samsung.

Go to their website, download the drivers, and try to enable the Dedicated Graphic card within the Software that Samsung provided you with...

Forget the BIOS, it is OEM-Locked, so there aren't many options for you to mess around with.

-Hope it helps! :) 
Bloc97
m
0
l
October 6, 2012 2:12:47 PM

bloc97 said:
With laptops, you should Never install a driver that comes from the company that made the parts.
OEM's like Samsung modifies the part a little bit to meet the requirements of its users.
You should install the drivers that came from your OEM company, in your case, Samsung.

Go to their website, download the drivers, and try to enable the Dedicated Graphic card within the Software that Samsung provided you with...

Forget the BIOS, it is OEM-Locked, so there aren't many options for you to mess around with.

-Hope it helps! :) 
Bloc97




Nope still couldn't get it to work >:( )
m
0
l
October 9, 2012 8:33:31 AM

Hey...... If you have any option which allows you to assign power saving or high performance mode to the application that you run in ATI Catalyst Control Centre,

then assign high performance mode to the game and try.

I also faced with the same problem with my hp g6 2005ax lap....
It'll only used the integrated GPU insted of 7670M........

after assigning high performance mode, my 7670m started working most of the time..........

use techgroup GPU Z to check verify it......

m
0
l
July 1, 2014 9:48:49 AM

guys it is very very simple,, after setting the catalyst with high performance,, try running the game in lower compatibility,, i.e.,in windows 7 mode or just trouble shoot the .exe file :) 
m
0
l
!