Sign in with
Sign up | Sign in
Your question

MSI HD 7850 1GB

Last response: in Graphics & Displays
Share
October 4, 2012 8:56:17 PM

Hi

I have just bought a new PC + Graphics card. Specs are ;

AMD 4100 Guad Core Processor 3.6 Ghz
8 GB RAM
Windows 7 64-Bit
MSI HD 7850 1GB DDR5 Graphics card

When i have been playing games , such as CS:GO or MW3 , im averaging around 6 FPS, obviously it should be alot higher than this. After hours of reading threads and forums , i beleive i have found the problem , i just dont know how to resolve it.

When i launch a game , my graphics acceleration should switch to x16 mode , for example PCI-E 3.0 x16 @ x16 , mine stays at PCI-E 3.0 x16 @ 1.1

Please see image showing this

http://imgur.com/cVSHb

I need to know how to change it so its running at x16. Help please.

Thanks :) 

More about : msi 7850 1gb

a c 141 U Graphics card
October 5, 2012 1:14:11 AM

That doesn't explain why you have such poor performance. PCI-E x16 1.1 won't hold back a 7850 in any significant way. The 7850 isn't powerful enough to use more bandwidth than that in any gaming scenario.

I would say check your temps with HWMonitor, odds are either your CPU or GPU is overheating, and is throttling back performance to prevent damage.

Driver problems are another possibility, you can try using driversweeper to clear out the old drivers, then reinstall them. Use Catalyst 12.8, it's the latest stable release. Avoid the 12.9 Beta for now, it has some issues.
October 5, 2012 7:36:00 AM

I will try re-installing the drivers again when i get back from work but iv done it many times already.

From what i can see , my pc/graphics is staying in "Power saving mode" when im launching games , so i think this is what is preventing me to be to play? Could this not be it?

Do you know how to change my settings to PCI-E x16 @16 , i just really need to try everything because its getting beyond a joke :( 
Related resources
a c 141 U Graphics card
October 5, 2012 7:46:34 AM

Check your Windows power profiles, make sure it isn't set to powersaving mode, that may stop your GPU from increasing its clockspeed.
October 5, 2012 9:34:10 AM

Sorry how do i do that. I havent a clue when it comes to fiddling with settings etc. Thank you
a c 141 U Graphics card
October 5, 2012 11:33:34 AM

Control Panel > Hardware and Sound > Power Options.
October 5, 2012 3:30:05 PM

ok thankyou , i am in power options now , what kind of things do i need to tweak in there please.
a c 141 U Graphics card
October 5, 2012 4:03:56 PM

Set the power plan to either balanced or high performance if it isn't there already. You can't do anything to directly alter the video card's clocks from this menu however, if you go into advanced options you can change the PCI Express Link speed so it runs at full speed constantly, though that won't fix your current problem.

If the power options aren't doing it, and you aren't overheating on either the CPU or GPU, (be sure to check your temps, those low framerates could very well be the result of thermal throttling), I would say use driversweeper to completely purge your video drivers, and then try installing a different revision, like 12.7 if 12.8 isn't working for you.
October 5, 2012 4:14:26 PM

Ok , when i go onto Power options , iv set it to high performance , and under PCI express , there is only an option "Link state power management" , and three options for this are "Off" , "Moderate power savings" and "Maximum power saving"

Its on off at the moment.

I dont see PCI express link speed anywhere?? Thanks
a c 141 U Graphics card
October 5, 2012 7:46:42 PM

Link state power management is what controls the link speed, turning it off will run the link at the maximum speed it supports constantly.
October 6, 2012 11:47:03 AM

When i open GPU-Z , and run the render test , the card goes out of power saving mode and i fps around 100 on it. But when i load a game it stays in power saving mode?

Iv used driversweeper and reinstalled the drivers , even tried the new 12.9 Beta Driver and still its not sorting it.

I have re-inserted the card , blowing to make sure there is no dust etc, still nothing.

I have set my power plan on Windows 7 to High performance , and still nothing.

Shall i just return it??
a c 141 U Graphics card
October 6, 2012 4:38:05 PM

At this point I would, it doesn't seem to be working properly, and you have tried just about everything.
October 6, 2012 4:57:29 PM

i just cant get my head around it , on every bench mark test i run its hittin 100fps , and getting high scores. =/
a c 141 U Graphics card
October 6, 2012 5:10:25 PM

What tests are you runnning? Try some games other than CS:GO and CoD. If everything checks out with everything aside from those two games, then there probably is something wrong with those games, and not the card.
October 8, 2012 6:47:35 PM

I have been doing a bit of research , and it seems that alot of people with the same processor as me are having fps problems , and it is solved by updating there bios

Any ideas how to do this??

My processor is a AMD FX-4100
October 8, 2012 7:38:29 PM

i have done it , i thank you very much for all your suggestions.



Flashed and updated my bios , and now hitting 70 fps on mw3.



Thanks again
!