Sign in with
Sign up | Sign in
Your question

Msi gtx 660 ti screen tearing

Last response: in Graphics & Displays
Share
October 7, 2012 12:26:57 AM

Hello,

I've recently upgraded to a msi gtx 660 ti power edition OC version from a radeon hd 5770, and in games I see screen tearing also on adaptive vsync.

Even if I don't use adaptive vsync and use frame limiting, I don't know if it's just me but I see minor screen tearing.

But If i watch HD YouTube videos in full screen, I see AWFUL very very noticeable screen tearing in it and usually in the same spot.

So is this a problem with flash or the graphics card, and why and am I still getting some screen tearing with vsync/adaptive vsync and what to do. Other than that I notice no problems.

The rest of my hardware is old and is bottle necking, such as my processor is a amd phenom II x3 720, so I'm not sure but I guess all my hardware bottle necking is causing this tearing?

Thanks :) 
October 7, 2012 12:48:43 PM

Hi, I have a Gigabyte Gtx 670 with the same problem. I guess the "Adaptive" Vsync simply doesn't work. What you can do is to turn on only "Vsync", that will solve the problem. Nvidia really needs to work on the "Adaptive" vsync. Otherwise, that's just a marketing tool.
Cheers
m
0
l
October 11, 2012 4:58:52 AM

I don't get why I would be getting screen tearing on youtube videos in HD and fullscreen.

Is that a problem with flash or my graphics card?
m
0
l
Related resources
January 16, 2013 3:44:19 PM

Hi lxmadnessxl,

I'm sorry to reply to you so late because I didn't know your reply. You can try to turn Vsync and tripple buffering on in the Global settings of Nvidia Control Panel. Hope this helps or please ignore this message if you already solved the problem.

Cheers
m
0
l
January 16, 2013 3:48:03 PM

I forgot an important thing. When you turn on Vsync, make sure you turn on tripple buffering and adjust game settings to get 60 FPS in order to prevent screen stuttering.

Cheers
m
0
l
June 21, 2013 7:49:47 PM

I have a GTX 650 Ti from MSI i get screen tearing to the max when i view videos/youtube only way to disable that is enable Aero and Desktop Composition to enable desktop vsync. But for games Guess run the game on full screen thats when adaptive vsync uses it not sure but my next card im buying is a ATI if i knew about the screen tearing i would of not bought nvidia.
m
0
l
!