Sign in with
Sign up | Sign in
Your question

Tried to build a PC, Motherboard light on but nothing else.

Last response: in Systems
Share
November 29, 2012 12:14:59 AM

I tried to build a PC and followed the online Newegg guide, i've read my motherboard Manual and feel stuck.
My motherboard light turns on but nothing else appears to be powered on.

I've read this: http://www.tomshardware.com/forum/261145-31-perform-ste...
Parts:

ASUS P8Z77-M LGA 1155 Intel Z77 HDMI SATA 6Gb/s USB 3.0 Micro ATX Intel Motherboard

CORSAIR Enthusiast Series TX750 V2 750W ATX12V v2.31/ EPS12V v2.92 80 PLUS BRONZE Certified Active PFC High Performance Power Supply

560 Ti Geforce

Intel Core i5-3570K Ivy Bridge 3.4GHz
a b B Homebuilt system
a c 435 V Motherboard
a b å Intel
November 29, 2012 8:20:43 AM

I would pull out the video card and try the onboard video first. You may the wrong power supply lead connected to it or on the board. Did you connect the 12v (4 or 8) pin connector next to the cpu socket?
m
0
l
November 29, 2012 12:10:43 PM

is the 4 pin AND 24 pin connected to the mobo? sounds like a common case of missing plug.
m
0
l
Related resources
November 29, 2012 10:11:19 PM

The problem was that the power switch cable was upside down.

I have a new Problem: when my GFX card is pluged in it won't boot. the gfx card fan turns on though.
m
0
l
November 29, 2012 10:31:55 PM

I just fiddled around with it and the computer will only boot if the power isn't plugged into my GFX card, but the GFX card is still plugged in and the fan is running.
m
0
l
November 29, 2012 10:54:58 PM

SOLVED: I plugged my VGA cable into my GFX card instead of my Motherboard. IT worked.
m
0
l
November 30, 2012 8:49:33 AM

Nice job :) 
m
0
l
!