Sign in with
Sign up | Sign in
Your question

ATI Mobility Radeon 2400 XT Driver

Last response: in Graphics & Displays
Share
October 10, 2012 2:45:45 AM

Hello,
I am having a driver problem with my 2400 XT. Before I start, this card is in an I-mac late 2008 -RUNNING WINDOWS 7- and it worked without the boot camp drivers that apple provides as they are out of date for Windows 7. Its a standard notebook card.

The card was working perfectly for a long time. The symptoms began when I uninstalled the card and reinstalled it with drivers for catalyst 8.10 with mobility mod added into them and later tried it again with 8.12. The issue was when i tried playing a game, for instance, Minecraft. It immediately crashes giving an error about Open GL not being found and it most likely being a driver issue. Another example, a simple indie game which ran fine, FTL, shows significant lag in the cursor on the screen. Somewhere around 1 or 2 FPS on the title screen. The lag is not apparent at any other time in using the OS. So thinking it was those drivers i tried uninstalling it and letting windows install drivers for it, to which Microsoft installed the "WDDM 1.1" which i believe is a generic video card driver. I also tried the newest Catalyst drivers from AMD with their automatic installer but have since reverted back to the windows driver as the issue has persisted.

I did notice that under properties in device manager it shows this information:
Device type: Display Adapters
Manufacturer: ATI Technologies Inc.
Location: PCI Slot 1 (PCI bus 1, device 0, function 0)

I find the PCI slot to be kinda fishy.
Could it be windows using multiple drivers installed on my computer? I believe the drivers that where working where downloaded automatically by windows but i can't remember to be honest.

Any help would be appreciated and thanks in advance!

- Eric K.
October 11, 2012 6:21:05 PM

what is your operation system bit
32 or 64 bit
October 12, 2012 2:29:34 PM

It is a 32 bit instillation of windows 7.

I would like to say that I have managed to resolve this issue by using Driver Sweeper from Guru3D in safe mode to completely remove all the drivers for the card and re-installing the drivers from ATI. It would seem that somehow windows was overlapping drivers or something strange. This seems to have resolved the issue.
!