Sign in with
Sign up | Sign in
Your question

Problem with ati drivers?

Last response: in Graphics & Displays
Share
October 10, 2012 9:52:26 AM

Hello,
I just purchased a asus HD7870-DC2-2GD5 gaphics card and im having a problem. I use this rig for gaming, most of what i play is cod5 nazi zombies and black ops. When the games first start i get choppy framerate for the first minute or so, once i look at the entire area it will smooth out until i go into a new area then it starts again with the fps drop. Here are the specs
FX-8150
16 gig amd ram
asus 7870
corsair gs700 psu
asrock 990fx xtreme 4
I replaced a gtx 560 ti with the 7870 and did not have any of these problems with the nvidia card. I did a fresh install of windows 7 and xp x64 and both operating systems have the same problem. Any ideas on this issue would be apreciated. Thanks

More about : problem ati drivers

October 10, 2012 10:34:37 AM

This really has nothing to do with the graphics card, it's a common issue most simply call "level or area loading" and it's because for the first few moments of a game, especially in a new level or area, all the data required to render what you are seeing is loading from your hard drive into memory. You are likely running at higher detail settings with the new card and you are noticing it more than you used to.
Turn your attention to maximizing hard drive transfer rates by shutting off any background programs or apps, make certain your anti-virus software is running in gaming mode.
The best sure-fire cure, get an SSD.
m
0
l
October 11, 2012 10:07:41 AM

Interesting, is this more of a problem with ati graphics cards? I've never had this issue with nvidia cards. I disabled all background programs and antivirus and i have the same results. Has anyone else experienced this problem with an ati card? Also I have a 7200rpm drive.
m
0
l
Related resources
October 13, 2012 2:52:23 PM

I will say this again, this is not a graphic card issue.
m
0
l
October 13, 2012 4:18:59 PM

You may be better off with more than one hard drive.
One for OS and basic apps. One for personal files.
One for Games.
A small fast drive is recommended for OS and things that need to go fast. A large 1TB drive is better for pictures, etc...
the larger the drive, the slower you go.
Also you can do this:
One thing is to make sure that the priority of the game is highest, there maybe other processes running that have priority over the game.
Including for instance security programs and antivirus. The latest of which have gaming modes.
If there is not a gaming media mode on the security try turning it OFF.

Another good thing is to eliminate as many unused / junk / UN-needed applications.
turn off the screen saver
Go into the power profiles,
set standby, hibernate and sleep to OFF
leave the monitor standby ON, that's OK (maybe not, try OFF)
Set the Hard Drive standby to NEVER
Set system Performance to MAXIMUM, not "quiet mode."

Open the bios set up and make sure "cool and quiet" is OFF. (AMD)
There may be a performance setting in the bios setup you have...make sure it's cranked up to max.
in the bios, see that the allocation for video, if available, is maxed.

Now open the hardware manager profiles...
click start
click computer
click system properties
click device manager
double click on mice and other pointing devices
right click on HID compliant mouse
left click on properties
click on the power management tab
UN-check the box that says: "allow the computer to turn off this device to save power." (there is now NO check mark in this box)
click OK

Now repeat this procedure for all mice, monitors, keyboards, and ALL USB ports on the device manager list.

You must open ALL the devices one at a time, as above, and turn off the power saver, for each device.
m
0
l
!