Sign in with
Sign up | Sign in
Your question

Help: 7850 PCIe 3.0 + MSI A75MA-G55 mobo not compatible?

Last response: in Graphics & Displays
Share
October 10, 2012 10:16:18 PM

Hey all,

I recently purchased a MSI R7850 Twin Frozr OC AMD Radeon HD 7850 for use with my MSI A75MA-G55 mobo.

When I hit the power button all the fans spin and I can hear my drive spin up but my bios does not beep and nothing shows up on my monitor (obviously this means it never boots to the OS either). I have a 700w PSU with the proper cabling (tried multiple cables) so I know everything is powered correctly. I also tried with my 500w just for shits n giggles.

Previously I was using a AMD A8-3870K APU w/ a Radeon 6670 for Dual Graphics and that worked fine. Using only the APU's integrated 6550D or only the dedicated 6670 w/ the 6550D disabled also work fine.

I purchased this on amazon and would love to know if I just bought a dead card before going through the hastle of sending it back. I was thinking it might be the fact that the mobo is pci-e 2.0 and the card is 3.0.

For reference, here is exactly what I am using when it dies.

PSU: http://www.amazon.com/gp/product/B007MLSGHE/ref=oh_deta...
Radeon 7850: http://www.amazon.com/gp/product/B007MLSGHE/ref=oh_deta...
APU: http://www.amazon.com/gp/product/B006J420UE/ref=oh_deta...
Mobo: http://www.amazon.com/gp/product/B0058M3RNW/ref=oh_deta...
October 12, 2012 4:46:39 AM

First check the motherboard manufacturer website for the list of compatible video cards.
It will be listed in the motherboard specifications.
m
0
l
February 1, 2014 4:15:14 PM

Hey was this ever solved? I have exactly the same problem.

m
0
l
!