Sign in with
Sign up | Sign in
Your question

enabling identifying network cable unplugged

Last response: in Networking
Share
November 22, 2011 1:13:47 PM

So here's a fresh spin (and not in a good way) on the seemingly common port-flapping issue, where a windows vista/7 machine's ethernet port vacillates between "enabling, identifying, network cable unplugged."

I've tried the fixes I've seen around, like forcing the speed to 10 or 100Mb duplex,etc. But I think the problem goes deeper than that -or drivers or faulty NICs. Its acting like it's in the cabling. . . but not. Any advice would be welcome.

Just switched from one DSL provider (Bell) to another (Teksavvy). Connected via a dry loop. When the Bell tech first set it up a year ago, he did it like this: Patch cord frome the Bell 2Wire modem/router combo to a female coupler. Female coupler attached to cat5 cable running about 25/30 feet along baseboards around the corner to another female coupler. Patch cord from female coupler to NIC in the back of my box. This worked fine.
New set up with Tek savvy is as follows: DSL modem via patch cord to (wireless) D-Link router. D-link router connected to computer by same aforementioned setup. This results in the port-flapping named in the title of this message, on the hard line only. Any change in my computer was ruled out by connecting a brand new, never been connected laptop and the same terminal as my computer. Results in port flapping. The same laptop connected to the router by just the patch cord results in a perfect connection. I've tried moving the patch cords around, it doesn't change the results, so they're fine. I have no way of testing this long stretch of installed cable in the middle, with the couplers on it, since I don't have an equal length cable to try out anywhere, but I'd be surprised if that just died after a year's use exactly when I connected new hardware to the other end of it. Running windows 7 with a RealTek NIC on my box. D-Link router (will check the model later, at work at the moment), and TP-Link DSL modem. The system delivers wireless internet flawlessly. Could this be interference? I don't think the cable is shielded, but the only source of RF added to the system is the D-Link Wifi. . . baffled. Suggestions welcome. Sorry for the essay.

-Marcus
November 23, 2011 12:21:51 PM

As a follow up for any who might find this useful: I looked at all the cables in the system, and found that the coupled section that the Bell tech installed is actually a crossover. The CellPipe 7130 (not 2Wire as I said earlier, sorry) modem has Auto-MDIX on all its ports, so this is not a problem. The Router that's now replaced it in the system only has it on its "Internet" port, not on any of the LAN ports. As far as I can tell, even though I've read in many places that gigabit-capable ports should all be Auto-MDIX or equivalent by default, my on board Realtek RTL8168/8111 apparently doesn't have it (couldn't find a lot of specs on it in my cursory search). Conclusion? Crossover cable = problem. Since I don't want to rewire everything, I ordered a cheap crossover patch cable to cancel out the crossover in the coupled section. Will post results.
m
0
l
November 30, 2011 12:30:22 PM

This is me posting results: no dice. Installing a second crossover changed nothing about the behaviour of the setup - still stumped.
m
0
l
!