Sign in with
Sign up | Sign in
Your question

My upgrade to a gtx 660 put me back further???

Last response: in Graphics & Displays
Share
October 12, 2012 4:04:07 PM

hi everyone i just upgraded my hd 6850 to a gtx 660. i live the card in all games except two. borderlands 2 and guild wars 2. i used to avg 50 fps in guild wars. now when im turning i drop to literally 0 fps for a coupe seconds. i wiped all the drivers off from the 6850. ot the latest 660 drivers and i get this??? why??? my performance dramatically dropped. in borderlands 2 i get like 30 fps. and dont even try phys x. my card is suppoesd to be good with phys x but for some reason its crap...

i really need help
a b U Graphics card
October 12, 2012 4:13:57 PM

What's your system? CPU, mobo, psu, OS and all that. And your gaming resolution.
Related resources
October 12, 2012 4:15:12 PM

rgd1101 said:
full spec? check the gpu temperature?
http://www.techspot.com/review/577-borderlands-2-perfor...
660 is better the 6850


well my specs are

MOBO:biostar ta790gx 128m
CPU: phenom2 x4 945
RAM:* gigs ddr2
GFX: gtx 660 twin frozr

i know the gpu never gets above 40 degrees. i have the twin frozr, stressed it and it never went above 40 degrees
October 12, 2012 4:30:45 PM

Hmmmm.....CPU bottleneck maybe?
How much RAM?
October 12, 2012 5:09:12 PM

srry i meant to put 8 gigs
October 12, 2012 5:10:00 PM

im seeing in gpu z that my card is running in 8x not 16x???? would that cause my problems?
a b U Graphics card
October 12, 2012 5:19:32 PM

while playing check if your gpu is running at full potential or not means near 100%
October 12, 2012 7:55:31 PM

the top PCIE slot is for your card, and the bottom slot is for the paddle card.

You have to put that paddle card in slave PCIEx16 slot i.e. nearer to the CPU and then place your graphic card in the Master PCIEx16 slot whichis nearer to the USB header,JPANEL headers etc.

if you have that correct then try this:

In the BIOS, under Advanced Chipset Settings, select AMD 790GX config., and set "Internal Graphics Mode Config" to "Disable."

Now select "PCI Express Confg." and select "Port #02 Features." Set "Gen2 High Speed Mode" to "Advertised RC".

Save and Exit. You should now be running at 16X.
!