Sign in with
Sign up | Sign in
Your question
Closed

Gpu usage neer above 50 percent?

Last response: in Graphics & Displays
Share
October 12, 2012 7:56:48 PM

i just bought a gtx 660 to upgrade from my 6850. i noticed in borderlands 2 the performance was complete garbage... i tried a couple other games, batman arkham city, borderlands 1. i don get it. why did i pay 250 dollars for a card thats only being half used...

More about : gpu usage neer percent

a b U Graphics card
October 12, 2012 8:16:39 PM

edit: Actually, the first thing you should probably check is that you completely uninstalled your AMD drivers. Try using DriverSweeper (in safemode I think) to get rid of the AMD stuff. I am pretty sure there are issues created by having both drivers installed.

What CPU do you have?

The GPU get's told to work by the CPU, if the CPU doesn't request a scene to be rendered often enough, the GPU doesn't do anything.

However, if you have anything relatively modern and reasonably powerful, it's probably not the problem in something like borderlands.

Do you have windows setup for maximum performance mode? How about any settings in the nVidia controller for graphics settings?

How are the temps on your card?

Have you tried the latest drivers? how about some older ones?
Score
0
a b U Graphics card
October 12, 2012 8:22:16 PM

If you have a Pentium Dual Core and a 660 then you're pretty much screwed, you wasted money and you're bottlenecked at the CPU. Or if you don't have enough RAM... or if your PSU is too weak to support the CPU's actual power requirements and it can't get up over 50% because it can't draw enough power.
Score
0
Related resources

Best solution

a b U Graphics card
October 12, 2012 8:32:02 PM

Do you have Battlefield 3?

For me and all my friends, it runs the GPU @ 100% during all gameplay, at least that's what the monitoring program's tell us.

Also, post ur system's other specs.
Mobo, PSU wattage, RAM, CPU, and temps during gameplay (just a ballpark to see if something's just not getting hot)
Share
October 12, 2012 8:37:54 PM

its funny how sometimes i post something and get no reply but then others so many people reply lo. thanks for the help here guys. i have done all driver erasing and new drivers for the card. old amd drivers are gone. i did notice that in bf3 the usage was 100. so was when i really cranked rage to its max. so i guess the card is only using what it needs to.
Score
0
a b U Graphics card
October 12, 2012 8:40:06 PM

Sometimes people don't have the answers. Other times, the only people viewing don't care (or don't know, or don't want to know) and by the time the people with answers show up, the post has slid too far down the forum.
Score
0
October 12, 2012 8:40:12 PM

my specs are

MOBO:biostar ta790gx128m
CPU: phenom 2 x4 945 oc to 3.45 ghz.
RAM:8 gigs ddr2
PSU:650 watt ocz zt series
GFX: MSI twin frozr gtx 660 oc editon
Score
0
October 12, 2012 8:41:13 PM

nbelote said:
Sometimes people don't have the answers. Other times, the only people viewing don't care (or don't know, or don't want to know) and by the time the people with answers show up, the post has slid too far down the forum.

well its nice to actually get some help. for awhile i thought this place was dead lol
Score
0
October 29, 2012 3:12:20 PM

Best answer selected by schecterplayer.
Score
0
a c 271 U Graphics card
October 29, 2012 5:57:42 PM

This topic has been closed by Mousemonkey
Score
0
!