Sign in with
Sign up | Sign in
Your question

Games flicker and crash in fullscreen with an "Optimus" GPU setup

Last response: in Graphics & Displays
Share
October 13, 2012 1:37:41 PM

I am totally perplexed with this problem.

I just got a new Lenovo z580 laptop for general use and wanted to play some games on it.

The first important thing to note is that this laptop has two graphics card in it. It is referred to as "Optimus" by nvidia but essentially the computer recognizes the call for DX or openGL and switched from the integrated Intel 4000 GPU to the GTX 630M. I can manually force it to run in either the integrated or dedicated graphics if I like (this is important for troubleshooting).

The Problem:
I have no found two of my preferred games (guild wars 2 and left for dead 2) will no function in fullscreen mode. Currently I have GW2 running in windowed mode. If I select to run it in fullscreen (any resolution gives the same results) the game flickers on and off for a few seconds until reverting back to windowed mode. L4D2 is very similar. If I try to start the game up in fullscreen mode it give and error saying "Failed to create D3D Device". If I force the game to start in window mode it runs fine. If I then switch back to fullscreen mode in the options menu it flickers between the game and black until I force close it in task manager.

Now if I disable the GTX 630M and force all the games to run on the integrated graphics they all run fine in fullscreen mode.

This would make it seem like the issue lies within something with the dedicated card. So far I have tried updating the graphics drivers and did a clean install. I played around with the refresh rate maximum in GW2 options hoping that would solve it but no change. I can't seem to find the place where I could play with the refresh rate settings for the dedicated card, only the integrated card, but the only option is has is 60Hz (which makes sense). I have also reset all the 3D manager settings to default.

I am not sure what else I can do, and haven't found anyone else with the specific issue.
October 15, 2012 1:09:59 AM

That exactly thing happend to me. I just buy an alienware m17x, 3 weeks ago and everything goes perfect except that I can't run things in fullscreen (just like you described).

This is the first post I found about that issue.

I didn't tried disabling the nvidia yet, could you tell me where did you do that? device manager? nvidia control panel? where?

thank you! hoping someone could help us...

P.S: sorry about my english, I do what I can xD
October 16, 2012 12:55:41 AM

Thanks for the response, maybe someone will be able to assist us. As for your question, you can disable the nvidia card by going into the nvidia control panel and under "manage 3d settings" set videocard priority to the integrated card. You can also force it to just use the dedicated card if you like.

I am still having this problem and have not found a solution. Hoping for someone to have some ideas for me.

Good Luck!
Related resources
October 16, 2012 1:09:49 AM

I just downloaded and play Team Fortress 2 and it works great in fullscreen, perfect... so it's weird :/  apparently the issue it's with some games, not all of them.
October 16, 2012 9:25:52 PM

That is also the case for me. TF2 works fine in full screen. As of now I only have problems with L4D2 and GW2. I am sure there are more games with the issue, I just don't have that many installed on this computer.
October 21, 2012 11:22:56 PM

No suggestions on this? I am game to try any reasonable troubleshooting steps that I have not already mentioned.
October 21, 2012 11:29:29 PM

I don't know if this will help, but my Qosmio has Optimus with a 560m + Intel 3000 and all games work fine. I haven't changed anything though. But maybe it'll give some hope? :/ 
October 22, 2012 4:39:33 PM

Thanks for the comment. At least I know its not just an issue with optimus and likely has more to do with either 1)this gen of card, 2)the particular model (630m) or 3)My particular system.
November 9, 2012 12:55:57 AM

Can't play age of empires 2 nor age of mythology D:
I'm fighting to make it go in window mode.

Still no suggestions? T-T
November 9, 2012 8:30:05 PM

Well, after expending ALL the afternoon googling, trying things, investigating, crying, fapping, crying again.. I FINALLY FOUND THE SOLUTION!!!!

(at least my solution)

I bought a Yiynova 10.1 (it's a tablet monitor for drawing on-screen), well, to use that i have to install "Displaylink" drivers from displaylink dot com... I suddenly think about uninstalling them and BAM! problem solved, everything go in fullscreen now...

DisplayLink Core, and DisplayLink Graphics were the problem, I uninstalled them and that's it, everything is great now n_n

I hope this solution works for you too, my problem-buddy! xD
!