Sign in with
Sign up | Sign in
Your question

XFX 7950 Problems.

Last response: in Graphics & Displays
Share
October 13, 2012 10:47:42 PM

I didn't get any real answers the last time so let's try this again. I bought a XFX 7950 from newegg.com I have random black line flickering only when on webpages and sometimes little tiny grainy blackliines on the desktop but only when messing with MSI Afterburner.
I deleted MSI Afterburner. I didn't really overclock just ramp up the fan speed and when I would hit apply those little lines would appear but only for a second. So far I have zero issues in any of my games all my games look pretty good. I must note that Crysis did Crash once but that was after messing with MSI Afterburner it has since not crashed. I have sweeped my drivers reinstalled the drivers I Have made sure my psu 6 pins were on tight I have done everything I can think of. I can't wake my monitor from sleep with this video card unless I hit the power button on my monitor twice. Sometimes when i do that I see a AMd message saying something about detect auto display not configured. I looked for settings and couldn't find auto detect anywhere in ccc. The lines only happen random and are not often at all. none of this happens at all when I use my old Nvidia card . My GTX 560ti runs fine without any issues so this makes me assume it has to do with AMD drivers. anyways can anyone help me with some suggestions on what to do? :sweat:  :sweat: 

More about : xfx 7950 problems

a b U Graphics card
October 13, 2012 11:21:52 PM

it doesnt really sound like a driver issue to me....

since you have another card to hold you over.....id rma it with xfx and get a new card....

one thing you could try first tho would be to try to replicate the problem on a different computer.....thats what xfx will do and if they cant find the issue, it will just be shipped back to you......

may need to "echkhemmm" make damn sure they find a problem.....(pin 'er till she pops overclock...)
m
0
l
October 13, 2012 11:54:04 PM

I don't have another Pc to test this on. some guys on here advised me it could be my motherboard or psu. So guess I best replace both. is this one any good ? http://www.amazon.com/OCZ-Fatal1ty-Modular-Gaming-compa...

and this is the only decent motherboard I can seem to find online. http://www.amazon.com/gp/product/B004FPYKPM/ref=ox_sc_a...

I really wanted another Monitor :(  I will RMA the card if the issues are still present with those brand new parts. I think the card is fine but maybe your right. what are signs of a defective video card? It plays games just fine and the screen doesn't do that black line flicker when watching videos or playing games. I did notice that greens are less green and games just don't look as pretty as my GTX 560ti though. If I ask for a refund should I go with a GTX 660ti? sorry about all the questions. AMD scares me at this point.
m
0
l
Related resources
October 14, 2012 1:29:49 AM

it is more of a budget issue I'd love to get that board. the other boards within my budget on newegg are god awful.
m
0
l
October 14, 2012 2:38:06 AM

just did a 15minue Furmark burn in test and it passed max temp was 74. I didn't notice any screen tearing or weirdness. Not sure what is going on. guess I am just going to have to ask for a refund and buy a GTX 660ti. none of this happens with my GTX 560ti. I can only point to drivers at this point. AMD and i are through.
m
0
l
!