Sign in with
Sign up | Sign in
Your question
Solved

Network HDD without wireless router

Last response: in Networking
Share
November 26, 2011 1:12:09 AM

Recently I bought a 2TB FreeAgent GoFlex Home network HDD, and I'm trying to hook it up without a wireless router. Right now I do not want to hook it up through the router because Im sharing it with many roommates, but I bought it because eventually I will have my own network that I would want to share it over.

So, I used a crossover cable to connect the HDD to my computer, and the lights on the device indicate that it is connected, but when it tries to contact the server it is unable to. So I cannot communicate with it. Is there a way to set up a virtual access point on the HDD so that it is fooled into thinking it is connected to a router, or something like that.

Not really sure what to do, so if anyone has any ideas please share them. Also, I'm only home on the weekends so I won't be able to test anything til next week.

My OS is windows XP
November 26, 2011 7:05:21 PM

As indicated in the documentation: "Ensure that your router gives out IP addresses to computers on your network (DHCP) and that DHCP is enabled on your router. DHCP is usually enabled on home networks. If it is not, you will have trouble connecting to GoFlex Home. If you need assistance enabling DHCP on your router, see your router documentation."

Since your PC is not a DHCP server, it can't work. You could find a free or inexpensive DHCP server to install on your PC. If you decide to do that, assign a static IP address to your PC, e.g., 192.168.10.1 mask 255.255.255.0. The DHCP server would then be configured to provide IP addresses starting at 192.168.10.2 or higher.

http://sourceforge.net/projects/dhcp-dns-server/files/D... (You only need DHCP)

Best solution

November 26, 2011 10:01:25 PM
Share

If the OP is just trying to initialize the external HD w/ a valid IP address, and assuming he has an existing network connection to the wireless router, then all he needs to do is bridge the two network connections. The external HD’s DHCP request will then travel over the bridge to the wireless router and get a DHCP assignment like everything else. Simple. Of course, it’s accessible to anyone else too, not just the OP.

However, if the OP is trying to PREVENT access to the external HD, he could use ICS instead. You would enable ICS on your existing wired/wireless internet connection and share it w/ the network connection to the external HD. Although the drive doesn’t actually need internet access, that doesn’t matter. You just want to gain access to the DHCP server that ICS provides and initialize the external HD. Specifically, Windows will give your PC the static IP address 192.168.0.1, and the external HD will be assigned 192.168.0.2 by the ICS DHCP server. Voila, your HD is accessible via 192.168.0.2. And it’s inaccessible to anyone else thanks to the ICS firewall.


Related resources
November 26, 2011 10:47:03 PM

Hopefully the wireless router has not been assigned the same IP address.
November 26, 2011 11:29:46 PM

Probably not, that's why MS uses the 192.168.0.x network rather than the more common 192.168.1.x network found in routers. But even so, it's just a small change to the registry to change the ICS default.

http://support.microsoft.com/kb/230148
November 27, 2011 3:24:20 AM

Thanks for the replies everyone. It seems like it will be an easy enough fix.

I think that I am just going to enable the ICS because then I won't have to install anything. I didn't think about bridging the connections, but right now I don't mind keeping it secret from the other computers on the network.

I wont be home for seven days so I will try it when i get home, but thanks and I will post if I have any other questions.
December 3, 2011 6:33:13 PM

Well, I got it working, but it was more of a stinker than I was hoping.

I couldn't use ICS because my router was the 192.168.0.x network. Then I went to the Microsoft article and tried to change the registry but there were no values for the first folder and I didn't even have the second folder that I needed to change. So I bridged the connections, and that works good because it is still password protected by the Seagate software.

That wasn't that easy though because I kept having an IP address conflict, so I found out my router went from 192.168.0.2-254, so i dropped it down to 230, so my HDD could have the address 192.168.0.231 and then I was able to bridge the connections.

Pretty slick though now that it's working, thanks for the help guys, apprectiate it
December 6, 2011 1:14:55 AM

Best answer selected by snowtrigger.
!