Sign in with
Sign up | Sign in
Your question

Gigabyte HD 7970 OC WF3 heavily underperforming

Last response: in Graphics & Displays
Share
October 16, 2012 6:58:05 AM

Greetings,

as the title says, I'm having some weird issues with this card. I recently bought this card (brand new) to replace Sapphire HD 7850 OC 2GB. Did everything by the book during installation but the new card is performing just slightly better, or in some cases, exactly the same as the previous card. For example, here is my Heaven benchmark score with the new card:





Compared with other HD 7970 card this result is terrible.

In the games like Skyrim, F1 2012, NBA 2K13, MAFIA 2, etc. fps is exactly the same as it was with the previous card. I don't understand why is this happening.

Here are my system specs:

CPU: Intel Core i5-3450 3.1GHz
MBO: MSI Z77A-G43
GPU: Gigabyte HD 7970 OC
HDD: HDD WD 1TB, Caviar Green
RAM: DDR3 8GB (2x4GB) Kingmax, 1333MHz
PSU: Zalman 500-GS
OS: Windows 7 Ultimate 64bit
GPU drivers: 12.8

Any kind of help or advice would be much appreciated, thanks in advance.

(P.S. excuse my bad english)
October 16, 2012 7:13:36 AM

Drivers!!!!

Play around with each version.
October 16, 2012 7:16:36 AM

Thanks for answering,

I've tried them all from 12.4 to 12.8 and nothing changes.
Related resources
October 16, 2012 8:12:41 AM

Hm, I think I didn't do that, I'll take a look, thanks.
October 16, 2012 8:51:58 AM

gran torino said:
Greetings,

as the title says, I'm having some weird issues with this card. I recently bought this card (brand new) to replace Sapphire HD 7850 OC 2GB. Did everything by the book during installation but the new card is performing just slightly better, or in some cases, exactly the same as the previous card. For example, here is my Heaven benchmark score with the new card:

http://i1191.photobucket.com/albums/z471/Ford_Focus_Klub/HB.jpg

http://i1191.photobucket.com/albums/z471/Ford_Focus_Klub/GPU-Z.jpg

Compared with other HD 7970 card this result is terrible.

In the games like Skyrim, F1 2012, NBA 2K13, MAFIA 2, etc. fps is exactly the same as it was with the previous card. I don't understand why is this happening.

Here are my system specs:

CPU: Intel Core i5-3450 3.1GHz
MBO: MSI Z77A-G43
GPU: Gigabyte HD 7970 OC
HDD: HDD WD 1TB, Caviar Green
RAM: DDR3 8GB (2x4GB) Kingmax, 1333MHz
PSU: Zalman 500-GS
OS: Windows 7 Ultimate 64bit
GPU drivers: 12.8

Any kind of help or advice would be much appreciated, thanks in advance.

(P.S. excuse my bad english)


#1 problem, you are using a 1 TB drive. Extremely slow.
The OS and minor apps should be installed on a small fast drive.
Example: 10,000 RPM 2-1/2" 70GB velociraptor.
The games for better operation should also be installed on a small fast drive- separate drive!
The 1TB drive is useful for your personal files, such as music, documents, videos, pictures.
Putting OS, files, apps and games on one 1TB drive- will run slower than a snail.

The OS should never be mixed with your personal files, it needs to run independently.
With separate drives, all that stuff can run without interference from other processes.

You guys are always blaming the video card for basic hardware and configuration problems.
It's not the card at all.
Without processor space, and lots of cache memory, and a fast OS drive, you can expect video or games to run poorly.

It ALL goes through the processor first, before it gets to the video card.
How fast is the drive access? On this system it's really, really slow.

However with some added drives, and reconfiguration, it should work quite a bit better.

Now, when installing all that new stuff, plug all the hardware in.
Then load a fresh win 7 onto the fast drive. That drive will be set to boot first in the bios set up.
When 7 loads, it will detect and properly configure all that hardware.

Then do this drill:
One thing is to make sure that the priority of the game is highest, there maybe other processes running that have priority over the game.
Including for instance security programs and antivirus. The latest of which have gaming modes.
If there is not a gaming mode on the security try turning it OFF.

Another good thing is to eliminate as many unused / junk / UN-needed applications.
turn off the screen saver
Go into the power profiles,
set standby, hibernate and sleep to OFF
leave the monitor standby ON, that's OK (maybe not, try OFF)
Set the Hard Drive standby to NEVER
Set system Performance to MAXIMUM, not "quiet mode."

Open the bios set up and make sure "cool and quiet" is OFF. (AMD)
There may be a performance setting in the bios setup you have...make sure it's cranked up to max.
in the bios, see that the allocation for video, if available, is maxed.

Now open the hardware manager profiles...
click start
click computer
click system properties
click device manager
double click on mice and other pointing devices
right click on HID compliant mouse
left click on properties
click on the power management tab
UN-check the box that says: "allow the computer to turn off this device to save power." (there is now NO check mark in this box)
click OK

Now repeat this procedure for all mice, monitors, keyboards, and ALL USB ports on the device manager list.

You must open ALL the devices one at a time, as above, and turn off the power saver, for each device.

AND I emphasize: you do not need ANY free "fix it" programs from the internet to make your system run correctly. All you need is on the windows disk.
So, avoid those types of downloads.
October 16, 2012 9:09:54 AM

Thanks for your answer.
Just one question: how come all this didn't affect my previous card that much?

If I understood it correctly (amongst else) you are advising me to change HDD? Will then my performance increase significantly?
October 16, 2012 9:44:17 AM

soundguruman said:
#1 problem, you are using a 1 TB drive. Extremely slow.
The OS and minor apps should be installed on a small fast drive.
Example: 10,000 RPM 2-1/2" 70GB velociraptor.
The games for better operation should also be installed on a small fast drive- separate drive!
The 1TB drive is useful for your personal files, such as music, documents, videos, pictures.
Putting OS, files, apps and games on one 1TB drive- will run slower than a snail.

The OS should never be mixed with your personal files, it needs to run independently.
With separate drives, all that stuff can run without interference from other processes.

You guys are always blaming the video card for basic hardware and configuration problems.
It's not the card at all.
Without processor space, and lots of cache memory, and a fast OS drive, you can expect video or games to run poorly.

It ALL goes through the processor first, before it gets to the video card.
How fast is the drive access? On this system it's really, really slow.

However with some added drives, and reconfiguration, it should work quite a bit better.

Now, when installing all that new stuff, plug all the hardware in.
Then load a fresh win 7 onto the fast drive. That drive will be set to boot first in the bios set up.
When 7 loads, it will detect and properly configure all that hardware.

Then do this drill:
One thing is to make sure that the priority of the game is highest, there maybe other processes running that have priority over the game.
Including for instance security programs and antivirus. The latest of which have gaming modes.
If there is not a gaming mode on the security try turning it OFF.

Another good thing is to eliminate as many unused / junk / UN-needed applications.
turn off the screen saver
Go into the power profiles,
set standby, hibernate and sleep to OFF
leave the monitor standby ON, that's OK (maybe not, try OFF)
Set the Hard Drive standby to NEVER
Set system Performance to MAXIMUM, not "quiet mode."

Open the bios set up and make sure "cool and quiet" is OFF. (AMD)
There may be a performance setting in the bios setup you have...make sure it's cranked up to max.
in the bios, see that the allocation for video, if available, is maxed.

Now open the hardware manager profiles...
click start
click computer
click system properties
click device manager
double click on mice and other pointing devices
right click on HID compliant mouse
left click on properties
click on the power management tab
UN-check the box that says: "allow the computer to turn off this device to save power." (there is now NO check mark in this box)
click OK

Now repeat this procedure for all mice, monitors, keyboards, and ALL USB ports on the device manager list.

You must open ALL the devices one at a time, as above, and turn off the power saver, for each device.

AND I emphasize: you do not need ANY free "fix it" programs from the internet to make your system run correctly. All you need is on the windows disk.
So, avoid those types of downloads.

Everything you wrote about HDD is crap.Slower HDD means slow game laoding.It has nothing to do with framerate.As for your problem OP.i am sure your PSU is not good enough for your card.500watt is less.That company is also not a top notch company like corsair,coolermaster when it comes to PSU.And plz OP don't waste your time doing anything the above guy posted.Your problem is PSU.Upgrade to 650 watt or 750.
October 16, 2012 9:46:01 AM

soundguruman said:
#1 problem, you are using a 1 TB drive. Extremely slow.
The OS and minor apps should be installed on a small fast drive.
Example: 10,000 RPM 2-1/2" 70GB velociraptor.
The games for better operation should also be installed on a small fast drive- separate drive!
The 1TB drive is useful for your personal files, such as music, documents, videos, pictures.
Putting OS, files, apps and games on one 1TB drive- will run slower than a snail.

The OS should never be mixed with your personal files, it needs to run independently.
With separate drives, all that stuff can run without interference from other processes.

You guys are always blaming the video card for basic hardware and configuration problems.
It's not the card at all.
Without processor space, and lots of cache memory, and a fast OS drive, you can expect video or games to run poorly.

It ALL goes through the processor first, before it gets to the video card.
How fast is the drive access? On this system it's really, really slow.

However with some added drives, and reconfiguration, it should work quite a bit better.

Now, when installing all that new stuff, plug all the hardware in.
Then load a fresh win 7 onto the fast drive. That drive will be set to boot first in the bios set up.
When 7 loads, it will detect and properly configure all that hardware.

Then do this drill:
One thing is to make sure that the priority of the game is highest, there maybe other processes running that have priority over the game.
Including for instance security programs and antivirus. The latest of which have gaming modes.
If there is not a gaming mode on the security try turning it OFF.

Another good thing is to eliminate as many unused / junk / UN-needed applications.
turn off the screen saver
Go into the power profiles,
set standby, hibernate and sleep to OFF
leave the monitor standby ON, that's OK (maybe not, try OFF)
Set the Hard Drive standby to NEVER
Set system Performance to MAXIMUM, not "quiet mode."

Open the bios set up and make sure "cool and quiet" is OFF. (AMD)
There may be a performance setting in the bios setup you have...make sure it's cranked up to max.
in the bios, see that the allocation for video, if available, is maxed.

Now open the hardware manager profiles...
click start
click computer
click system properties
click device manager
double click on mice and other pointing devices
right click on HID compliant mouse
left click on properties
click on the power management tab
UN-check the box that says: "allow the computer to turn off this device to save power." (there is now NO check mark in this box)
click OK

Now repeat this procedure for all mice, monitors, keyboards, and ALL USB ports on the device manager list.

You must open ALL the devices one at a time, as above, and turn off the power saver, for each device.

AND I emphasize: you do not need ANY free "fix it" programs from the internet to make your system run correctly. All you need is on the windows disk.
So, avoid those types of downloads.

And you should really leave tom hardware.becoz you have zero tech knowledge.
October 16, 2012 9:54:57 AM

cooldudesubho said:
Everything you wrote about HDD is crap.Slower HDD means slow game laoding.It has nothing to do with framerate.As for your problem OP.i am sure your PSU is not good enough for your card.500watt is less.That company is also not a top notch company like corsair,coolermaster when it comes to PSU.And plz OP don't waste your time doing anything the above guy posted.Your problem is PSU.Upgrade to 650 watt or 750.


Thanks. Is there a way to test my PSU (some software)?

Wouldn't the system just shut down if the power supply wasn't enough, instead of resulting poor performance?
October 16, 2012 10:01:31 AM

Yeah it should shut down.But maybe your 7970 is working in low performance mode becoz its getting less amps from your psu.Really hard to tell.Only thing you can do is update your mobo bios to latest one and re-install OS.And not to forget you are using OC version.So more power needed.
October 16, 2012 10:05:54 AM

cooldudesubho said:
Yeah it should shut down.But maybe your 7970 is working in low performance mode becoz its getting less amps from your psu.Really hard to tell.


How can i check that? I'am using GPU-Z, OC GURU II and Sapphire Trixx to monitor my card.
October 16, 2012 10:11:51 AM

See in sensors if it is full clocked up when running heavens.
October 16, 2012 10:15:49 AM

Sorry I don't understand, what sensors?
October 17, 2012 6:25:11 AM

Ok, here is some feedback.



I tried beta drivers - no change.

suat said:
Have you installed the missing DX components that do not install by default when you install Windows 7 ? http://www.microsoft.com/en-us/download/details.aspx?id...


Looked for this and found out that I got it installed already.

Monitored my card with several programs and everything seems fine, but poor performance remains.

Any other suggestions? Thank you.

October 17, 2012 7:45:16 AM

gran torino said:

Monitored my card with several programs and everything seems fine, but poor performance remains.


You mean you monitored your cards clocks and temps while running the benchmark to check that everything is normal?
Have you checked the temps and clock speed of your cpu while benchmarking too?

The interesting thing is that what you describe - moving to a move powerful GPU and not gaining any performance gains - sounds just like a CPU bottleneck, though there shouldn't be much of a bottleneck with your current cpu.

What happens if you run the benchmark at a lower resolution?
October 17, 2012 9:29:08 AM

cobot said:
You mean you monitored your cards clocks and temps while running the benchmark to check that everything is normal?
Have you checked the temps and clock speed of your cpu while benchmarking too?

The interesting thing is that what you describe - moving to a move powerful GPU and not gaining any performance gains - sounds just like a CPU bottleneck, though there shouldn't be much of a bottleneck with your current cpu.


Yes, and everything seems to be OK CPU/GPU related.
Just monitored GPU usage while using Heaven Benchmark and it's 99 %. This is very confusing to me because my GPU usage with the previus card (HD 7850) while benchmarking was 70 - 80 %.

cobot said:
What happens if you run the benchmark at a lower resolution?


Didn't try that, 1680X1050 is the lowest I have tried so far. I have DELL U2412M 1920X1200 monitor and when I try to benchmark using that setting results are catastrophically poor.

@suat
Thanks, I will try that too.
October 17, 2012 9:38:37 AM

suat said:
Install Kombustor: http://www.geeks3d.com/20120423/msi-kombustor-2-3-0-dow...

Install: http://www.cpuid.com/softwares/hwmonitor.html

Run Kombustor and perform a Burn-in test while observing Volatges and Tempearture with HWMonitor.

All voltages should be within +/- 5% tolerances, namely, 12 V should be between 11.4 V and 12.6 V, etc.

All temperatures should be within your components specified values.


Hmm, just tried MSI kombuster and temperatures run terribly high and after a while I get a black screen on monitor but the computer keeps working (card fans get very nosiy and continue to work) and all I can do is reset it.
October 17, 2012 12:08:10 PM

Did you run Kombustor in a window or full screen ? Why did you not run Hardware monitor to check for voltages along with temperatures ?

Hardware monitor records min and max voltages and temperatures. You see min and max values so that you know if a parameter is out of tolerance.
October 17, 2012 12:42:35 PM

I run it in a full window. I will try hardware monitor and report results here.
October 17, 2012 1:18:23 PM

Run Kombustor in windowed mode and observe voltages and temperatures with HWMonitor. Place the two windows side by side. If you use full screen and have a shutdown suddenly, you cannot see if voltages are out of range and temps too high.

EDIT: Your gfx card OCed version requires 550 W PSU, whereas yours is 500 W only. http://www.thermaltake.outervision.com/Power
October 17, 2012 3:49:13 PM

When you run Kombustor full screen, it works. In windowed mode, it doesn't. Is this what you are saying ?
October 17, 2012 3:58:38 PM

No, I tried Kombuster only in window mode, (apologize) I have mistaken Kombuster with Furmark which I have been running the first time and there I'am getting black screen.
October 17, 2012 4:39:27 PM

I strongly advise you to use HWMonitor and note the min and max voltages and temps while running furmark or whatever. Uninstall and then re-install Kombustor and then run Burn-in test along, monitoring voltages and temps.
!