Sign in with
Sign up | Sign in
Your question

New homebuilt computer not displaying

Last response: in Systems
Share
December 6, 2012 1:08:10 PM

Hi! I just built my first computer and although it powers on it isn't displaying on the monitor. It may or may not be giving USB power, also.

Components:
Antec Three Hundred ATX Mid Tower Gaming Computer Case
AMD Phenom II X4 965 AM3 3.4Ghz 512KB 45NM 125W 4000MHZ
Crucial 128 GB m4 2.5-Inch Solid State Drive SATA 6Gb/s CT128M4SSD2
Crucial Ballistix Sport 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800) Desktop Memory Model BLS2KIT4G3
VisionTek 900371 Radeon HD 6450 1GB DDR3 PCI Express 2.1 x16 HDCP Ready Low Profile Ready Video Card
COOLER MASTER GX 450W RS450-ACAAD3-US 450W ATX12V v2.31 80 PLUS BRONZE Certified Active PFC Power Supply
ASUS M4N98TD EVO ATX AMD Motherboard

When I power on the machine, the case fans receive power through the motherboard. The ram works in another machine, and the video card works in that other machine as well. I'm also using the same monitor and video cables with the known working computer. I've tried moving the ram and the video card. I've checked the CPU for damage. I don't know what else to try.
December 6, 2012 3:02:04 PM

Thank you guys! The answer was I hadn't plugged in the CPU power. I'm sorry I missed the sticky note; I'm on a tiny computer at the moment and I got frustrated with searching.
m
0
l
a b B Homebuilt system
December 6, 2012 4:14:42 PM

im glad you have figured it out, happy gaming
m
0
l
!