Sign in with
Sign up | Sign in
Your question

AMD Radeon 7670m Problem

Last response: in Graphics & Displays
Share
October 24, 2012 9:44:14 AM

Hi.. I have Dell Inspiron 5520 with switchable graphics Intel HD 4000 and AMD Radeon HD 7670m. For few games like Batman Arkham City, it works well. But for other Games like The Witcher II and Max Payne III my laptop uses Intel graphics card rather than AMD GPU even if i select high performance from AMD control catalyst control panel.Consequently, these games runs at very low frame rate. Can someone help me in this regard???
October 24, 2012 11:49:55 AM

There's some stuff that you can try below...
But the reality is that laptops are not actually engineered for games. This computer is rated a little less useable than many other laptops. It just does not have the resources for the video to play taxing games.
So no matter what you do, it won't come up to the level of a real gaming machine.
HINT: Don't take advertising or user reviews as truth.

One thing is to make sure that the priority of the game is highest, there maybe other processes running that have priority over the game.
Including for instance security programs and antivirus. The latest of which have gaming modes.
If there is not a gaming mode on the security try turning it OFF.

Another good thing is to eliminate as many unused / junk / UN-needed applications.
turn off the screen saver
Go into the power profiles,
set standby, hibernate and sleep to OFF
leave the monitor standby ON, that's OK (maybe not, try OFF)
Set the Hard Drive standby to NEVER
Set system Performance to MAXIMUM, not "quiet mode."

Open the bios set up and make sure "cool and quiet" is OFF. (AMD)
There may be a performance setting in the bios setup you have...make sure it's cranked up to max.
in the bios, see that the allocation for video, if available, is maxed.

Now open the hardware manager profiles...
click start
click computer
click system properties
click device manager
double click on mice and other pointing devices
right click on HID compliant mouse
left click on properties
click on the power management tab
UN-check the box that says: "allow the computer to turn off this device to save power." (there is now NO check mark in this box)
click OK

Now repeat this procedure for all mice, monitors, keyboards, and ALL USB ports on the device manager list.

You must open ALL the devices one at a time, as above, and turn off the power saver, for each device.
October 25, 2012 4:13:22 PM

That's all right but my question is still there. Let's be specific..

As I have mentioned earlier that may laptop runs some graphically very high demanding games like Metro 2033 & Batman Arkham city pretty well because of the use of AMD GPU.

But few games like The Withcer II & Assassin's Creed Revelation don't use AMD. Instead they use Intel HD 4000 graphics card. I am sure about this because of two reasons:

1. When I am Playing Batman A.City, the frame rate decreases as I unplug AC power because my settings are set for power saving on battery and high performance on AC power. But When I play Assassin's Creed, frame rates do not change while unplugging AC power. It clearly means that AMD is not being used in this game even if high performance settings are assigned to this game by using AMD control panel.

2. When i go to AMD control panel and select game like Batman A.City & Metro 2033 etc, it automatically selects "High Performance". But when I select Assassin's Creed & The Witcher II etc, it shows "Not Assigned". Even if I change it to "High Performance", the panel again shows "Not Assigned" when I quit game after playing it.

Hope you have got my point..

I need help in this regard.

Thanks.
Related resources
November 5, 2012 7:29:11 PM

Is it possible that those games don't support your current graphics configuration?
My setup is the same, but with two radeon cards and only some games are capable of taking advantage of the better card. It doesn't even matter what version of Directx it uses.
Although I suspect that I have driver issues and most of the amd provided drivers don't work properly. At least the new catalyst wont recognize them and terminate the CCC program.
It sucks most wanted 2 only uses the integrated card,and it only runs smooth at lower than medium settings:( 
Where did you get your drivers?
Plus I don't get to set "high performance" anywhere. Do you set application profiles? Everytime I try to set a game up with a 3d profile it doesn't show up afterwards.
November 8, 2012 3:11:30 AM

Settings profiles using AMD control panel is also proved to be useless. I am facing the same problems which you mentioned but still looking for the solution...
September 6, 2013 10:13:14 PM

skycheerful said:
Hi.. I have Dell Inspiron 5520 with switchable graphics Intel HD 4000 and AMD Radeon HD 7670m. For few games like Batman Arkham City, it works well. But for other Games like The Witcher II and Max Payne III my laptop uses Intel graphics card rather than AMD GPU even if i select high performance from AMD control catalyst control panel.Consequently, these games runs at very low frame rate. Can someone help me in this regard???


Hi
I had the same problem with my Inspiron 5520 ... it has a built-in Intel 4000 HD graphics card and AMD radeon 7270M
at first I thought that the problem occurred bcuz I updated the bios From V A11 to v A13
I tried reinstalling AMD driver many times but it didn't work then I found a new bios update V A14 on dell.com ..I installed the new up date but It didn't work
then I started messing around with CCC and I did something that solved the problem for me and it was so simple

here's what I did :

- right click on ur desktop >
- configure switchable graphics (this will Open CCC )
- on the left side click on Power ( If u don't see it Go to preferences and chose the advanced view)
- n then check the option "Enable powerplay
- n then press apply
- n that did it for me and now I can play my games with no problems

if it didn't work try updating ur bios n make sure ur laptop is plugged in when you want to start a game
I hope this will solve ur problem n sorry for my bad English
!