Sign in with
Sign up | Sign in
Your question

ASRock Z77 Extreme 4 Boot Problems

Tags:
  • New Build
  • BIOS
  • Boot
  • ASrock
  • Systems
Last response: in Systems
Share
December 13, 2012 12:06:32 PM

Hi everyone,

I just recently upgraded my mobo to an ASRock Z77, however on cold boots the bios asks me to "please select proper boot device". This comes up every time I boot the computer. If I enter the UEFI with F2 or Del then save and exit, (without changing any settings), the bios proceeds to windows and boots perfectly.

I have two boot devices plugged in. My SSD, which I use as the primary boot, and a HDD, which I use as a back-up and storage. I've tried disabling the HDD in the UEFI but the issue still occurs.

Any ideas/suggestions would be most appreciated.

More about : asrock z77 extreme boot problems

December 13, 2012 12:13:32 PM

In your BIOS you need to configure the boot order. Optical-SSD-etc.
m
0
l
December 13, 2012 12:22:11 PM

If by boot order you mean boot priorities then, my boot priority #1 is my SSD, #2 used to be my optical drive but I disabled that in an attempt to fix the issue.

If there's a boot order option somewhere, I can't find it, could you point me in the right direction?
m
0
l
Related resources
December 13, 2012 12:26:04 PM

Unfortunately I am at work and can't look at my BIOS (I have the same board, just micro atx). Boot Priority is correct though. Like I said, it should be optical-SSD. Make sure you are using the correct SATA ports to (the ones connected to the Intel chip). I will try and post back to you after work when I can dig into my BIOS.
m
0
l
!